6320 Powerquad Transmission Issue
Results 1 to 5 of 5
Like Tree2Likes
  • 2 Post By Deere6320

Thread: 6320 Powerquad Transmission Issue

  1. Top | #1

    Join Date
    Mar 2017
    Last Online
    06-18-2017 @ 08:20 AM
    Location
    North Carolina
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    6320 Powerquad Transmission Issue

    New to the forum...I have a 6320 with a power quad transmission. The shuttle shift will not engage forward or reverse nor will the power quad shift with the shift buttons on the manual gear shifter. Checked all fuses in the fuse panel, all are good. All connectors under the tractor on the transmission are connected. I do not have a TSM to try and trace what might be breaking the connection. Does anyone have any ideas? The tractor runs, hydraulics work correctly on load and 3-point hitch. Manual says if caution light only flashes, there is a malfuntion with the transmission electrical system.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Oct 2014
    Last Online
    Yesterday @ 02:50 PM
    Location
    Coyote Flats,Texas
    Posts
    1,745
    Thanks
    15
    Thanked 299 Times in 269 Posts
    Welcome to GTT
    Sorry I can't help you with your tractors problem but I will guess a faulty relay. All those electric controlled devices are nice until they quit operating correctly. Being as I'm old & set in my ways I prefer manual trans & hyd controlled functions because when the cable breaks I can locate that problem.

  4. Top | #3

    Join Date
    Mar 2017
    Last Online
    06-18-2017 @ 08:20 AM
    Location
    North Carolina
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I agree......JD makes it hard for the common man to diagnose problems.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Jan 2011
    Last Online
    11-07-2019 @ 08:15 PM
    Location
    Maryland
    Posts
    889
    Thanks
    5
    Thanked 315 Times in 240 Posts
    Do you have an operators manual? If so, look up procedure to check for error codes. There are many possible reasons for the symptoms you have. Possible left hand reverser lever bad, sensor bad. shift solenoid bad, controller bad, broken wire, etc. Without an error code to point you in right direction, It is only a guessing game. Look under section 130 for diagnostic trouble codes.

  7. The Following User Says Thank You to jd110 For This Useful Post:

    Deere6320 (03-18-2017)

  8. Top | #5

    Join Date
    Mar 2017
    Last Online
    06-18-2017 @ 08:20 AM
    Location
    North Carolina
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks for the information jd110. Just stoppped by to update everyone that I found the issue. I was able to to clear the codes using the method in the manual. After that only one code kept repeating. EPC code 306055.31. After a quick search on the net i checked the "Return to home fuse". It was oriented in the fuse panel incorrectly. Turned it around and all is well. What's weird is, it doesn't "feel" like it is inserted correctly. It is loose to the touch. Not sure my tractor requires this fuse but at this point I'm leaving it be.

    My thoughts on this experience. Not to pleased with the limited ability the user has to trouble shoot the electrical system. JD has a lock on the ability to work on their equipment forcing the user to go to the dealer and pay what I believe are high service fees. Technical service manuals are over priced. Not sure if this is a JD thing or the way at which all tractors are going. I would recommend anyone looking for a new tractor to go as mechanical as possible, if you rather work on it yourself and not rely on paying a dealer a high price to tell you it requires a $20 part to get back running. Common sense stuff I know. Hope this helps someone down the road.



    Quote Originally Posted by jd110 View Post
    Do you have an operators manual? If so, look up procedure to check for error codes. There are many possible reasons for the symptoms you have. Possible left hand reverser lever bad, sensor bad. shift solenoid bad, controller bad, broken wire, etc. Without an error code to point you in right direction, It is only a guessing game. Look under section 130 for diagnostic trouble codes.
    BigJim55 and Tx Jim like this.

  9. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •