Is it more like my tranny pump failing, or bad 3pt lift seals?
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Like Tree4Likes

Thread: Is it more like my tranny pump failing, or bad 3pt lift seals?

  1. Top | #1

    Join Date
    Apr 2017
    Last Online
    04-10-2017 @ 07:47 PM
    Location
    Orlando, FL
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Is it more like my tranny pump failing, or bad 3pt lift seals?

    I just acquired a used 1979 2040 with 145 loader and 6ft box blade. The tractor shows under 1500 hours, and seems to run perfect (no black or white smoke at all, does run hot, all gears and pto work great, no leaks) but I quickly discovered several things. First issue was that the crank case was way overfilled (turned out to be diesel fuel). Second issue, when you turn the motor off the box blade drops to the ground like a rock (I have never seen this on any of my other tractors, but had a Kubota with a clogged filter that stopped lifting when the oil was hot). Third issue, it takes 20 seconds or so for the 3pt lift or loader to work properly (I'm assuming tranny pump has to build pressure). And the fourth issue is that once the clutch is pushed down the loader only works for about 20-30 seconds.
    I quickly ordered and installed a new lift pump and did an oil change and of course a new fuel filter, and I have already read up enough to know that with the clutch pushed my tranny pump stops turning so it does not prime the front pump for the loader hence the dead loader when the clutch is in. This brings me to the more difficult to figure out problems which could be one and the same. Since I have never worked on this type of tractor with hydraulic brakes and hydraulic steering I am not 100% sure I can assume anything, but since I have yet to experience a loss in steering or brakes, perhaps my tranny pump is still in decent shape. That brings me to the question of what seal/check valve is it that should be keeping the 3pt lift up and if that is totally gone would it cause the initial delay in hydraulic function from cold start.
    I have yet to run this tractor for more than 30 minutes as I have been fixing little stuff, the voltage reg was dead, tach is jumping so it needs a new cable, topped off the tranny oil, replaced a broken flashing light, etc. etc. But I have done a lot of testing of the loader, and I'm getting ready for my first time pulling a 6ft finish mower around my back 4 acres. I have also read about checking certain spots on the tranny to see if there is excessive head which indicates a high pressure hydraulic leak, and I can not say for sure if that won't happen during extended operation.
    I'm hoping this is an easy fix and perhaps someone on the forum has good news for me, so thanks in advance,
    -Dave
    BigJim55 likes this.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    Mar524ak's Avatar
    Join Date
    Nov 2016
    Last Online
    11-13-2019 @ 01:48 PM
    Location
    Amarillo tx
    Posts
    524
    Thanks
    17
    Thanked 77 Times in 55 Posts
    If you did a flow test in hydraulic pump it probably would fail. Sounds like hydraulic pump is pretty weak. Try adjusting 3 point it might help. When you push clutch in your steering probably goes away too in assuming? I've messed with a few of these and it's always the pump. There should be a way to adjust the flow of the pump in the bottom.


    Sent from my iPhone using Tapatalk Pro

  4. Top | #3

    Join Date
    Oct 2014
    Last Online
    Today @ 05:55 PM
    Location
    Coyote Flats,Texas
    Posts
    1,748
    Thanks
    15
    Thanked 299 Times in 269 Posts
    Welcome to GTT
    I need a couple of questions answered to correctly give assistance. Does your tractor have a 3 or 4 cyl engine? If 3 cyl engine is serial number below or above 266750. Below this SN has open center hyd & above has closed center hyd's. With engine running,3 pt raised look in hyd filler hole behind seat for moving oil which would indicate blown rockshaft control valve seals or leaking RS piston seal. Have you changed setting of L/D lever under seat when operating 3 pt? IIRC trans pump is powered by pto drive shaft not trans input shaft. What type valve controls loader & how is valve plumbed to hyd system?
    Last edited by Tx Jim; 04-04-2017 at 08:36 AM.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Apr 2017
    Last Online
    04-10-2017 @ 07:47 PM
    Location
    Orlando, FL
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks to you both for giving me some info to work with, It is a 3 cylinder, and the serial number is 336297. I have not touched the L/D lever under the seat yet, and will certainly put the lift up and look in the fill hole to see if there is oil leaking from the rocker shaft (I have a decent bore scope camera as well) . I have not owned and therefore seldom operated a dual clutch tractor before, so it is nice to know by only pushing the pedal a little the pump will keep working off the PTO shaft.
    I got the tractor warmed up for 10 minutes while I added some fuel before I used the finish mower today, then I kept the tractor under load for about 45 minutes before deciding to re-grease the spindles on the mower. The lift worked fine after mowing and lifted the quite heavy 6ft finish mower with no noticeable issues. I did forget the shoot around the tranny with my IR temp gun, and by the time I was done greasing the mower it started raining.
    I hope this lift issue is something that will not require working on the pump, but I have some experience with "cylinder and piston" style hydraulic pumps with valve plates so I am not overly concerned about repairing the rotary style pump. For one thing it is still working and most likely has not gotten badly scored or worn out, there do appear to be a lot of o-rings though so I'm guessing as they get hard the performance goes to heck. What is the story on the hydraulic bypass valve at the filter? Does this machine have anything like that, and it could it be causing my problem?
    Splitting the tractor is my big "I don't wanna" but mostly because I will need to get some repair instructions as to how to extract the pump from the tranny.. Having rebuilt a handful of large automatic overdrive trannys from cars and trucks, and also having repaired several manual shift transmissions as well, I'm sure this will not be too difficult for me if it comes down to that.
    I had to tear down the hydraulic control valves on my Yanmar 2700 after replacing the hydraulic pump that had sheared the primary shaft when the roll pin gave way and piece got in the pump. Apparently a tiny sliver of metal made its way to the control valves and stuck one valve piston so even after getting a nice used replacement pump and putting it on, the lift was still dead. Pulling that control block off was a last ditch "I sure hope I find the problem" effort after checking everything else that I could get to.
    Since I do not see the same design on this tractor I am not sure where everything is, but with a good diagram and your help I know I can figure this out and have it working like new.

  7. Top | #5
    Drifterbike's Avatar
    Join Date
    Jul 2015
    Last Online
    Today @ 10:40 AM
    Location
    Hampton Ill
    Posts
    2,721
    Thanks
    1,086
    Thanked 318 Times in 279 Posts
    A few years back i had simular problems with my 3 cly 1020 Gas. I had water in my hydro fluid that leaked in thruogh cracked gear shift boots. after two flush and fills still had hydro problems, Hicth running slow and failing, and just poor pto responce. What it was the sump screen was plugged. If you have one check it. once we cleaned it its been fine since. Good Luck
    2018 2038R 220R FEL, 72" Mower, Radial tires, wheel spacers, dual rear SVCs, CtA grapple, single point for FEL, 60" broom with front hitch;2018 1025R 54"auto connect, HDAP tires, Quick Hitch, Ballast Box, Etc...;1967 1020 3cylinder gas, #47 FEL, 72" Landpride Grooming Mower, 6ft box blade, For Sale(no Hurry); life Member NRA since 1974

  8. Top | #6

    Join Date
    Oct 2014
    Last Online
    Today @ 05:55 PM
    Location
    Coyote Flats,Texas
    Posts
    1,748
    Thanks
    15
    Thanked 299 Times in 269 Posts
    OK serial number establishes that your tractor has closed center hyd's. The hyd filter relief valve is in frt of the hyd filter and can be checked by removing a plug to access the valve. What type valve controls loader(ind or scv)? Next time you have tractor warmed up aim laser thermometer at the steering valve under steering wheel.

  9. Top | #7

    Join Date
    Apr 2017
    Last Online
    04-10-2017 @ 07:47 PM
    Location
    Orlando, FL
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I will be doing the screens soon Drifterbike, just because the tractor is new to me and I have no idea when or if they have been cleaned before. Tx Jim, I opened up the fill with the "lift up engine running", and there is no blow by at the rocker shaft piston seal. I used the bore scope to look around a bit and because this video camera has a bright little light right by the camera I could see a fine mist was in the air inside the housing. Next I pushed the clutch half way and tested the loader and watched the lift and everything worked perfect, and the lift stayed up, 20 seconds after pushing the clutch all the way in however, and the lift starts to drop. I had only had it running for a few minutes, but put my hand down where the control lever shaft is located and noticed it was just above ambient temp, and I also saw the plugs that seal the control valve bores, so now I know where they are. I also finally looked around and saw the plate metal tab that sets the lift to one of four positions: top is "D" second down is 1/2 way between D and LD, third is LD, and fourth is L. It was in the half way between hole, so when I moved the tab down to L and shut off the motor the mower went down but it took 10-15 seconds so it was much slower than before. I still need to read up on adjusting the control/adjustment that is directly below the front of the seat on top of the rocker cover, but maybe this new info indicates a leak in a valve seal somewhere since the pump was not part of the equation and yet drift vs lift position made a significant difference in the lift bleed down.

  10. Top | #8

    Join Date
    Apr 2017
    Last Online
    04-10-2017 @ 07:47 PM
    Location
    Orlando, FL
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks again Jim, I'm not sure how to identify the type of loader controls, but they appear to be factory JD (I'll figure out how to add pics in a day or so), the two hoses to and from the loader attach below the foot rest directly without any T fittings, one connects in front of the right side of the filter housing (is this where the relief valve is?), and the other hose connects to the right side rear of a different housing that is just behind the filter housing. There is a steel hydraulic line coming out of the front of that housing that either goes to the power steering, or may run up to the front pump. I'm not 100% sure that the front one is the return fluid since it comes from the loader controls, but since the other one connects to the same housing that supplies fluid via a hard line, I'm guessing that means high pressure fluid. I know I need a manual and have done a quick search for any instructions for the various controls and adjustments to no avail, so I still do not know for sure if the one directly on top of the rocker cover is a "lock", or if it adjusts the speed of the lift (it moved freely both clockwise and counterclockwise about 1 full turn.
    I don't generally just start playing with adjustments to see what happens, and was even warned while working on my first Kubota that you can dead head the hydraulic pump and damage it if you close the valve that locks the lift while the motor is running.

    I have considered putting the lift way up and standing with my hand on that valve, and spinning it clockwise as quickly as possible after shutting the motor off to see if it is a lift lock.

    I had worked many years as an automotive technician, and for the last 10 years have been mostly a Marine mechanic, so I am not a tractor mechanic by trade. That being said, I have owned and repaired 6 various tractors in the last 20 years, and have no fear of doing something for the first time (I pulled and repaired the tandem hydraulic tranny from my Case 1845 Skidsteer a year ago).

  11. Top | #9

    Join Date
    Jan 2011
    Last Online
    Today @ 09:21 PM
    Location
    Maryland
    Posts
    890
    Thanks
    5
    Thanked 315 Times in 240 Posts
    The adjustment on top of the rockshaft housing is the rate of drop valve. the further you turn it in, the slower it will lower. If turned all the way in, it should not go down at all if piston seal is good. You can turn it all the way in while running without fear of damages. The mist you see in the fill hole is the orings on the rockshaft control valves leaking. You need to removed the rockshaft housing and then remove the cylinder/control valve housing from the underside of it to replace the orings. Orings #5, 6, and 7 are the likely problems, but I would replace all orings and seals while you have it a part. This could be all of your hydraulic problems, but I would still clean the sump screen, check the filter relief valve, and check steering column for heat indicating leaking orings there as well. SOme pictures of the loader valve and its connections to the tractor will verify correct plumbing there.
    Attached Thumbnails Attached Thumbnails RWP1755________UN01JAN94.jpg  

  12. Top | #10

    Join Date
    Apr 2017
    Last Online
    04-10-2017 @ 07:47 PM
    Location
    Orlando, FL
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks jd110, I had seen that diagram somewhere when I was looking for pics with Identification of the valve on top, but it did not show the "drop speed" control valve. I guess it will not hurt to run a test to see if the lift stays up with the valve closed just to confirm that the piston seal is good, then again, once I have it off I am the kind of mechanic that would change the piston seal just as a precaution as I will hopefully be keeping this tractor for a long time (it is so much more powerful and easier to operate than my Kubota L series with manual steering and brakes).
    I had to open the top of my Yanmar to repair a broken PTO shifter it had when I first got it (that tractor had all kinds of little issues that I took care of over the course of about 6 months).

    As far as this 2040 goes, the nice old guy I bought it from did tell me about it having a crankcase full of fuel that he assumed it was something very costly to repair, so he had parked it in the barn over a year ago. I suspected it was something simple, and with a fresh battery it started right up (decent compression, and injection pump and injectors worked) and ran without knocking and even full of fuel it did not smoke (rings and pistons probably not damaged). He said he had owned it for 15 years but due to health reasons no longer needed it and did not want to spend a ton of money getting it fixed just to sell it. I did not know about the lift going down (we loaded it up with nothing on the back) so I never asked about it. When we fired up with the fuel in the oil I was in a hurry to load it and shut it back off but the loader did not respond for the better part of a minute, and he was very surprised. I revved it up a bit and eventually it worked just fine, when I asked him, he said it had always had the loader on it and he had never had any hydraulic issues. Finding the tranny oil was way low and knowing it has been sitting a long time I figured the pump had lost prime, but to be honest anything could have happened before I showed up.

    At this point I will start by finding the housing gasket, valve o-rings, piston seal/seals, and anything else that may be needed regarding the screen, filter and relief valve. I'll take pics of the loader control valve and hopefully it will have a tag somewhere I can get too. I will also take pics of how the hoses attach to the transmission. There is a very slow drip on the front one and it has a quick release so I need to check that out anyway. This tractor was parked in a barn, not left out in the weather so the oil in the tranny looked like new, as does in insides of the rocker shaft area, but it took about 2 gals to get it to the full mark on the dip stick. I hate to speculate, but it is possible some hoses had to be changed and the lost oil was not replaced, but who knows.
    BigJim55 likes this.

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •