JD7420 transmission speed low
Results 1 to 7 of 7
Like Tree4Likes
  • 2 Post By jd110
  • 1 Post By criv
  • 1 Post By jd110

Thread: JD7420 transmission speed low

  1. Top | #1

    Join Date
    Apr 2018
    Last Online
    09-01-2019 @ 06:39 AM
    Location
    Southeast
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts

    JD7420 transmission speed low

    Friend has a jd 7420 powerquad with code epc 306061.31 transmission speed too low. We replaced RE 12182 wheel speed sensor but the problem remains. Can anyone tell me what the RE 295932 sensor also mounted on powerquad drive system does? It's mounted next to the wheel speed sensor but I can not find any info of it's function.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    johnH123's Avatar
    Join Date
    Feb 2015
    Last Online
    Today @ 12:19 PM
    Location
    Indiana
    Posts
    4,405
    Thanks
    464
    Thanked 329 Times in 277 Posts
    I have no idea, but if you can't find an answer here, ask This guy on youtube. He definitely knows what he's talking about.
    - 2002 John Deere 4510 TLB PR,
    -Woods BB60X 60" rotary cutter
    -Countyline box blade,
    -Allis Chalmers sickle mower,
    -RED windrow rake,
    -titan 48" 3000 pound forks/bale spear
    - Farm Star rear bale spear

    Yamaha Rhino 700, Yamaha Rhino 660,
    Murray 624 mower/38" deck

  4. Top | #3

    Join Date
    Jan 2011
    Last Online
    Yesterday @ 09:16 PM
    Location
    Maryland
    Posts
    889
    Thanks
    5
    Thanked 315 Times in 240 Posts
    The RE 295932 is the transmission shaft speed sensor.. The Re12182 is the wheel speed sensor. THe code you have is related to the transmission shaft speed and not wheel speed. If you know how, access epc14 and then start tractor and run in 4th gear. epc14 monitors the transmission shaft speed and in 4th gear, it should match engine speed.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Apr 2018
    Last Online
    09-01-2019 @ 06:39 AM
    Location
    Southeast
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    JD110, Thank you for the response. I can get to the epc and see the codes and addresses how ever do not see a 14. Could you enlighten me on how to get to epc 14? His tractor has the dual gauge plus II digital display without HMS.

  7. Top | #5

    Join Date
    Jan 2011
    Last Online
    Yesterday @ 09:16 PM
    Location
    Maryland
    Posts
    889
    Thanks
    5
    Thanked 315 Times in 240 Posts
    Some addresses are not available in "customer mode". If accessing "technician mode" you have to be careful because some addresses can be changed that affect how things work or can make things not work at all. Instead of waiting at least 4 seconds after turning ignition on to activate roll mode switch, you need to activate roll mode switch before turning key. When dIA is displayed, release roll mode switch and then other addresses should be accessible.

  8. The Following User Says Thank You to jd110 For This Useful Post:

    criv (04-02-2018)

  9. Top | #6

    Join Date
    Apr 2018
    Last Online
    09-01-2019 @ 06:39 AM
    Location
    Southeast
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I should have stated the symptoms from the tractor when starting this thread in case it may help someone in the future.When putting in forward or reverse it would return to neutral after 10-15 seconds with code epc 306061.31 which was transmission speed too low. After jd110 told which was the transmission speed sensor we replaced it and the tractor is running well again. Thank you jd110. By the way, I entered the diagnostics by holding the roll mode lever and turning the key to on but still could not access epc 14. I really would have liked to see the transmission speed to check the sensor before changing the part, but it all worked out.
    Georgia_Johndeere likes this.

  10. Top | #7

    Join Date
    Jan 2011
    Last Online
    Yesterday @ 09:16 PM
    Location
    Maryland
    Posts
    889
    Thanks
    5
    Thanked 315 Times in 240 Posts
    Glad to hear you got it going. Accessing technician mode can be finicky. It may be you didn't actually access it. I have tried multiple times to get access sometimes. Also a possibility a software update may be required to activate certain addresses. Your friend could get his dealer to update to newest software if he wants. The BCU software and EPC software needs to be updated together, and then transmission needs recalibration as well as the hitch. He can expect to pay 2 or 3 hours labor to have it done unfortunately.
    Georgia_Johndeere likes this.

  11. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •