John Deere 8450 power loss
Results 1 to 3 of 3

Thread: John Deere 8450 power loss

  1. Top | #1

    Join Date
    Sep 2013
    Last Online
    04-12-2019 @ 12:37 PM
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    John Deere 8450 power loss

    It works good from start up for about 10 min then it loses power and smokes a lot. There is a whistling noise from the first gasket after the turbo. The turbo has been replaced. Any suggestions would be appreciated.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Oct 2014
    Last Online
    Yesterday @ 05:55 PM
    Location
    Coyote Flats,Texas
    Posts
    1,748
    Thanks
    15
    Thanked 299 Times in 269 Posts
    I suggest to check for good fuel flow from tank to inj pump. Is fuel tank venting?

  4. Top | #3

    Join Date
    Oct 2018
    Last Online
    10-13-2018 @ 09:27 PM
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It's very simple. Had the exact same problem and symptoms on my 8410 tractor. The air coming of of the turbo going into the motor is leaking out somewhere (whistling sound). Fix the leak and your problem will be solved. Chances are there was nothing wrong with turbo. Good luck.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •