6420 not warming up to operating temp
Results 1 to 6 of 6
Like Tree5Likes
  • 3 Post By bcbrouwer
  • 1 Post By rtgt
  • 1 Post By Old Machinist

Thread: 6420 not warming up to operating temp

  1. Top | #1

    Join Date
    Jun 2012
    Last Online
    10-04-2019 @ 06:24 PM
    Location
    canada
    Posts
    49
    Thanks
    5
    Thanked 4 Times in 4 Posts

    6420 not warming up to operating temp

    As the title says my 6420 will not get up to operating temperature (180 degrees). Ive used my ir digital thermometer (with new batteries) to verify my heat gauge is accurate and the temp tops out at 120 degrees on the top rad hose, and 105 on the bottom after running hard for a half hour, so my sensor and gauge are fine. I realize the first thing most people will think is faulty thermostats, so Ive already replaced both the engine and low temp side thermostats, and have the same temperatures. This is a new to me tractor but my other 6320 and 7320 both get up 170-180 degrees so its definitely not a normal characteristic of this machine. Not sure where else to go other than replacing the viscous fan clutch, but wow they are a lot of $ just to test it out. Also it doesn't seem to be kicking out too much air compared to what they are capable of. Any other ideas? Also replaced coolant with new and bled the system. heater works fine but but not real hot, obviously. I repair most of my own stuff but this is an odd one to me, still scratching my head.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Jun 2012
    Last Online
    10-04-2019 @ 06:24 PM
    Location
    canada
    Posts
    49
    Thanks
    5
    Thanked 4 Times in 4 Posts
    Found the problem for anyone else who may want to know for future. Fan clutch locks up once its started and drives full air flow all the time. usually when they fail they spin slow and tractor overheats but this is opposite. compared side by side with my 6320. new clutch on order.. but not from deere, they want $760 cad! fawcett tractor in ontario $395 plus shipping. still a lot for what it is.
    rtgt, BigJim55 and PJR832 like this.

  4. Top | #3
    rtgt's Avatar
    Join Date
    May 2013
    Last Online
    Yesterday @ 11:59 PM
    Location
    Kentucky
    Posts
    6,778
    Thanks
    1,832
    Thanked 1,212 Times in 863 Posts
    Glad that you found the problem.

    Thanks for posting the fix.
    BigJim55 likes this.
    Taking the easy way is what makes rivers and men crooked.

    3039R, H160 FEL, 375A Backhoe, Artillian Grapple & Forks
    Z915E
    XUV560

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Feb 2019
    Last Online
    Today @ 06:16 PM
    Location
    N. FL
    Posts
    187
    Thanks
    4
    Thanked 30 Times in 26 Posts
    That is an odd one. Please report back after the new fan clutch is installed to verify the fix.

    Back in the day we just had fixed blade fans. Then came the flex blade fan and finally the viscous clutch. The purpose of the viscous clutch was to reduce noise and increase power. Not so much to regulate temperature I don't think.

    It would seem to me a properly working thermostat should control the coolant flow and regulate the temperature regardless of air volume other than it being too low.
    jd110 likes this.
    John Deere 4310 tractor, New Holland 575E backhoe, John Deere F725 mower

  7. Top | #5

    Join Date
    Jan 2011
    Last Online
    11-09-2019 @ 06:07 AM
    Location
    Maryland
    Posts
    889
    Thanks
    5
    Thanked 315 Times in 240 Posts
    Quote Originally Posted by Old Machinist View Post
    That is an odd one. Please report back after the new fan clutch is installed to verify the fix.

    Back in the day we just had fixed blade fans. Then came the flex blade fan and finally the viscous clutch. The purpose of the viscous clutch was to reduce noise and increase power. Not so much to regulate temperature I don't think.

    It would seem to me a properly working thermostat should control the coolant flow and regulate the temperature regardless of air volume other than it being too low.

    I have to agree that it would be unusual for fan running too fast to keep engine too cool. Sounds like the viscous fan needs to be replaced anyway. One thing that does come to mind is the radiator. Since the 6420 has the split cooling system, It is possible the two systems are mixing internally. The low temperature side @ 140 degrees, cools the engine oil, hydraulic oil, and intake air. The 180 degree side is for engine. Usually the complaint is overheated hydraulic oil if the 2 sides mix since the low side gets warmer than normal when tractor is loaded heavy or is running high flow hydraulic functions. I guess it is possible at lower ambient temperatures and/or light loads combined with extra air flow due to malfunctioning fan could cause lower than normal temps. Just a thought...

  8. Top | #6

    Join Date
    Jun 2012
    Last Online
    10-04-2019 @ 06:24 PM
    Location
    canada
    Posts
    49
    Thanks
    5
    Thanked 4 Times in 4 Posts
    Thanks for the reply's, ill keep an eye on the hydraulic oil temp and take low side temperatures as well with the temp gun. I just received the viscous clutch so might replace it tomorrow and report back here. Another note about the fan, when I shut the engine off the crank rocks back and forth before stopping completely, the fan is locked with the "rocking" of the crank, whereas my other 2 20 series tractors and even my 6230, the fan will coast to a rest within 3-5 seconds of being shut off. Also it has been cool here lately, but still my other tractors will run upto normal temp so hoping its just in the fan clutch. otherwise the radiator makes sense.

  9. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Similar Threads

  1. 6420 will not come up to temp
    By TURBO in forum Agricultural Tractors
    Replies: 12
    Last Post: 02-13-2018, 07:09 PM
  2. Operating temp JD50
    By PhillipS in forum Johnny Poppers
    Replies: 8
    Last Post: 05-02-2017, 02:38 PM
  3. john deere 6420 temp in winter never gets up
    By colonialrepair in forum Utility Tractors
    Replies: 1
    Last Post: 02-23-2016, 10:02 PM
  4. Replies: 2
    Last Post: 08-24-2015, 07:19 AM
  5. Replies: 37
    Last Post: 03-14-2015, 12:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •