Need help with 1981 JD 750 Dozer problem
Results 1 to 7 of 7

Thread: Need help with 1981 JD 750 Dozer problem

  1. Top | #1

    Join Date
    Feb 2011
    Last Online
    02-07-2011 @ 07:45 PM
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Need help with 1981 JD 750 Dozer problem

    Pushes and steers fine at 3/4 throttle but not at full throttle. Have all new filters on it. Any ideas? All help appreciated.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    Brian's Avatar
    Join Date
    Aug 2010
    Last Online
    06-05-2014 @ 02:22 PM
    Location
    Bay City, Michigan
    Posts
    3,571
    Thanks
    50
    Thanked 333 Times in 213 Posts
    So what happens at full throttle? Tons of black smoke? Will it stall? What are the symptoms?



    Brian

  4. Top | #3
    Captain Hook Kennyd's Avatar
    Join Date
    Aug 2010
    Last Online
    Today @ 08:13 PM
    Location
    Westminster, MD
    Posts
    15,890
    Thanks
    4,799
    Thanked 3,808 Times in 2,416 Posts
    Welcome to DT Cowman

    We need more info to help...but is sounds like the IP (injection pump) may need a rebuild, that's why Brian is asking about the smoke.
    Kenny

    -John Deere 3720 Deluxe Cab TLB
    FEL, MMM, Artillian 42" Forks and Modular Grapple, I-Match, Ballast Box, Trac-Vac 854 (for sale) and lots of other STUFF.
    -John Deere 455 w/60" MMM


    Bolt on Grab Hooks and other cool stuff are now for sale!!

    Visit our YouTube Channel

    My Equipment:
    John Deere 3720 Deluxe Cab, 300cx FEL, 366 Front Blade, 59" Front Snowblower, Ballast Box
    Artillian 3K Forks, Grapple, Front-Hoe Bucket
    John Deere 455, 60" MMM

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    RandyM's Avatar
    Join Date
    Sep 2010
    Last Online
    03-14-2017 @ 10:30 AM
    Location
    Stoughton, Wisconsin
    Posts
    6,594
    Thanks
    1,047
    Thanked 1,057 Times in 671 Posts
    Welcome to DT Cowman.
    Randy __________________________________________________ ___ Be Safe!

    2009 - 2305 w/62 MMM **** 2008 - 2520 w/72 MMM **** 200CX w/49 bucket
    Weight Box w/extension ***** LandPride RTR 1558 Tiller ******* 54 Snow blower
    60 Gallon Demco Sprayer *** 60 Broom ** BB2060 Box Blade**SS2036B Spreader
    Everything Attachments ETA-PluggerV2-60 Aerator

    The more I learn, the less I know.

  7. Top | #5

    Join Date
    Feb 2011
    Last Online
    02-07-2011 @ 07:45 PM
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    At full RPM it doesn't push strong and kind of stalls a little until you back off to about 3/4 throttle then it gets a surge. Motor power seems good but does seems to surge a few times under a real hard push. It almost seems like the pumps are starving for oil. The left side pulls a little stronger than the right. Unk hours. Haven't had it very long. Unk history. Appreciate your time and the welcomes.

  8. Top | #6
    Captain Hook Kennyd's Avatar
    Join Date
    Aug 2010
    Last Online
    Today @ 08:13 PM
    Location
    Westminster, MD
    Posts
    15,890
    Thanks
    4,799
    Thanked 3,808 Times in 2,416 Posts
    It sounds like you have two problems, one the engine and one the hydraulic system. I would tackle the engine first-maybe get the injectors tested at a local shop, and possible the timing checked also. Once the engine is running strong you can move to the hydraulic system.
    Kenny

    -John Deere 3720 Deluxe Cab TLB
    FEL, MMM, Artillian 42" Forks and Modular Grapple, I-Match, Ballast Box, Trac-Vac 854 (for sale) and lots of other STUFF.
    -John Deere 455 w/60" MMM


    Bolt on Grab Hooks and other cool stuff are now for sale!!

    Visit our YouTube Channel

    My Equipment:
    John Deere 3720 Deluxe Cab, 300cx FEL, 366 Front Blade, 59" Front Snowblower, Ballast Box
    Artillian 3K Forks, Grapple, Front-Hoe Bucket
    John Deere 455, 60" MMM

  9. Top | #7
    Brian's Avatar
    Join Date
    Aug 2010
    Last Online
    06-05-2014 @ 02:22 PM
    Location
    Bay City, Michigan
    Posts
    3,571
    Thanks
    50
    Thanked 333 Times in 213 Posts
    How long has it sat before you got it and started using it? I ask because these things usually sit outside and people leave them with a half tank of fuel. I would treat the helk out of the fuel and if you can see the filters through a sight glass, check that they are not plugged up again.

    I agree with Kenny, the injectors and the injection pump might be bad on the engine side.



    Brian

  10. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Similar Threads

  1. 6420 problem
    By gls3555 in forum Utility Tractors
    Replies: 4
    Last Post: 07-28-2011, 08:30 PM
  2. Replies: 11
    Last Post: 06-28-2011, 10:19 PM
  3. Problem with LR135
    By SD1992 in forum Lawn & Garden Tractors
    Replies: 1
    Last Post: 06-14-2011, 05:12 PM
  4. JD 750 Research
    By ian in forum Construction Equipment
    Replies: 1
    Last Post: 03-12-2011, 12:26 PM
  5. Ertl Precision #1 - JD 650H Dozer 1/16th Scale
    By Spudland_Dave in forum For Sale
    Replies: 0
    Last Post: 12-18-2010, 07:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •