Opinions on what happened to this 220v Plug - Page 2
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Like Tree47Likes

Thread: Opinions on what happened to this 220v Plug

  1. Top | #11
    jdmich's Avatar
    Join Date
    Aug 2014
    Last Online
    Today @ 07:20 PM
    Location
    North/East of Davison, Michigan
    Posts
    3,731
    Thanks
    647
    Thanked 409 Times in 321 Posts
    Agree with what everyone else said. Loose connections cause heat.
    etcallhome and Zebrafive like this.
    Thanks Bob
    Fire trucks are Red/Tractors are Green

    2005 JD 790. 419 FEL, Frontier Forks, 6' brush Hog, back blade,7'FEL Snowplow.
    1963 JD 4010. 7' Lucknow 3pt Snowblower
    JD 24T Baler
    JD 14T Baler
    2013 JD 825i-Cab,winch,led lights 6' Snowplow.
    1951 JD MT.
    2011 JD Z445

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #12
    etcallhome's Avatar
    Join Date
    Jan 2011
    Last Online
    Today @ 08:57 PM
    Location
    Preston County WV
    Posts
    13,744
    Thanks
    3,468
    Thanked 2,596 Times in 1,665 Posts
    After 22 yrs,, (as someone told me)

    $hit happens.


    Agree with others , probably damaged when it was installed and over the years of use and no use.


    It finally broke.

    Feel lucky you got 22 yrs.
    Gene

    Have fun and be safe !!!
    USAR 8yr 8 mo SSG 99th ARCOM
    JD 1025R, H120 FEL 54" bucket, 54" mmm Auto Conn, 54" Front blade, JD back hoe ,JD IMatch, 48" Bush Hog tiller, Middlebuster from MF dealer, used King Kutter 5' rear blade, a new 47" JD Front blower and Original Tractor cab w/heater.
    We have a Red Honda Pioneer 700-4 (4 seater) w/soft top , doors, and winch.

  4. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 2 of 2 FirstFirst 1 2

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •