John Deere 2720 3 PT won't lift
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Like Tree32Likes

Thread: John Deere 2720 3 PT won't lift

  1. Top | #1

    Join Date
    Nov 2014
    Last Online
    01-21-2019 @ 08:08 PM
    Location
    East Dubuque IL
    Posts
    11
    Thanks
    10
    Thanked 1 Time in 1 Post

    John Deere 2720 3 PT won't lift

    Hey there, new to GTT, but I've been reading it for years and decided, since I've got an issue with my tractor, was hoping someone here could help me out. I recently added a single SCV to my 2720 by using the dealer installed power beyond (for a new backhoe). I used an open center SCV and connected the PB to it. I planned to use it on a rear blade with hydraulic angle. When I finished the install, everything worked great in the garage. When I got a chance to use it for an actual snowfall, again, it worked flawlessly. I used it for about an hour that morning. That evening, I got the tractor out of the garage and went to move more snow and after I lowered the blade with the 3PT, it would not raise back up. Nothing. Tried everything I could think of, hydraulic fluid level is fine, lowering drop speed was good. Still nothing. Finally, had to unhook the blade where it was at and got the tractor back in the garage. Looking it over in the garage, I can lift the 3PT arms up with my hands very easily, but the lever does nothing. Any thoughts?? Any help would be greatly appreciated.
    pcabe5 and PJR832 like this.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Sep 2014
    Last Online
    Today @ 06:29 PM
    Location
    West Michigan
    Posts
    1,854
    Thanks
    93
    Thanked 214 Times in 171 Posts
    Have you checked and reconnected all the hydro couplers? Does it sound like the hydro pump is in bypass when you try to raise the 3pt? Or in bypass while running?
    PJR832 likes this.
    2004-L130

    2013-2032r, Curtis Hard side cab (project), H130 FEL & 61"bucket, Artillian Modular Grapple on HD frame with Diverter, 2300# Artillian frame w/ 36" x 3" tines, 46BH 9" & 13" bucket, Frontier RB1060, HLA 1000 series 60" JDQA Snow plow, JD ballast box, RK QH, Homemade 3pt multi purpose hitch, 117W of extra LED lights on ROPS and side Brush guards, Ken's bolt on hooks-3x, Ideal Knife grooved R-4's.

  4. The Following User Says Thank You to balrog006 For This Useful Post:

    vormezeele (02-10-2018)

  5. Top | #3
    Official "Groovie" Dude
    Join Date
    Jun 2011
    Last Online
    @
    Location
    N/A
    Posts
    5,663
    Thanks
    1,459
    Thanked 744 Times in 605 Posts
    Would you mind posting some pictures of your valve setup?
    PJR832 likes this.

  6. The Following User Says Thank You to pcabe5 For This Useful Post:

    vormezeele (02-10-2018)

  7. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  8. Top | #4

    Join Date
    Nov 2014
    Last Online
    01-21-2019 @ 08:08 PM
    Location
    East Dubuque IL
    Posts
    11
    Thanks
    10
    Thanked 1 Time in 1 Post
    Yea, I have all the couplers connected. I even took my SCV setup out of the loop and looped the hose back as it was before when I don't have the backhoe attached and it still doesn't work. I will take pictures in the daylight. Could my new SCV setup somehow have screwed up hydraulic system?

  9. Top | #5
    Captain Hook Kennyd's Avatar
    Join Date
    Aug 2010
    Last Online
    Today @ 08:06 PM
    Location
    Westminster, MD
    Posts
    15,887
    Thanks
    4,798
    Thanked 3,807 Times in 2,415 Posts
    Did you use a Power Beyond equipped valve and a separate return line? In other words do you have three lines (not counting the work ports connected to the cylinder) connected or just two?


    I can lift the 3PT arms up with my hands very easily,
    FYI that is normal, there is no down pressure except gravity so the arms can float up.
    pcabe5, dieselshadow and Yank like this.
    Kenny

    -John Deere 3720 Deluxe Cab TLB
    FEL, MMM, Artillian 42" Forks and Modular Grapple, I-Match, Ballast Box, Trac-Vac 854 (for sale) and lots of other STUFF.
    -John Deere 455 w/60" MMM


    Bolt on Grab Hooks and other cool stuff are now for sale!!

    Visit our YouTube Channel

    My Equipment:
    John Deere 3720 Deluxe Cab, 300cx FEL, 366 Front Blade, 59" Front Snowblower, Ballast Box
    Artillian 3K Forks, Grapple, Front-Hoe Bucket
    John Deere 455, 60" MMM

  10. The Following User Says Thank You to Kennyd For This Useful Post:

    vormezeele (02-11-2018)

  11. Top | #6

    Join Date
    Nov 2014
    Last Online
    01-21-2019 @ 08:08 PM
    Location
    East Dubuque IL
    Posts
    11
    Thanks
    10
    Thanked 1 Time in 1 Post
    KennyD, no I did not use a power beyond equipped valve with a separate return line, just a single SCV open center valve from Northern Tool. I figured I could use the existing power beyond lines to power the SCV. See my setup below. To power the SCV , I disconnected the looping hose and took the male end to one side of my valve and brought the other hose from the valve and put it back into the female.Currently, I have the power beyond unhooked from the SCV and back in it's normal loop and still no 3PT working. Loader, power steering, transmission all working fine.

    Click image for larger version. 

Name:	20180211_122432 (2).jpg 
Views:	7 
Size:	59.5 KB 
ID:	544938
    Click image for larger version. 

Name:	20180211_122417 (2).jpg 
Views:	8 
Size:	62.4 KB 
ID:	544946
    pcabe5 likes this.

  12. Top | #7
    Keeper of the GTT Cookies dieselshadow's Avatar
    Join Date
    Nov 2011
    Last Online
    Today @ 09:06 PM
    Location
    Joelton TN
    Posts
    19,510
    Thanks
    1,048
    Thanked 4,152 Times in 2,520 Posts
    Is the tractor making any unusual and strange noises? Can you make the hydraulic system go into relief? You should be able to hear the relief valve lift when you max something out like the loader.
    pcabe5 likes this.
    - Jason

    GreenTractorTalk.com Rules, Policies, and Terms of Use

    Subscribe to dieselshadowman on YouTube

    2720 w/ 200CX FEL
    , Ken's weld-on hooks, Fit Rite Hydraulics Top and Tilt kit, Artillian forks.
    1954 60 - getting full restoration, 1964
    110 round fender in the shop for crustoration
    Ferris IS3200Zzero turn mower

  13. The Following User Says Thank You to dieselshadow For This Useful Post:

    vormezeele (02-11-2018)

  14. Top | #8
    Captain Hook Kennyd's Avatar
    Join Date
    Aug 2010
    Last Online
    Today @ 08:06 PM
    Location
    Westminster, MD
    Posts
    15,887
    Thanks
    4,798
    Thanked 3,807 Times in 2,415 Posts
    I fear that some backpressure may have been created back towards the rockshaft/3PH valve and damaged it, this is the concern when not using PB equipped valves.

    When everything was working, and the new valve plumbed in, did the blade see any unusually high forces while operating?
    glc, pcabe5 and Superglidesport like this.
    Kenny

    -John Deere 3720 Deluxe Cab TLB
    FEL, MMM, Artillian 42" Forks and Modular Grapple, I-Match, Ballast Box, Trac-Vac 854 (for sale) and lots of other STUFF.
    -John Deere 455 w/60" MMM


    Bolt on Grab Hooks and other cool stuff are now for sale!!

    Visit our YouTube Channel

    My Equipment:
    John Deere 3720 Deluxe Cab, 300cx FEL, 366 Front Blade, 59" Front Snowblower, Ballast Box
    Artillian 3K Forks, Grapple, Front-Hoe Bucket
    John Deere 455, 60" MMM

  15. The Following User Says Thank You to Kennyd For This Useful Post:

    vormezeele (02-11-2018)

  16. Top | #9
    Superglidesport's Avatar
    Join Date
    Dec 2011
    Last Online
    Today @ 05:19 AM
    Location
    Littleton, MA
    Posts
    7,653
    Thanks
    678
    Thanked 1,561 Times in 977 Posts
    Quote Originally Posted by Kennyd View Post
    I fear that some backpressure may have been created back towards the rockshaft/3PH valve and damaged it, this is the concern when not using PB equipped valves.

    When everything was working, and the new valve plumbed in, did the blade see any unusually high forces while operating?
    I'm thinking the same thing Kenny. I would also want to check the rock shaft draft feedback control linkage to make sure it's neither disconnected nor jammed.

    If the SCV plumbing was causing a restriction the hydraulic fluid may have become overheated and caused a lift piston or spool valve to score or seize. An piston seal or o-ring may have been damaged.
    glc and pcabe5 like this.
    John Deere 3320
    eHydro, R4's, 300CX Loader, 61" HD Bucket
    JD Tooth Bar, Deluxe Hood Guard, Ken's Bolt-on Hooks
    485 Backhoe w. 18" HD Bucket
    Mid-PTO, Front 3 Point Hitch, 366 Front Blade
    Tarter 5' 3PH Tiller
    Frontier AP12F Forks

    John Deere 2032R
    R3's, 220R Loader, 57" HD Bucket
    Curtis Hard Side Cab & Heater
    62D Deck, iMatch Quick Hitch
    54 Snowblower
    Super HeavyHitch
    Little Wonder "Optimax" & JRCO Blower Buggy
    Fimco 60 Gallon 3PH Boomless Sprayer w. PTO Pump

  17. The Following User Says Thank You to Superglidesport For This Useful Post:

    vormezeele (02-11-2018)

  18. Top | #10
    Official "Groovie" Dude
    Join Date
    Jun 2011
    Last Online
    @
    Location
    N/A
    Posts
    5,663
    Thanks
    1,459
    Thanked 744 Times in 605 Posts
    Is that the Nortrac 45462? If so, you would have needed to also purchase the optional power beyond plug. Otherwise from what I see you were trying to run the rockshaft on the tank return of the valve.

    Can you make the hydraulics go into relief as dieselshadow mentioned? Just move your loader joystick all the way in one direction and you should here the tractor grunt. I'd kinda like to know if your system is still making pressure on the implement side.
    Last edited by pcabe5; 02-11-2018 at 04:17 PM.

  19. The Following User Says Thank You to pcabe5 For This Useful Post:

    vormezeele (02-11-2018)

  20. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 3 1 2 3 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •