44" snow blower hardly lifts on JD X320
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By dukeh62

Thread: 44" snow blower hardly lifts on JD X320

  1. Top | #1

    Join Date
    Feb 2015
    Last Online
    11-19-2016 @ 05:39 PM
    Location
    CT
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    44" snow blower hardly lifts on JD X320

    Hi folks!

    I have a John Deere X320 with the 44" snow blower attachment that I've used flawlessly the past two seasons. However, today when I installed the blower, it hardly lifts off the ground with the mechanical lift...maybe 1.5-2" tops. Also, the lift pedal is MUCH farther forward than it was previously...which means there isn't enough travel for it to pick the blower up.

    For the life of me I can't figure it out. Something obviously moved/shifted since it was taken off this past spring.

    I would greatly appreciate some places to start looking.

    Thanks in advance!

    Eric
    Last edited by dukeh62; 11-19-2016 at 04:36 PM.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Yesterday @ 03:11 PM
    Location
    Area 51 in Cambria,NY
    Posts
    3,774
    Thanks
    415
    Thanked 480 Times in 371 Posts
    Just off the top of my head is the height adjustment on 0 or lowest position.Is the deck lock on when you put it on.You may have to remove the blower and make sure no linkage on the tractor is binding and try it again.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  4. Top | #3

    Join Date
    Feb 2015
    Last Online
    11-19-2016 @ 05:39 PM
    Location
    CT
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by TJR345 View Post
    Just off the top of my head is the height adjustment on 0 or lowest position.Is the deck lock on when you put it on.You may have to remove the blower and make sure no linkage on the tractor is binding and try it again.
    Yeah, unfortunately I did have it in the lowest position and the deck lock was on.

    The fact that the lift pedal isn't coming back far enough is obviously the culprit. I just need to find out what's causing that.
    BigJim55 likes this.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •