John Deere 425 stalls when releasing parking brake
Results 1 to 3 of 3

Thread: John Deere 425 stalls when releasing parking brake

  1. Top | #1

    Join Date
    Apr 2017
    Last Online
    04-26-2017 @ 07:47 PM
    Location
    illinois
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    John Deere 425 stalls when releasing parking brake

    I have a JD 425,it ran fine all last year and upon using this year it started up and runs great until I release the parking brake then it dies ,I checked the seat switch and the parking brake switch both seem fine, I did notice the ignition module board connectors seemed corroded and 2 wires looked as if they got hot at one time probably due to corrosion ,I noticed when moving the brake the red and green lights on module flicker. I am wondering if the board could be bad?Bad ground? I did notice a few times last summer when I engaged PTO switch it did not engage immediately I had to operate switch a few times, any ideas?Thanks

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    xcopterdoc's Avatar
    Join Date
    Jan 2012
    Last Online
    Today @ 07:45 AM
    Location
    nc
    Posts
    1,636
    Thanks
    190
    Thanked 843 Times in 324 Posts
    The switches "seem" fine? Did you check for power to switch and out of switch?. Start there.

    Sent from my LGL52VL using Tapatalk

  4. Top | #3

    Join Date
    Apr 2017
    Last Online
    04-26-2017 @ 07:47 PM
    Location
    illinois
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I checked for continuity to see if switches were functioning but no I didn't test for voltage

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •