X300 will not start, no crank, no hours meter
Results 1 to 2 of 2

Thread: X300 will not start, no crank, no hours meter

  1. Top | #1

    Join Date
    Apr 2017
    Last Online
    04-30-2017 @ 09:38 PM
    Location
    Manitoba, Canada
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    X300 will not start, no crank, no hours meter

    My neighbour is having trouble starting his X300 092107 tractor. The hour meter and head light don't work, no crank. Fuses good. Battery good, swapped with my X300, also swapped Electronic Control Unit with my X300. Disconnected cable to key switch, my tractor had voltage on 2 leads, dead tractor only had voltage on one lead.

    Please help, what should I check next.

    Thanks

    Stephen

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Today @ 05:49 AM
    Location
    Area 51 in Cambria,NY
    Posts
    3,731
    Thanks
    415
    Thanked 477 Times in 368 Posts
    I would check the safety switches,seat pto and brake.Any one can cause a no start.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  4. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •