x758 starting up hard recently
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Like Tree26Likes

Thread: x758 starting up hard recently

  1. Top | #1

    Join Date
    Apr 2016
    Last Online
    Today @ 12:18 AM
    Location
    Minnesota
    Posts
    1,231
    Thanks
    20
    Thanked 84 Times in 80 Posts

    x758 starting up hard recently

    The x758 I bought last year has 100 hours on it now. All last summer, all winter, and this spring until two days ago it has always started up right away, with very little smoking. Same starting response whether it had run a day ago, an hour ago, or three weeks ago. The last two days though it is having a very different situation happening. At cold start it will crank and crank and spit out thick smoke as it is doing so. After turning over for what seems like quite a while (long enough I've stopped cranking to give the starter a brief rest, maybe 5-7 seconds) then it will fire up and be normal. As soon as it fires the smoke goes away. Subsequent warm starts are fast like it used to be.

    Prior to these last two days I've started it up multiple times a week this spring and it has been normal. Though the fuel in it is from a few months back I find it hard to believe that old fuel is an issue that just pops up one day after working fine a few days before. The battery is strong and it cranks fast all the time. Only recent maintenance to it has been to remove the snowblower and install the mower, as well as greasing all lube points.

    Any thoughts what it might be?

    Thanks,
    Rob
    TJR345 likes this.
    2016 x758 w/60" HC mower, 54" snowblower, MC519 bagger
    2010 2520 w/61" H130 loader, TA 42" forks, KK 60" Pro tiller, iMatch quick hitch, KK middle buster
    1996 345 - Traded
    Other toys: Stihl BR600 backpack blower; McCulloch chainsaws: 10-10S, 700, 805, 10-10; JD trimmer

    2520:__________________________x758:__________________________Faithful 345:___________________

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Yesterday @ 10:25 PM
    Location
    Area 51 in Cambria,NY
    Posts
    3,731
    Thanks
    415
    Thanked 477 Times in 368 Posts
    How long does the glow plugs cycle,does it seem shorter than it used to be.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  4. Top | #3
    99srxman's Avatar
    Join Date
    Jan 2017
    Last Online
    08-19-2019 @ 06:38 PM
    Location
    Richfield WI.
    Posts
    123
    Thanks
    21
    Thanked 11 Times in 11 Posts
    I think I would start with fresh fuel and maybe a new fuel filter and see what happens ??

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    etcallhome's Avatar
    Join Date
    Jan 2011
    Last Online
    Yesterday @ 09:07 PM
    Location
    Preston County WV
    Posts
    13,225
    Thanks
    3,231
    Thanked 2,417 Times in 1,550 Posts
    Think I would change fuel filter , just a thought do you use any fuel additives especially since fuel is a couple of months old.

    if no help then guessing a problem with a glow plug either way sounds like it would be under warranty .
    Gene

    Have fun and be safe !!!
    USAR 8yr 8 mo SSG 99th ARCOM
    JD 1025R, H120 FEL 54" bucket, 54" mmm Auto Conn, 54" Front blade, JD back hoe ,JD IMatch, 48" Bush Hog tiller, Middlebuster from MF dealer, used King Kutter 5' rear blade, a new 47" JD Front blower and Original Tractor cab w/heater.
    We have a Red Honda Pioneer 700-4 (4 seater) w/soft top , doors, and winch.

  7. Top | #5
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Yesterday @ 10:25 PM
    Location
    Area 51 in Cambria,NY
    Posts
    3,731
    Thanks
    415
    Thanked 477 Times in 368 Posts
    Quote Originally Posted by 99srxman View Post
    I think I would start with fresh fuel and maybe a new fuel filter and see what happens ??
    Quote Originally Posted by etcallhome View Post
    Think I would change fuel filter , just a thought do you use any fuel additives especially since fuel is a couple of months old.

    if no help then guessing a problem with a glow plug either way sounds like it would be under warranty .
    Fuel doesn't go bad in a couple of months,it seems with the poor cold start but easy hot start sounds like glow plug problem.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  8. Top | #6

    Join Date
    Apr 2016
    Last Online
    Today @ 12:18 AM
    Location
    Minnesota
    Posts
    1,231
    Thanks
    20
    Thanked 84 Times in 80 Posts
    I did put some diesel additive that touted its 'stabilization' capabilities in the fuel last winter when I added it because I knew I wouldn't be using the tractor much over winter. I've just burned up another tank for my first mowing so I'll have some fresh fuel in shortly.

    I hadn't changed the fuel filter yet since it was only at 100 hours but I looked again and the manual says "or annually" so I can do that.

    The indicator light on the cluster may not be on as long as it used to. I guess I didn't pay too much attention. The first time it did this I had turned the key on and left it there a minute as I dealt with something else before I actually cranked it. Today I watched the light and started cranking right when it went out, with identical results. But the light may be on only 3 sec or so instead of 4-5 before?? I don't remember.

    Thanks,
    Rob
    etcallhome, Drifterbike and TJR345 like this.
    2016 x758 w/60" HC mower, 54" snowblower, MC519 bagger
    2010 2520 w/61" H130 loader, TA 42" forks, KK 60" Pro tiller, iMatch quick hitch, KK middle buster
    1996 345 - Traded
    Other toys: Stihl BR600 backpack blower; McCulloch chainsaws: 10-10S, 700, 805, 10-10; JD trimmer

    2520:__________________________x758:__________________________Faithful 345:___________________

  9. Top | #7
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Yesterday @ 10:25 PM
    Location
    Area 51 in Cambria,NY
    Posts
    3,731
    Thanks
    415
    Thanked 477 Times in 368 Posts
    If the glow plug is only on for 2-3 seconds then that's your problem.If under warranty take it to the dealer.Either a bad glow plug or two or the module is bad.If out of warranty you can ohm the glow plugs.Open circuit is a bad plug.My x595 is glow plug circuit on 8-10 seconds.
    BigJim55 and Drifterbike like this.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  10. Top | #8

    Join Date
    Apr 2016
    Last Online
    Today @ 12:18 AM
    Location
    Minnesota
    Posts
    1,231
    Thanks
    20
    Thanked 84 Times in 80 Posts
    It's under warranty. I have a great dealer who will take care of me. It's just that they are an hour away and dragging it up there takes some time & effort. Especially if I have to leave it a day or two so they can test it with full-cold startups.

    The closer dealer seems incredibly incompetent. The parts guy has had trouble finding things in their computer system even when I told him exactly what I needed, from the exact model of tractor to look up, or even with an actual JD part number. And then they don't carry it "but we have it in our other store and we could have it in a day or two." So I don't patronize them.

    How many seconds is normal for the Yanmar in an x75x to run the glow plug on a cold start in moderate temps (50-60*F)? I really can't remember but I thought mine has only ever stayed on 3-5 seconds max. Way shorter duration than the plugs in my 2520.

    Rob
    BigJim55 and Drifterbike like this.
    2016 x758 w/60" HC mower, 54" snowblower, MC519 bagger
    2010 2520 w/61" H130 loader, TA 42" forks, KK 60" Pro tiller, iMatch quick hitch, KK middle buster
    1996 345 - Traded
    Other toys: Stihl BR600 backpack blower; McCulloch chainsaws: 10-10S, 700, 805, 10-10; JD trimmer

    2520:__________________________x758:__________________________Faithful 345:___________________

  11. Top | #9

    Join Date
    Apr 2016
    Last Online
    Today @ 12:18 AM
    Location
    Minnesota
    Posts
    1,231
    Thanks
    20
    Thanked 84 Times in 80 Posts
    Went out to check things. Re-seated all the fuses and relays in the fuse box since it was suggested to me elsewhere that corrosion of the fuse blades may be reducing power to the glow plugs. Turned key on, counted and glow plugs were on 5 seconds. Cranked it as soon as the indicator light went out. Started normally this time. I'll keep monitoring the starts and see if it reverts to bad again. I'm also going to replace the fuel filter since it has been a year. The separator bowl looks clean and water-free, but it's cheap insurance. And some fresh diesel coming...

    When I pulled the sealed cover off the fuse box something small fell out. At first I thought it looked like a fuse but it fell so fast. Looked around and found this little plastic piece sitting by a mower spindle. Doesn't look important but I'm not sure what it would have been. Ideas?

    Rob
    Attached Thumbnails Attached Thumbnails 20170504_121518.jpg
    etcallhome and Drifterbike like this.
    2016 x758 w/60" HC mower, 54" snowblower, MC519 bagger
    2010 2520 w/61" H130 loader, TA 42" forks, KK 60" Pro tiller, iMatch quick hitch, KK middle buster
    1996 345 - Traded
    Other toys: Stihl BR600 backpack blower; McCulloch chainsaws: 10-10S, 700, 805, 10-10; JD trimmer

    2520:__________________________x758:__________________________Faithful 345:___________________

  12. Top | #10
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Yesterday @ 10:25 PM
    Location
    Area 51 in Cambria,NY
    Posts
    3,731
    Thanks
    415
    Thanked 477 Times in 368 Posts
    Quote Originally Posted by BigBlue View Post
    It's under warranty. I have a great dealer who will take care of me. It's just that they are an hour away and dragging it up there takes some time & effort. Especially if I have to leave it a day or two so they can test it with full-cold startups.

    The closer dealer seems incredibly incompetent. The parts guy has had trouble finding things in their computer system even when I told him exactly what I needed, from the exact model of tractor to look up, or even with an actual JD part number. And then they don't carry it "but we have it in our other store and we could have it in a day or two." So I don't patronize them.

    How many seconds is normal for the Yanmar in an x75x to run the glow plug on a cold start in moderate temps (50-60*F)? I really can't remember but I thought mine has only ever stayed on 3-5 seconds max. Way shorter duration than the plugs in my 2520.

    Rob
    Sounds like the dealer near me,incompetent.I drive 45-50 minutes to get a dealer who knows his stuff and parts people that go out of there way to help.
    Seems no matter the temp the glow plugs run a certain time (mine about 8 sec)
    BigJim55 likes this.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts