Help with ax595
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Like Tree1Likes

Thread: Help with ax595

  1. Top | #1

    Join Date
    Jun 2017
    Last Online
    06-29-2017 @ 09:56 PM
    Location
    bristol virgina
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Help with ax595

    I have tried to post this in tech. but it will not allow me to post it so I am putting it here. Engine starts an runs fine as long as brake is applied, when brake is released engine dies. I have jumpered seat switch an it has no effect, I have taped brake switch closed, an will operate ok but if mowing deck is engaged engine will die. I need some help please.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Today @ 04:53 AM
    Location
    Area 51 in Cambria,NY
    Posts
    3,727
    Thanks
    414
    Thanked 476 Times in 367 Posts
    The proper place to post is lawn and garden.Hopefully the mods will see it and move it.As for your question off the top of my head the 3 safety switches all work together to complete a loop (seat,pto,brake) then there are relays that close also on the right side.I can look at my tech manual for the troubleshooting steps when I get home from work.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  4. Top | #3
    vs-Admin's Avatar
    Join Date
    Sep 2015
    Last Online
    Today @ 11:50 AM
    Location
    Toronto
    Posts
    788
    Thanks
    1
    Thanked 172 Times in 98 Posts
    Thread moved.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    sennister's Avatar
    Join Date
    Dec 2015
    Last Online
    Today @ 01:00 PM
    Location
    Twin Cities, MN
    Posts
    1,950
    Thanks
    23
    Thanked 214 Times in 176 Posts
    I looked at the manual for my X585 as I know it covers several models but it didn't cover the X595 even though they are the same generation. I took a glance at the schematics and a hunch would have me look at the PTO Interlock Module. There are several relay in there which I don't think are replaceable which might cause this.

    Starting with the brake on is normal. I know I have to push in the brake to fire it up. The machine cutting off with the brake switch jumpered when the PTO engages sounds normal. I don't recall if it shuts down everything or just the PTO if the brake is set but I want to say you can't run the PTO with the brake set. I don't have any PTO attachments on my machine to test that though.

    Sounds like someone has the X595 manual so I will wait to see if the test procedure helps narrow down the fault. I have the one for the X585 but it is talking about EFI modules in some of the tests which wouldn't apply. I would imagine most of the other stuff is about the same but don't want to send you down a wrong path.


    JD Z950R 60" Deck with DFS Collection System

    JD X585, 54C deck,
    CTC Model X4750 F.E.L - Modified Imp Pressure Relief from 900 to 1175PSI, Power Flow and MC519 cart, 54-inch Quick-Hitch Front Blade, 47-inch Quick-Hitch Snow Blower, 3-pt hitch, HF Quick Hitch, Heavy Hitch, 60" box blade/rear blade, Dethacher, Sprayer cart

  7. The Following User Says Thank You to sennister For This Useful Post:

    cbud167(06-26-2017)

  8. Top | #5
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Today @ 04:53 AM
    Location
    Area 51 in Cambria,NY
    Posts
    3,727
    Thanks
    414
    Thanked 476 Times in 367 Posts
    From what I read and looked at the electrical diagram the problem could be the brake switch.When the pedal is pushed in it also activates the RIO sw.The RIO is part of the pto circuit.I have a feeling the brake/rio switch is bad.
    The purple wire 765 from from S6 brake sw to the S2 RIO sw must have power.From the S2 to the A2 control module (circuit board) is wire 705 pink/black must have power.A green led on A2 means all cranking circuit operating conditions are met and the circuit is functional.Check that out and let me know their are other things but that's the start.
    BigJim55 likes this.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  9. Top | #6

    Join Date
    Jun 2017
    Last Online
    06-29-2017 @ 09:56 PM
    Location
    bristol virgina
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    thank you I will work on it tomarrow

  10. Top | #7

    Join Date
    Jun 2017
    Last Online
    06-29-2017 @ 09:56 PM
    Location
    bristol virgina
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    ok I put a new brake switch on it an still same problem, the green lite on circuit board is on an I start it an it stays on until I let out on the brake. lite goes out an engine dies. : next suggestion?

  11. Top | #8
    bloodrunsgreen's Avatar
    Join Date
    Feb 2015
    Last Online
    Today @ 12:38 PM
    Location
    Mid-Michigan
    Posts
    466
    Thanks
    14
    Thanked 54 Times in 52 Posts
    I would pull and clean the interlock module (both sides), these boards get dirty and can cause issues, inspect for burnt traces and components, clean the connections.

  12. Top | #9

    Join Date
    Jun 2017
    Last Online
    06-29-2017 @ 09:56 PM
    Location
    bristol virgina
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    are you referring to the printed circuit board?

  13. Top | #10

    Join Date
    Jun 2017
    Last Online
    06-29-2017 @ 09:56 PM
    Location
    bristol virgina
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Sure could use a wiring diagram

  14. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts