D170 engine running poorly
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By H-D dealer dude

Thread: D170 engine running poorly

  1. Top | #1

    Join Date
    Feb 2016
    Last Online
    08-20-2019 @ 01:22 PM
    Location
    Virginia
    Posts
    133
    Thanks
    1
    Thanked 18 Times in 16 Posts

    D170 engine running poorly

    Have a D170 with 69 hrs on it. Yesterday while mowing grass engine suddenly got a bit louder and now has about 70% of the power it had before. Put gas in it checked the oil ( fine still clear and no smell of gas in it). Let it sit, today I checked the plugs 9 see pic) and gapped and changed them and still have the same issue. Any ideas? BTW this is the B&S 25 Hp engine.
    Attached Thumbnails Attached Thumbnails IMG_5953.JPG  

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Sep 2015
    Last Online
    03-02-2019 @ 06:20 PM
    Location
    Lehigh Valley PA
    Posts
    3,228
    Thanks
    1
    Thanked 201 Times in 195 Posts
    Quote Originally Posted by 1MOA View Post
    Have a D170 with 69 hrs on it. Yesterday while mowing grass engine suddenly got a bit louder and now has about 70% of the power it had before. Put gas in it checked the oil ( fine still clear and no smell of gas in it). Let it sit, today I checked the plugs 9 see pic) and gapped and changed them and still have the same issue. Any ideas? BTW this is the B&S 25 Hp engine.
    What kind of louder sound are you talking about?
    Check the exhaust system for damage or missing parts. If either pipe came off the cylinder head or the gasket in between them blew out. You will get extra exhaust noise and a reduction in power. The down pipes could have also cracked off the muffler

    If you are getting an internal engine noise it could be any number of problems. Like a loose rocker arm or a bent push rod. Either problem would definitely give you a reduction in power.
    2014 X540 with HDAP tires, 54" deck, brush guard, arm rests and cargo bag.
    JD 48" plow with angle from seat kit & heavy duty skid shoes.
    4 suitcase weights and chains.
    JD tow behind spreader.
    JD 42" lawn sweeper.
    JD 10P cart.
    JD JS61 RWD walk behind mower.
    Stihl KM110 power head with pole saw, shaft extension, power scythe, curved shaft edger, 2 straight shaft cutters (string & blade).
    Stihl MS180-CBE 16" saw.
    Stihl SH86C hand held blower vac.

  4. Top | #3

    Join Date
    Aug 2017
    Last Online
    09-18-2017 @ 10:08 AM
    Location
    Indiana
    Posts
    6
    Thanks
    0
    Thanked 2 Times in 1 Post
    If you don't find anything wrong on the outside, might check your valve clearance. And look for a bent push rod.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Feb 2016
    Last Online
    08-20-2019 @ 01:22 PM
    Location
    Virginia
    Posts
    133
    Thanks
    1
    Thanked 18 Times in 16 Posts
    Quote Originally Posted by H-D dealer dude View Post
    What kind of louder sound are you talking about?
    Check the exhaust system for damage or missing parts. If either pipe came off the cylinder head or the gasket in between them blew out. You will get extra exhaust noise and a reduction in power. The down pipes could have also cracked off the muffler

    If you are getting an internal engine noise it could be any number of problems. Like a loose rocker arm or a bent push rod. Either problem would definitely give you a reduction in power.
    The engine is running louder, exhaust system is not compromised, no smoke, no strange noises. Just louder.

  7. Top | #5

    Join Date
    Sep 2015
    Last Online
    03-02-2019 @ 06:20 PM
    Location
    Lehigh Valley PA
    Posts
    3,228
    Thanks
    1
    Thanked 201 Times in 195 Posts
    Quote Originally Posted by 1MOA View Post
    The engine is running louder, exhaust system is not compromised, no smoke, no strange noises. Just louder.

    First off them plugs look to be burning good.

    Can you post a video? Describing noise is hard to do.

    Are you sure that the noise is coming from the engine? When you say 70% power are you talking over all or just the driving? I'm wondering if something happened to the belts, deck or transmission to make the engine work harder thus increasing the noise from the engine.

    I see you have very low hours on the clock. Is the machine still under warranty? If so have your local dealer take a look.
    2014 X540 with HDAP tires, 54" deck, brush guard, arm rests and cargo bag.
    JD 48" plow with angle from seat kit & heavy duty skid shoes.
    4 suitcase weights and chains.
    JD tow behind spreader.
    JD 42" lawn sweeper.
    JD 10P cart.
    JD JS61 RWD walk behind mower.
    Stihl KM110 power head with pole saw, shaft extension, power scythe, curved shaft edger, 2 straight shaft cutters (string & blade).
    Stihl MS180-CBE 16" saw.
    Stihl SH86C hand held blower vac.

  8. Top | #6

    Join Date
    Feb 2016
    Last Online
    08-20-2019 @ 01:22 PM
    Location
    Virginia
    Posts
    133
    Thanks
    1
    Thanked 18 Times in 16 Posts
    I dropped it off at the dealership today so no video. The mechanic who initially pulled it off the trailer was baffled too he also commented the engine sounded "tinny" but it starts and runs just fine.

    It is 26 days out of warranty it will be interesting to see what it is and I will keep you posted.

  9. Top | #7
    xcopterdoc's Avatar
    Join Date
    Jan 2012
    Last Online
    Today @ 08:06 AM
    Location
    nc
    Posts
    1,637
    Thanks
    190
    Thanked 852 Times in 325 Posts
    I wish I could say I never saw failures on those engines. Mostly they happen pretty quick. With in the first 10 or so hours. Rare to see one fail after that but it does happen. Of course this is saying if it is in fact an internal problem. Most later hr failures are caused by oil leaks. Lack of lubrication causes tell tale signs that will be noted.

    Sent from my LGL52VL using Tapatalk

  10. Top | #8

    Join Date
    Feb 2016
    Last Online
    08-20-2019 @ 01:22 PM
    Location
    Virginia
    Posts
    133
    Thanks
    1
    Thanked 18 Times in 16 Posts
    oil level was fine and has been changed.

  11. Top | #9

    Join Date
    Feb 2016
    Last Online
    08-20-2019 @ 01:22 PM
    Location
    Virginia
    Posts
    133
    Thanks
    1
    Thanked 18 Times in 16 Posts
    Ended up being the PTO had a broken piece and it was slipping. No warranty coverage but bill was $187 parts and labor.

  12. Top | #10

    Join Date
    Sep 2015
    Last Online
    03-02-2019 @ 06:20 PM
    Location
    Lehigh Valley PA
    Posts
    3,228
    Thanks
    1
    Thanked 201 Times in 195 Posts
    Quote Originally Posted by 1MOA View Post
    Ended up being the PTO had a broken piece and it was slipping. No warranty coverage but bill was $187 parts and labor.
    Glad you got it fixed.
    1MOA likes this.
    2014 X540 with HDAP tires, 54" deck, brush guard, arm rests and cargo bag.
    JD 48" plow with angle from seat kit & heavy duty skid shoes.
    4 suitcase weights and chains.
    JD tow behind spreader.
    JD 42" lawn sweeper.
    JD 10P cart.
    JD JS61 RWD walk behind mower.
    Stihl KM110 power head with pole saw, shaft extension, power scythe, curved shaft edger, 2 straight shaft cutters (string & blade).
    Stihl MS180-CBE 16" saw.
    Stihl SH86C hand held blower vac.

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •