X540 lubrication
Results 1 to 2 of 2

Thread: X540 lubrication

  1. Top | #1

    Join Date
    Aug 2014
    Last Online
    08-05-2014 @ 03:23 PM
    Location
    saginaw, michigan
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Arrow X540 lubrication

    I am befuddled and confused. I inherited an X540 three years ago that my father bought in late 2007. Today the battery died and I replaced it. Then I decided to lube it, which I do regularly as per the book. However, as I went thru the lube points in the book, I again failed to find a zerk fitting for the lift pedal assembly. I have never, ever been able to find it and tho the picture shows one, there is no fitting on the round assembly! Looking and feeling all around I still cannot find one. I have a 54" deck and do not use a snow blower. Am I missing something or is it possible my X540 does not have a grease fitting for the lift pedal assembly? Every time I grease this machine I scratch my head in wonderment and today found this forum after trying to find an answer. Any help would be appreciated.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    jgayman's Avatar
    Join Date
    Jul 2012
    Last Online
    Today @ 01:56 PM
    Location
    Central Pennsylvania
    Posts
    9,476
    Thanks
    357
    Thanked 1,549 Times in 1,172 Posts
    Doesn't the X540 have a hydraulic lift? I didn't think it even had a lift pedal. I have a base model X500 and it of course has the mechanical lift pedal.

  4. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •