New to me x475
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Like Tree29Likes

Thread: New to me x475

  1. Top | #1

    Join Date
    Apr 2018
    Last Online
    10-17-2019 @ 12:21 PM
    Location
    iowa
    Posts
    24
    Thanks
    5
    Thanked 1 Time in 1 Post

    New to me x475

    Recently upgraded from a gt275 to a x475.the previous owner said that it was serviced last year and came out of storage to sell. Claims there is 700hrs on it but after getting home I noticed The hour meter doesn't work. The only attachment that has ever been attach is the 54c. What should I look over and check now that I have it home. Also what all do I need to add a 3point on the rear. I also see some people add a cat0 and some do cat1. Also debating on snowblower/blade. I had blower on my old one but not sure money will be available for a blower for awhile.

    Sent from my SM-G930R4 using Tapatalk
    BigJim55 and Fozsey like this.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Apr 2018
    Last Online
    10-17-2019 @ 12:21 PM
    Location
    iowa
    Posts
    24
    Thanks
    5
    Thanked 1 Time in 1 Post
    I also found a blade with quick hitch. Believe it's from a 400 series. What all do I need to make it work on my tractor? Just new longer hoses? Blade seems to be in decent shape. What would be fair price on the blade and new hoses?

    Sent from my SM-G930R4 using Tapatalk

  4. Top | #3
    BigJim55's Avatar
    Join Date
    Nov 2013
    Last Online
    Today @ 06:57 AM
    Location
    Schellsburg, PA
    Posts
    11,248
    Thanks
    3,039
    Thanked 1,406 Times in 1,105 Posts
    Quote Originally Posted by reit38 View Post
    I also found a blade with quick hitch. Believe it's from a 400 series. What all do I need to make it work on my tractor? Just new longer hoses? Blade seems to be in decent shape. What would be fair price on the blade and new hoses?

    Sent from my SM-G930R4 using Tapatalk
    does this blade come with the quick hitch? i have no quick hitch for mine, and i can't say if the 400's would fit the X-series?

    u was wondering what to check on ur to u X-475. have u greased ur u-joints on the shaft from the motor to rearend?

    how's the fan belt look? is it tight or loose?
    how old is the anti-freeze in it?
    air filter-new oil and filter change?
    how about a hydraulic oil change and filter? just a few things i can think of u need to look over.

    last thing which should of been on the top item--a manual for it-unless the previous owner gave u one with the tractor.

    get one right away and read it all. good luck and happy
    etcallhome, ColonyPark and Fozsey like this.
    jim

    2006 2520 mcut, 2004 x475, 1953 model 50, 1985 318-was my Dad's,
    king kutter tiller-60", frontier-stone rake, jd-4ft brush hog, frontier-6ft back-blade, frontier-forks, 48 inch forks,
    2-54inch jd snow plows, jd-5ft-pull brush hog,

    2018 835R gas model gator-"aka" the Cadillac i say!! 6ft jd snow plow-which already has a dtac out on it. i got just about everything on it i could at the time

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Apr 2018
    Last Online
    10-17-2019 @ 12:21 PM
    Location
    iowa
    Posts
    24
    Thanks
    5
    Thanked 1 Time in 1 Post
    Yes blade has quick hitch with it

    Sent from my SM-G930R4 using Tapatalk

  7. Top | #5
    sennister's Avatar
    Join Date
    Dec 2015
    Last Online
    Today @ 06:21 AM
    Location
    Twin Cities, MN
    Posts
    2,238
    Thanks
    33
    Thanked 244 Times in 202 Posts
    If it were me, I would go through all the filters, fluids and lube points. That way you know where you are at. It is odd that the hour meter doesn't work. Do the other gauges? I had an issue with my instrument cluster and it was doing all kinds of strange things. Like pegging out the fuel and temp gauges when the PTO was on. But it was intermittent. The official fix was to bond the ground (splice in a new ground wire to the ground wire on the harness. I also had some broken soldier points where the connector was attached into the circuit board on the dash. I just re-soldiered them and added the new ground wire. Works fine after that. Not sure if this issue applies to your machine.

    Can't speak for sure on the quick hitch with blade. I would expect something like $500-600 but that is a guess and it depends on condition. The only thing you should need is the longer hoses but I don't know the 400 or X475 all that well.

    As for the blower. This was my first year in the last 4 that I used it. No I am not selling it but that said, I rarely use it. I have it for those big snow falls. It is my insurance policy and know that I can always fall back on it. I would rather plow twice than blow once.
    etcallhome, BigJim55 and Fozsey like this.


    JD Z950R 60" Deck with DFS Collection System

    JD X585, 54C deck,
    CTC Model X4750 F.E.L - Modified Imp Pressure Relief from 900 to 1175PSI, Power Flow and MC519 cart, 54-inch Quick-Hitch Front Blade, 47-inch Quick-Hitch Snow Blower, 3-pt hitch, HF Quick Hitch, Heavy Hitch, 48" box blade/rear blade, Dethacher, 3pt Sprayer

  8. Top | #6

    Join Date
    Apr 2018
    Last Online
    10-17-2019 @ 12:21 PM
    Location
    iowa
    Posts
    24
    Thanks
    5
    Thanked 1 Time in 1 Post
    On the gauges.....

    The gas and temp gauge barely move when it's running. Where is normal running temp?

    The Park and pto lights come on I know those work for sure

    Sent from my SM-G930R4 using Tapatalk

  9. Top | #7
    TJR345's Avatar
    Join Date
    Jan 2016
    Last Online
    Today @ 05:10 AM
    Location
    Area 51 in Cambria,NY
    Posts
    3,777
    Thanks
    415
    Thanked 480 Times in 371 Posts
    Adding the 3pt hitch is easy,you can get the Deere or the aftermarket Ruegg.The guick hitch off a 400 I'm not sure it would fit.The 400 was an odd tractor,only attachments for that model seemed to fit.I've read that guys have a tough time finding stuff for them.
    If it is off a 425,445,455 the yes it just mounts different and you need longer hoses.
    Last edited by TJR345; 04-28-2018 at 06:19 AM.
    sennister and Fozsey like this.
    Tom

    2019 X590 with power mulch control and PF bagger
    30" mechanical tiller
    02 X595 with 62" deck,front thatcher and powerflow PTO kit
    3pt hitch with Heavy Hitch 45 JD loader
    12 JD suitcase weights
    JD/Brinly 3pt plow
    Frontier SS1036 3pt pto spreader
    (2) JS63C walk behind mowers
    TS 105 JD weed wacker
    tow behind 15 gal. sprayer
    Turftime 60" lawn roller
    Turftime 54" 3pt core aerator

  10. Top | #8
    sennister's Avatar
    Join Date
    Dec 2015
    Last Online
    Today @ 06:21 AM
    Location
    Twin Cities, MN
    Posts
    2,238
    Thanks
    33
    Thanked 244 Times in 202 Posts
    Quote Originally Posted by reit38 View Post
    On the gauges.....

    The gas and temp gauge barely move when it's running. Where is normal running temp?

    The Park and pto lights come on I know those work for sure

    Sent from my SM-G930R4 using Tapatalk
    The lights always worked on my dash when it was messed up. It was just that they would peg out. However they could do other things as well. In my case it started with the temp gauge. It would go past the red section. It could be a hot 95 day and be pegged out. As soon as the PTO was shut off the gauge would drop down to the normal green range. It would do this in a couple seconds even though the engine is still running wide open and I am at a complete stop. So I knew it wasn't overheating. No way it would cool that fast.

    The gas gauge is easier to diagnose. Fill it up. It should read full.

    I want to say now that it is fixed, mine runs in the middle of the green range somewhere. I don't look at it that close.
    Last edited by sennister; 04-28-2018 at 06:46 AM.
    Fozsey likes this.


    JD Z950R 60" Deck with DFS Collection System

    JD X585, 54C deck,
    CTC Model X4750 F.E.L - Modified Imp Pressure Relief from 900 to 1175PSI, Power Flow and MC519 cart, 54-inch Quick-Hitch Front Blade, 47-inch Quick-Hitch Snow Blower, 3-pt hitch, HF Quick Hitch, Heavy Hitch, 48" box blade/rear blade, Dethacher, 3pt Sprayer

  11. Top | #9
    sennister's Avatar
    Join Date
    Dec 2015
    Last Online
    Today @ 06:21 AM
    Location
    Twin Cities, MN
    Posts
    2,238
    Thanks
    33
    Thanked 244 Times in 202 Posts
    Quote Originally Posted by TJR345 View Post
    Adding the 3pt hitch is easy,you can get the Deere or the aftermarket Ruegg.The guick hitch off a 400 I'm not sure it would fit.The 400 was an odd tractor,only attachments for that model seemed to fit.I've read that guys have a tough time finding stuff for them.
    If it is off a 425,445,455 the yes it just mounts different and you need longer hoses.
    Good point. 400 can represent a large range of tractors and not all of them would work.
    TJR345 and Fozsey like this.


    JD Z950R 60" Deck with DFS Collection System

    JD X585, 54C deck,
    CTC Model X4750 F.E.L - Modified Imp Pressure Relief from 900 to 1175PSI, Power Flow and MC519 cart, 54-inch Quick-Hitch Front Blade, 47-inch Quick-Hitch Snow Blower, 3-pt hitch, HF Quick Hitch, Heavy Hitch, 48" box blade/rear blade, Dethacher, 3pt Sprayer

  12. Top | #10
    sennister's Avatar
    Join Date
    Dec 2015
    Last Online
    Today @ 06:21 AM
    Location
    Twin Cities, MN
    Posts
    2,238
    Thanks
    33
    Thanked 244 Times in 202 Posts
    Here is a thread on where I went through my X585.

    http://www.greentractortalk.com/foru...hing-x585.html

    on this post I had ripped apart the instrument cluster.

    http://www.greentractortalk.com/foru...ml#post1047665
    TJR345 and Fozsey like this.


    JD Z950R 60" Deck with DFS Collection System

    JD X585, 54C deck,
    CTC Model X4750 F.E.L - Modified Imp Pressure Relief from 900 to 1175PSI, Power Flow and MC519 cart, 54-inch Quick-Hitch Front Blade, 47-inch Quick-Hitch Snow Blower, 3-pt hitch, HF Quick Hitch, Heavy Hitch, 48" box blade/rear blade, Dethacher, 3pt Sprayer

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 3 1 2 3 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts