Cloudy instrument cluster on new x584
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Like Tree3Likes

Thread: Cloudy instrument cluster on new x584

  1. Top | #1
    ean
    ean is offline

    Join Date
    Sep 2018
    Last Online
    Yesterday @ 09:18 AM
    Location
    Madison, WI
    Posts
    68
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Cloudy instrument cluster on new x584

    So I'm very happy with my x584 and have just under 2 hours on it. When I finished mowing yesterday I noticed that my instrument cluster was cloudy. I thought maybe it just had an oil smudge on it but when I tried to clean it off it wasn't having any effect on it. There is very little humidity out here now that it's fall. I'm sure there must be some moisture that has gotten in (haven't ridden it in the rain, and it's stored in a dry shed). I didn't didn't appear until the end of my mowing (about 40 minutes). It's rather annoying to not have a clear instrument cluster (also being that it's brand new). Has anyone else experienced this? Any quick remedy for it? I'll see if I can get some pictures of it.

    For illustration it looked very similar to this (position and blur).
    Click image for larger version. 

Name:	screenshot_09-24-2018 14h35m_08s.png 
Views:	123 
Size:	115.8 KB 
ID:	650092

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    jgayman's Avatar
    Join Date
    Jul 2012
    Last Online
    Yesterday @ 10:25 PM
    Location
    Central Pennsylvania
    Posts
    9,798
    Thanks
    368
    Thanked 1,606 Times in 1,220 Posts
    Unfortunately it is normal. The previous dash with just the hour meter clouded up the same way. My X500 does it all the time and it is stored indoors and never left out in the rain.

    It should clear itself after a while.
    2012 2720 -- 200CX Loader -- 54" Quick Attach Snow Blower -- Frontier LR5060 Rake -- Land Pride RB1660 Blade (Hydraulic Angle) -- Artillian 42" Forks -- Ken's Bolt on Grab Hooks -- Fit Rite Hydraulic top-link -- 2013 X500 for mowing duties

  4. Top | #3
    99srxman's Avatar
    Join Date
    Jan 2017
    Last Online
    08-19-2019 @ 06:38 PM
    Location
    Richfield WI.
    Posts
    123
    Thanks
    21
    Thanked 11 Times in 11 Posts
    Hair dryer ??

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    BOBL's Avatar
    Join Date
    Aug 2018
    Last Online
    Yesterday @ 09:20 PM
    Location
    Boston north east
    Posts
    238
    Thanks
    0
    Thanked 28 Times in 24 Posts
    Almost 50 hours on my 580. Washed it twice with hose, driven it in the rain, store it in a shed, and we've had plenty of rain. No problems at all. Call the dealer.
    BigJim55 and firemachine69 like this.
    JD X738
    48" deck, 3pt hitch, 54" blade w/ full hydraulics, quick attach
    48" York rake, 56" box blade, mid row buster, dethatcher, aerator, 900lb roller
    Various Heavy Hitch adapters, ball hitch, hook, 2" sleeve hitch, etc..
    3200lb. hitch mounted winch
    Polar 1700 3/4 ton cart with side rails
    Power King 5" 15HP towable chipper

    Kubota G2000S w/ 4w steering, hydraulics, 60" deck

    Vietnam Veteran

  7. Top | #5
    ean
    ean is offline

    Join Date
    Sep 2018
    Last Online
    Yesterday @ 09:18 AM
    Location
    Madison, WI
    Posts
    68
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Noticed it a bit more today. I reached out to my dealer.

    Click image for larger version. 

Name:	IMG_20181004_175101.jpg 
Views:	10 
Size:	2.96 MB 
ID:	651634Click image for larger version. 

Name:	IMG_20181004_175846.jpg 
Views:	10 
Size:	3.22 MB 
ID:	651636
    BigJim55 likes this.

  8. Top | #6
    BOBL's Avatar
    Join Date
    Aug 2018
    Last Online
    Yesterday @ 09:20 PM
    Location
    Boston north east
    Posts
    238
    Thanks
    0
    Thanked 28 Times in 24 Posts
    Obviously a defective LCD. So why did you wait so long to contact the dealer?
    JD X738
    48" deck, 3pt hitch, 54" blade w/ full hydraulics, quick attach
    48" York rake, 56" box blade, mid row buster, dethatcher, aerator, 900lb roller
    Various Heavy Hitch adapters, ball hitch, hook, 2" sleeve hitch, etc..
    3200lb. hitch mounted winch
    Polar 1700 3/4 ton cart with side rails
    Power King 5" 15HP towable chipper

    Kubota G2000S w/ 4w steering, hydraulics, 60" deck

    Vietnam Veteran

  9. Top | #7
    ean
    ean is offline

    Join Date
    Sep 2018
    Last Online
    Yesterday @ 09:18 AM
    Location
    Madison, WI
    Posts
    68
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by BOBL View Post
    Obviously a defective LCD. So why did you wait so long to contact the dealer?
    lol, I went from reporting this at 1.8hrs to now 2.5hrs (It's been raining almost everyday here, so I havent used it much in a few weeks). Warranty goes for 4yrs/400hrs... Hardly waited that long to report it.

  10. Top | #8
    BOBL's Avatar
    Join Date
    Aug 2018
    Last Online
    Yesterday @ 09:20 PM
    Location
    Boston north east
    Posts
    238
    Thanks
    0
    Thanked 28 Times in 24 Posts
    Quote Originally Posted by ean View Post
    lol, I went from reporting this at 1.8hrs to now 2.5hrs (It's been raining almost everyday here, so I havent used it much in a few weeks). Warranty goes for 4yrs/400hrs... Hardly waited that long to report it.
    I get your point, but just thinking if it were me, and with hours on the tractor, I would have at least called the dealer, asked if they had the display module in stock, that sort of thing. Good luck with the fix.
    JD X738
    48" deck, 3pt hitch, 54" blade w/ full hydraulics, quick attach
    48" York rake, 56" box blade, mid row buster, dethatcher, aerator, 900lb roller
    Various Heavy Hitch adapters, ball hitch, hook, 2" sleeve hitch, etc..
    3200lb. hitch mounted winch
    Polar 1700 3/4 ton cart with side rails
    Power King 5" 15HP towable chipper

    Kubota G2000S w/ 4w steering, hydraulics, 60" deck

    Vietnam Veteran

  11. Top | #9
    ean
    ean is offline

    Join Date
    Sep 2018
    Last Online
    Yesterday @ 09:18 AM
    Location
    Madison, WI
    Posts
    68
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Tractor is coming back from the dealer today. They said they haven't see a lot of it but JD was aware of it. We'll see how it goes with the new display.

  12. Top | #10
    ean
    ean is offline

    Join Date
    Sep 2018
    Last Online
    Yesterday @ 09:18 AM
    Location
    Madison, WI
    Posts
    68
    Thanks
    0
    Thanked 2 Times in 2 Posts
    They should have set the hour meter to the number of hours on my tractor correct? It looks like they just skipped that installed it and set it out with 0.0 hours! Guess I have to remember that now for all of my service intervals. I had 3 hours on it, so not the end of the world but I thought I would have that at least.

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •