I'm having a problem with the forward pedal on my x495.
Results 1 to 6 of 6

Thread: I'm having a problem with the forward pedal on my x495.

  1. Top | #1

    Join Date
    Feb 2019
    Last Online
    02-20-2019 @ 08:26 PM
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I'm having a problem with the forward pedal on my x495.

    The forward pedal is sticking when I push the pedal down and release. I have to pull the pedal back in order to stop. Do I need to grease something?

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    May 2014
    Last Online
    09-03-2019 @ 10:10 PM
    Location
    Denver, CO
    Posts
    78
    Thanks
    2
    Thanked 11 Times in 9 Posts
    I had a similar problem with my GX345 this past fall which turned out to be the shock absorber on transaxle. I believe it's called a control arm damper on your transaxle. I replaced it and problem solved. I was able to disconnect the damper on mine to verify that was the issue before I replaced it.

    Your X495 and the GX345 are different animals but that is where I would start - assuming you have ruled out the obvious such as debris on the control rods, binding with the foot wells, etc.

    Good luck.

  4. The Following User Says Thank You to denverguy For This Useful Post:

    xcopterdoc (02-21-2019)

  5. Top | #3
    Captain Hook Kennyd's Avatar
    Join Date
    Aug 2010
    Last Online
    Today @ 07:04 PM
    Location
    Westminster, MD
    Posts
    16,268
    Thanks
    4,998
    Thanked 4,035 Times in 2,514 Posts
    There are linkages under there that need to be lubricated, your going to have to take the deck off and get under there to see everything.
    Attached Thumbnails Attached Thumbnails Capture.PNG  
    Kenny

    -John Deere 3720 Deluxe Cab TLB
    FEL, MMM, Artillian 42" Forks and Modular Grapple, I-Match, Ballast Box, and lots of other STUFF.
    -John Deere 455 w/60" MMM


    Bolt on Grab Hooks and other cool stuff are now for sale!!

    Visit our YouTube Channel

    My Equipment:
    John Deere 3720 Deluxe Cab, 300cx FEL, 366 Front Blade, 59" Front Snowblower, Ballast Box
    Artillian 3K Forks, Grapple, Front-Hoe Bucket
    John Deere 455, 60" MMM

  6. The Following User Says Thank You to Kennyd For This Useful Post:

    celltech (02-24-2019)

  7. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  8. Top | #4

    Join Date
    Mar 2016
    Last Online
    Today @ 05:24 PM
    Location
    Between Missouri & Kansas
    Posts
    297
    Thanks
    0
    Thanked 33 Times in 28 Posts
    Right under the right side foot pedal stand, is a "Torsion Spring" that connects to the bracket the Forward Foot pedal. This spring keeps the Forward Pedal centered on the tractor. Check to see if it had broken or came loose.

  9. Top | #5

    Join Date
    Oct 2018
    Last Online
    08-12-2019 @ 05:03 PM
    Location
    NW Minnesota
    Posts
    30
    Thanks
    1
    Thanked 1 Time in 1 Post
    Quote Originally Posted by kbeaag View Post
    Right under the right side foot pedal stand, is a "Torsion Spring" that connects to the bracket the Forward Foot pedal. This spring keeps the Forward Pedal centered on the tractor. Check to see if it had broken or came loose.

    Is that spring #31 in kennyd's post?
    Last edited by celltech; 02-24-2019 at 08:27 AM.

  10. Top | #6

    Join Date
    Mar 2016
    Last Online
    Today @ 05:24 PM
    Location
    Between Missouri & Kansas
    Posts
    297
    Thanks
    0
    Thanked 33 Times in 28 Posts
    Quote Originally Posted by celltech View Post
    Is that spring #31 in kennyd's post?



    That would be correct. It's the only spring in that area.

  11. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Similar Threads

  1. X495 Park Brake Latch and brake pedal not working
    By fv43576 in forum Lawn & Garden Tractors
    Replies: 3
    Last Post: 07-02-2018, 09:10 PM
  2. 1025r Hydrostatic Pedal Problem - Always moving forward
    By Richard_P_Harvey in forum Sub Compact Utility Tractors (SCUT)
    Replies: 15
    Last Post: 12-16-2017, 02:43 PM
  3. My 1023 doesn't stop right away after you take you foot off the forward pedal....
    By tommott77 in forum Sub Compact Utility Tractors (SCUT)
    Replies: 10
    Last Post: 05-03-2017, 03:26 PM
  4. Replies: 3
    Last Post: 10-21-2016, 07:37 AM
  5. New guy having trouble with forward gear on a JD 300
    By MNJD300 in forum Vintage Lawn & Garden Tractors
    Replies: 5
    Last Post: 08-29-2014, 01:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •