X390 Hyd Lift Issue
Results 1 to 2 of 2

Thread: X390 Hyd Lift Issue

  1. Top | #1

    Join Date
    Apr 2019
    Last Online
    04-11-2019 @ 02:08 PM
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    X390 Hyd Lift Issue

    Have a 3 year old X390 with hyd mower deck lift. Started leaking hydraulic oil yesterday and I found the cylinder was "rubbing" on the corner of the frame where it sits. This caused a real defined slit in the end of the cylinder and eventually cut deep enough into the weld that it is now leaking oil. Looking at the problem, I gotta believe it's an inherent issue with the design and was wondering if anyone else has had this problem. A new cylinder is $350 but I'm waiting to hear if it's covered by warranty. 4 year bumper to bumper I believe. It's an easy enough fix though, clean and grind down the weld and repair it, however since there's only 175hrs on the mower, I think it should be replaced. I plan on grinding the edge of the frame down so it will no longer contact the cylinder along with a piece of rubber or something to insulate it. Either poor design or bad luck on my part, not sure. Anyone else?

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Jun 2013
    Last Online
    Yesterday @ 10:20 PM
    Location
    Southern Maine
    Posts
    7,282
    Thanks
    592
    Thanked 686 Times in 576 Posts
    Quote Originally Posted by GregX390 View Post
    Have a 3 year old X390 with hyd mower deck lift. Started leaking hydraulic oil yesterday and I found the cylinder was "rubbing" on the corner of the frame where it sits. This caused a real defined slit in the end of the cylinder and eventually cut deep enough into the weld that it is now leaking oil. Looking at the problem, I gotta believe it's an inherent issue with the design and was wondering if anyone else has had this problem. A new cylinder is $350 but I'm waiting to hear if it's covered by warranty. 4 year bumper to bumper I believe. It's an easy enough fix though, clean and grind down the weld and repair it, however since there's only 175hrs on the mower, I think it should be replaced. I plan on grinding the edge of the frame down so it will no longer contact the cylinder along with a piece of rubber or something to insulate it. Either poor design or bad luck on my part, not sure. Anyone else?
    See what the dealer does. Deere May have an approved fix to prevent recurrence. It may not involve grinding the frame.

  4. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Similar Threads

  1. Accessories for X390
    By twodogs603 in forum Lawn & Garden Tractors
    Replies: 9
    Last Post: 02-17-2017, 08:29 PM
  2. X390, 48 inch deck, design issue!
    By fishrman in forum Lawn & Garden Tractors
    Replies: 21
    Last Post: 08-18-2016, 04:28 PM
  3. 60D Hyd lift, hair pin popped out
    By 56Nine in forum Implements & Attachments
    Replies: 3
    Last Post: 07-19-2016, 06:17 AM
  4. Hyd line routing for mmm lift.
    By etcallhome in forum Sub Compact Utility Tractors (SCUT)
    Replies: 8
    Last Post: 11-12-2014, 08:35 PM
  5. Independent lift hyd. hose would not connect
    By JDPilot in forum Sub Compact Utility Tractors (SCUT)
    Replies: 10
    Last Post: 08-09-2012, 06:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •