Moisture instrument cluster x700 series, 2016 x738
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Like Tree9Likes

Thread: Moisture instrument cluster x700 series, 2016 x738

  1. Top | #1

    Join Date
    Nov 2016
    Last Online
    Yesterday @ 05:26 PM
    Location
    Southeast Nebraska
    Posts
    182
    Thanks
    54
    Thanked 9 Times in 4 Posts

    Moisture instrument cluster x700 series, 2016 x738

    I know it has been brought up before in the past. It was posted before that Deere won't cover it under warranty. So I called they dealer today to see it they knew about the problem. My Dealer was not aware of this issue. They said they would order a new cluster and replace it under warranty. I will see if it gets replaced when the new cluster shows up.
    The issue started last summer with moisture. Now it is worst this year when it is exposed to the sun. I could not even read the cluster because of all the moisture inside.
    kylew likes this.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    SulleyBear's Avatar
    Join Date
    Oct 2014
    Last Online
    Yesterday @ 02:18 PM
    Location
    Beautiful beaches, moderated summer heat and lake effect snows. Right where I want to be.
    Posts
    6,574
    Thanks
    1,346
    Thanked 2,326 Times in 1,315 Posts
    Quote Originally Posted by ultra7350 View Post
    I know it has been brought up before in the past. It was posted before that Deere won't cover it under warranty. So I called they dealer today to see it they knew about the problem. My Dealer was not aware of this issue. They said they would order a new cluster and replace it under warranty. I will see if it gets replaced when the new cluster shows up.
    The issue started last summer with moisture. Now it is worst this year when it is exposed to the sun. I could not even read the cluster because of all the moisture inside.
    What was the delivery date on your machine?

    How many hours are on it?

    It's always best to present your situation on your machine to your service manager at the dealer you work with. While there are some very clear cut cases where items have been not covered under warranty, if your machine is within the time frame and hours of the warranty period, its always a good idea to ask about the issue you are having with your machine.

    Not only does it not cost anything to ask, there might have been other circumstances in the rejection of someone else's claim which don't apply in your situation. Nothing ventured, nothing gained.......

    The dash unit is not a low cost item. Do you have an idea of how or where the moisture is getting in the dash unit?

    If you could, post a picture of how it looks, just for others to see the severity.

    Good luck with the repair and make sure to let us know how it turns out.
    kylew likes this.

    1025R with Mauser Cab
    (10/2017)/ 120R FEL / RC2048 Mower / All of Ken's Bolt on Products / 60" HD Front Broom / 3 pt 45 Gallon Boom less Sprayer / CA2068 Core Aerator / I-Match / 54" Snow Plow w/ angling Quick Attach / Frontier 3 Pt Sprayer / Pallet Forks / 8 -42# Weights

    John Deere 455 (New in 9/1996) / MC519 Cart /60" MMM /47" Snow Thrower / 7'3" snow plow / Quick Hitch /
    4 -42# Weights / JD#10 Cart

    ExMark Lazer Z w/60" Deck , Billy Goat Blower , Full Stable of Echo Products





  4. Top | #3

    Join Date
    Nov 2016
    Last Online
    Yesterday @ 05:26 PM
    Location
    Southeast Nebraska
    Posts
    182
    Thanks
    54
    Thanked 9 Times in 4 Posts
    Date of service 10/16 with 85 hours.
    This is the first time I ever called the dealer about warranty work. He was nice enough to offer pickup and drop off for free since I bought it from there. He even told me if I have any other warranty issues that I could think of since they will have it.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Nov 2017
    Last Online
    06-01-2019 @ 02:33 PM
    Location
    Everywhere
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Lol it's normal and has been for years now.
    ejb69 likes this.

  7. Top | #5
    arlen's Avatar
    Join Date
    Apr 2012
    Last Online
    Yesterday @ 11:21 PM
    Location
    South East Minnesota
    Posts
    3,103
    Thanks
    327
    Thanked 409 Times in 308 Posts
    Quote Originally Posted by Subdivisionbigdog View Post
    Lol it's normal and has been for years now.
    What's normal?...That dealers are fixing it under warranty, or that it's normal for moisture to accumulate inside the cluster?
    SulleyBear likes this.
    4720 66hp Open Station, Power Beyond, 3rd, 4th and 5th Rear SCV, iMatch, 400cx with SSQA, 3rd Loader Function, MX6, BoDozer Grapple
    JD 320D Skid Loader
    Gator 865r...Fully Pimped Out

    X748SE 24hp, 647 Tiller, 54" front blade, 47 Snow Blower, 62C deck, JD disk

    JD 997 Zero Turn

    Farmall B

    2 miniature donkeys, 1/8 hp (each)

  8. Top | #6
    SulleyBear's Avatar
    Join Date
    Oct 2014
    Last Online
    Yesterday @ 02:18 PM
    Location
    Beautiful beaches, moderated summer heat and lake effect snows. Right where I want to be.
    Posts
    6,574
    Thanks
    1,346
    Thanked 2,326 Times in 1,315 Posts
    Quote Originally Posted by arlen View Post
    What's normal?...That dealers are fixing it under warranty, or that it's normal for moisture to accumulate inside the cluster?
    I hope it's the dealers fixing it as I sure wouldn't tolerate any moisture obstructing anything in the dash......

    1025R with Mauser Cab
    (10/2017)/ 120R FEL / RC2048 Mower / All of Ken's Bolt on Products / 60" HD Front Broom / 3 pt 45 Gallon Boom less Sprayer / CA2068 Core Aerator / I-Match / 54" Snow Plow w/ angling Quick Attach / Frontier 3 Pt Sprayer / Pallet Forks / 8 -42# Weights

    John Deere 455 (New in 9/1996) / MC519 Cart /60" MMM /47" Snow Thrower / 7'3" snow plow / Quick Hitch /
    4 -42# Weights / JD#10 Cart

    ExMark Lazer Z w/60" Deck , Billy Goat Blower , Full Stable of Echo Products





  9. Top | #7

    Join Date
    Jul 2018
    Last Online
    Yesterday @ 08:09 PM
    Location
    South Eastern, Connecticut
    Posts
    299
    Thanks
    3
    Thanked 42 Times in 38 Posts
    I thought that moisture in the dash was a design feature.

    It seems like they all have it it must have been on purpose.
    ejb69 and arlen like this.
    X738, 54HC deck w/ auto connect, 3PH
    Woods GBC48 box scraper
    Day dreaming of a 54" snow blower

  10. Top | #8
    jgayman's Avatar
    Join Date
    Jul 2012
    Last Online
    Yesterday @ 09:10 PM
    Location
    Central Pennsylvania
    Posts
    9,243
    Thanks
    352
    Thanked 1,483 Times in 1,126 Posts
    Quote Originally Posted by CJadamec View Post
    I thought that moisture in the dash was a design feature.

    It seems like they all have it it must have been on purpose.
    I think you are right. Even the small hour meter display on my X500 is usually fogged up while the tractor is in operation, making it almost impossible to read.
    2012 2720 -- 200CX Loader -- 54" Quick Attach Snow Blower -- Frontier LR5060 Rake -- Land Pride RB1660 Blade (Hydraulic Angle) -- Artillian 42" Forks -- Ken's Bolt on Grab Hooks -- Fit Rite Hydraulic top-link -- 2013 X500 for mowing duties

  11. Top | #9
    etcallhome's Avatar
    Join Date
    Jan 2011
    Last Online
    Yesterday @ 10:31 PM
    Location
    Preston County WV
    Posts
    13,040
    Thanks
    3,151
    Thanked 2,298 Times in 1,509 Posts
    I was told Deere WOULD NOT REPLACE the dash on Harleys x738.. that was 2 years ago.
    Gene

    Have fun and be safe !!!
    USAR 8yr 8 mo SSG 99th ARCOM
    JD 1025R, H120 FEL 54" bucket, 54" mmm Auto Conn, 54" Front blade, JD back hoe ,JD IMatch, 48" Bush Hog tiller, Middlebuster from MF dealer, used King Kutter 5' rear blade, a new 47" JD Front blower and Original Tractor cab w/heater.
    We have a Red Honda Pioneer 700-4 (4 seater) w/soft top , doors, and winch.

  12. Top | #10

    Join Date
    Jan 2012
    Last Online
    Yesterday @ 09:32 PM
    Location
    East Central Indiana
    Posts
    1,430
    Thanks
    89
    Thanked 239 Times in 171 Posts
    I mowed with my X739 today. I started before lunch. There was no moisture on the dash when I started. I stopped for lunch, the mower set out in the sun for about an hour. When I went back to start mowing again, there was now moisture under the dash glass.
    etcallhome likes this.
    Kioti CK3510SE HST, Kioti KL4030 Loader, John Deere 655 Tiller, Frontier LR2072 Landscape Rake, Virnig V50 Pallet Forks, Woods GB60 Box Blade
    John Deere X739 AWS 4X4, 60HC Auto Connect Deck, Front grader blade.
    John Deere 825i Gator

    John Deere Tractors I have owned in the past.
    425 AWS, 455, 4400, 2210, 4710, 2320, 2720, X475, 1026R, 4120, 2025R

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Wiring diagram for x495 instrument cluster plug
    By eversr007 in forum Lawn & Garden Tractors
    Replies: 10
    Last Post: 03-27-2018, 02:33 PM
  2. Instrument cluster icon 'bagger full'?
    By BigBlue in forum Lawn & Garden Tractors
    Replies: 4
    Last Post: 02-06-2018, 08:34 PM
  3. Instrument cluster removal 1025r help
    By tsdunay in forum Sub Compact Utility Tractors (SCUT)
    Replies: 7
    Last Post: 10-21-2017, 06:50 PM
  4. Instrument cluster question
    By UBNT in forum Sub Compact Utility Tractors (SCUT)
    Replies: 14
    Last Post: 04-07-2017, 11:57 PM
  5. 1025R Instrument cluster clouding up turning white???
    By Mb190e in forum Sub Compact Utility Tractors (SCUT)
    Replies: 12
    Last Post: 10-03-2016, 08:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •