new to the forum have a X720 and a few questions
Results 1 to 5 of 5

Thread: new to the forum have a X720 and a few questions

  1. Top | #1

    Join Date
    Jun 2019
    Last Online
    07-12-2019 @ 10:13 PM
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    new to the forum have a X720 and a few questions

    Hello everyone...I have had my X720 for approx. 3 years and it has approx. 420 hours on it. I have performed all of the required maintenance at the appropriate intervals and it has run well. However, I do have a problem with it starting as well as a few other questions. I hope it is OK to ask all the questions in the same post, if not just let me know and I'll start a thread for each question

    - the low oil light is on and I checked the oil and it is fine. I changed the oil at 400 hours and there was no light. any idea why it is on? also, could the sensor be causing my hard to start problem noted below?


    - recently it has been hard to start and this weekend it would not start, it would turn over, but would not start. I pulled the plugs and they looked fine and I checked the spark and it looked fine as well. It did not run out of fuel, but since I didn't smell any gas I went ahead and loosened the fuel screw that the manual talks about in the event you run out of gas. I also checked the air filter and the oil and no issues. after each of these I tried to start it and nothing. However about 10 minutes later it did start and started all weekend fine. Any thoughts?

    - I have a snow blade and a mower deck and I am not sure in what position the hydraulic valve (lockout or by-pass) should be in when I am using these attachments?

    - I am also having a hard time getting the parking brake to release, I have to try it several times (pushing brake pedal and release handle down before it will finally release, any thoughts?

    Thanks in advance for any suggestions

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    goat704!'s Avatar
    Join Date
    Feb 2018
    Last Online
    07-02-2019 @ 08:40 AM
    Location
    South Saint Paul,Mn.
    Posts
    423
    Thanks
    101
    Thanked 54 Times in 39 Posts
    from MN
    2017 2032R - 220r FEL, 72" mmm,Frontier 2084 blade ,JD 670 tiller, frontier 48" pallet forks, allied 2060 snowblower,JD 513 brush hog, EA 55" grapple,Frontier 2060 box blade, Farmi 351p logging winch
    LX 186 - 48" deck, 38" snowblower
    F 510
    GTX 38
    Cub Cadet GTX 1054
    2011 825i Gator

  4. Top | #3

    Join Date
    Aug 2010
    Last Online
    Today @ 08:04 AM
    Location
    Maryland
    Posts
    63
    Thanks
    22
    Thanked 5 Times in 5 Posts
    Welcome to the forum. When attempting to start, do you hear the fuel pump run when you turn the key on? From what I've heard a lot of hard start or no start issues are cause by a bad fuel pump, that could be a suspect. Might be worth picking up a technical manual for the tractor. The low oil may be a faulty sensor, though I don't think it would cause your hard to start issue.

    Rick
    2017 JD X758 54HC deck, 54" front blade, Reugg Cat1 3pt, & Front Fenders
    2018 JD 3039r Deluxe Cab w/ Air Ride Seat & Mid PTO, 320r Loader w/ HD bucket, 72D deck, Horst Forks, Ballast Box, Landpride FDR 2584

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    bloodrunsgreen's Avatar
    Join Date
    Feb 2015
    Last Online
    Today @ 10:55 AM
    Location
    Mid-Michigan
    Posts
    454
    Thanks
    14
    Thanked 54 Times in 52 Posts
    Did you get the operators manual with the tractor? If not, it is available as a online version.

    Here is the link: OMM157070_I7

  7. Top | #5

    Join Date
    Jun 2019
    Last Online
    07-12-2019 @ 10:13 PM
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thanks for the welcomes and the info


    - yes the I hear the fuel pump when I turn the key
    - I do have the owners manual, but not the technical/shop manual

    again....appreciate any insight on any of the issues.....Thanks

  8. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts