SST15 lost steering
Results 1 to 5 of 5

Thread: SST15 lost steering

  1. Top | #1

    Join Date
    Aug 2011
    Last Online
    11-23-2011 @ 12:11 PM
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    SST15 lost steering

    I have a SST15 that without any notice just stopped turning left or right.... it will go forward and backwards but will not turn at all moving forward or reverse...I have replaced the little filters on the two actuators but no luck

    Any help here please!
    Last edited by scottybb; 08-23-2011 at 10:01 AM. Reason: Mispelled

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    kjung17's Avatar
    Join Date
    Apr 2011
    Last Online
    03-19-2013 @ 06:20 PM
    Location
    Sainte Genevieve, Missouri, United States
    Posts
    311
    Thanks
    0
    Thanked 14 Times in 10 Posts
    I believe that machine relies on vacuum to turn. Check your vacuum hoses from the steering logic to the engine.
    Thanks,
    Kevin

    Master Service Technician, John Deere AG, North America
    Advanced Service Technician, John Deere C&CE, North America

    We, the unwilling, led by the unknowing, have done so much, for so long, with so little that we can now do anything with nothing.

  4. Top | #3

    Join Date
    Aug 2011
    Last Online
    11-23-2011 @ 12:11 PM
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    While it is running I can remove vacuum hoses and can feel suction from any hose???

    Thanks for the suggestion

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Aug 2011
    Last Online
    11-23-2011 @ 12:11 PM
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have found that when the battery is fully charged it works fine so my guess is I need a new battery and that will cure my issue. After charging it I mowed the yard no problem

  7. Top | #5
    RandyM's Avatar
    Join Date
    Sep 2010
    Last Online
    03-14-2017 @ 10:30 AM
    Location
    Stoughton, Wisconsin
    Posts
    6,594
    Thanks
    1,047
    Thanked 1,057 Times in 671 Posts
    Those darn batteries seem to cause all kinds of seemingly unrelated problems. Glad you found your problem and it is a simple fix. Thanks for the up date.
    Randy __________________________________________________ ___ Be Safe!

    2009 - 2305 w/62 MMM **** 2008 - 2520 w/72 MMM **** 200CX w/49 bucket
    Weight Box w/extension ***** LandPride RTR 1558 Tiller ******* 54 Snow blower
    60 Gallon Demco Sprayer *** 60 Broom ** BB2060 Box Blade**SS2036B Spreader
    Everything Attachments ETA-PluggerV2-60 Aerator

    The more I learn, the less I know.

  8. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Similar Threads

  1. Missy the lost cat.....
    By Brian in forum Off Topic
    Replies: 5
    Last Post: 10-26-2011, 11:35 PM
  2. sort of lost my username
    By dutch in forum Off Topic
    Replies: 9
    Last Post: 08-25-2011, 04:44 PM
  3. Replies: 10
    Last Post: 06-12-2011, 09:27 PM
  4. help with steering please
    By new2deere in forum New Member Introductions
    Replies: 0
    Last Post: 03-15-2011, 04:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •