L120 riding mower will not start
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: L120 riding mower will not start

  1. Top | #1

    Join Date
    Aug 2015
    Last Online
    08-30-2015 @ 05:02 PM
    Location
    United States
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    L120 riding mower will not start

    Mower will not start. Does not even begin to turn over. It acts like a safety switch is bad. Hiwever, i have replaced brake, pto, and seat safety switches. battery is good and i have traced all wiring and connections as best i can. Any help????

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    dzldanz's Avatar
    Join Date
    Dec 2014
    Last Online
    04-18-2019 @ 07:01 AM
    Location
    Ottawa,Stittsville,Ontario
    Posts
    404
    Thanks
    86
    Thanked 41 Times in 35 Posts
    OK I'll start the replies.
    What's your battery voltage reading?
    Current: 3320 HST cab with 59" front blower, Hydraulic chute deflector, Vertical Exhaust, Front Fenders,
    Grooved and loaded Front and Rear R-4's
    External Mirrors, Jensen Bluetooth Radio / Headset. Front Hydraulics
    Whelen warning lights, JD366 front blade
    Gone: X595 with heated cozy cab,stainless vertical exhaust

  4. Top | #3

    Join Date
    Aug 2015
    Last Online
    08-30-2015 @ 05:02 PM
    Location
    United States
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Have not taken a reading, but i have tried to jump start just to ensure its not battery. Battery was only 3 mos old when prob started

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    dzldanz's Avatar
    Join Date
    Dec 2014
    Last Online
    04-18-2019 @ 07:01 AM
    Location
    Ottawa,Stittsville,Ontario
    Posts
    404
    Thanks
    86
    Thanked 41 Times in 35 Posts
    Can you hear the starter relay clicking?
    Current: 3320 HST cab with 59" front blower, Hydraulic chute deflector, Vertical Exhaust, Front Fenders,
    Grooved and loaded Front and Rear R-4's
    External Mirrors, Jensen Bluetooth Radio / Headset. Front Hydraulics
    Whelen warning lights, JD366 front blade
    Gone: X595 with heated cozy cab,stainless vertical exhaust

  7. Top | #5

    Join Date
    Aug 2015
    Last Online
    08-30-2015 @ 05:02 PM
    Location
    United States
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Negative. There is nothing. The headlights come on and that is it

  8. Top | #6

    Join Date
    Sep 2014
    Last Online
    Today @ 12:32 PM
    Location
    West Michigan
    Posts
    1,896
    Thanks
    94
    Thanked 219 Times in 175 Posts
    Quote Originally Posted by newtoncd13 View Post
    Negative. There is nothing. The headlights come on and that is it
    Another member here with an L series recently had a similar issue-he had a bad fuse.
    2004-L130

    2013-2032r, Curtis Hard side cab (project), H130 FEL & 61"bucket, Artillian Modular Grapple on HD frame with Diverter, 2300# Artillian frame w/ 36" x 3" tines, 46BH 9" & 13" bucket, Frontier RB1060, HLA 1000 series 60" JDQA Snow plow, JD ballast box, RK QH, Homemade 3pt multi purpose hitch, 117W of extra LED lights on ROPS and side Brush guards, Ken's bolt on hooks-3x, Ideal Knife grooved R-4's.

  9. Top | #7

    Join Date
    Aug 2015
    Last Online
    08-30-2015 @ 05:02 PM
    Location
    United States
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by balrog006 View Post
    Another member here with an L series recently had a similar issue-he had a bad fuse.
    I had also replaced the fuse, just in case.

  10. Top | #8
    dzldanz's Avatar
    Join Date
    Dec 2014
    Last Online
    04-18-2019 @ 07:01 AM
    Location
    Ottawa,Stittsville,Ontario
    Posts
    404
    Thanks
    86
    Thanked 41 Times in 35 Posts
    Is their power getting to the starter relay trigger terminal when trying to start?
    Current: 3320 HST cab with 59" front blower, Hydraulic chute deflector, Vertical Exhaust, Front Fenders,
    Grooved and loaded Front and Rear R-4's
    External Mirrors, Jensen Bluetooth Radio / Headset. Front Hydraulics
    Whelen warning lights, JD366 front blade
    Gone: X595 with heated cozy cab,stainless vertical exhaust

  11. Top | #9

    Join Date
    Aug 2015
    Last Online
    08-30-2015 @ 05:02 PM
    Location
    United States
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i jumped the solenoid and it turns over. I think i have found the problem

  12. Top | #10

    Join Date
    Sep 2014
    Last Online
    Today @ 12:32 PM
    Location
    West Michigan
    Posts
    1,896
    Thanks
    94
    Thanked 219 Times in 175 Posts
    Quote Originally Posted by newtoncd13 View Post
    i jumped the solenoid and it turns over. I think i have found the problem
    hope that's it!
    2004-L130

    2013-2032r, Curtis Hard side cab (project), H130 FEL & 61"bucket, Artillian Modular Grapple on HD frame with Diverter, 2300# Artillian frame w/ 36" x 3" tines, 46BH 9" & 13" bucket, Frontier RB1060, HLA 1000 series 60" JDQA Snow plow, JD ballast box, RK QH, Homemade 3pt multi purpose hitch, 117W of extra LED lights on ROPS and side Brush guards, Ken's bolt on hooks-3x, Ideal Knife grooved R-4's.

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •