X300 Question
Results 1 to 3 of 3

Thread: X300 Question

  1. Top | #1

    Join Date
    Aug 2011
    Last Online
    10-18-2011 @ 07:27 PM
    Location
    Central Illinois
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    X300 Question

    I just bought me a used 2006 X300 with 460 hours. My question is it seems really slow compared to my old LT160, the specs on the 160 says the top speed is 5.8 mph compared to the X300 which says it's top speed is 5.5 mph. Is there any way to adjust the speed or is it being rather slow telling me there may be some other transmission related problems?

    Maybe it's just my imagination.

    Thanks ahead of time for any help or advice.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    Brian's Avatar
    Join Date
    Aug 2010
    Last Online
    06-05-2014 @ 02:22 PM
    Location
    Bay City, Michigan
    Posts
    3,571
    Thanks
    50
    Thanked 333 Times in 213 Posts
    Wow, you would not think you could notice .3 mph. How do the linkages work? Do they feel stiff or like something is not moving like it should? I would also check and see how the hydro fluid looks. You never know if it has been changed or if the filter has been changed. I could be speaking out of turn here because something tells me that the x300 trans is not serviceable?

    Someone with more knowledge will speak up soon.



    Brian

  4. Top | #3

    Join Date
    Jun 2011
    Last Online
    08-20-2015 @ 12:26 PM
    Location
    Georgia
    Posts
    84
    Thanks
    5
    Thanked 16 Times in 9 Posts
    Murph,

    The transmission is a sealed unit. I would check the drive belt for wear. It could be slipping.
    or
    The pedal linkage may be worn and needs to be adjusted.

    Just my S.W.A.G.

    GotDeeres
    [

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Similar Threads

  1. Snow plow for the X300
    By js5020 in forum Lawn & Garden Tractors
    Replies: 2
    Last Post: 12-21-2011, 04:53 AM
  2. Considering a new X300 w/48" deck.
    By Dave T in forum Lawn & Garden Tractors
    Replies: 36
    Last Post: 11-04-2011, 10:39 AM
  3. D110 vs X300
    By luxury1 in forum Lawn & Garden Tractors
    Replies: 2
    Last Post: 07-23-2011, 02:30 PM
  4. Part fell off X300 mower
    By Quinn in forum Lawn & Garden Tractors
    Replies: 2
    Last Post: 06-26-2011, 09:33 PM
  5. new x300 question
    By Barry Z in forum Lawn & Garden Tractors
    Replies: 4
    Last Post: 06-24-2011, 06:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •