445 Front Lift Float Issue
Results 1 to 7 of 7

Thread: 445 Front Lift Float Issue

  1. Top | #1

    Join Date
    Nov 2014
    Last Online
    06-20-2017 @ 06:30 PM
    Location
    United States
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    445 Front Lift Float Issue

    Float mode on the blade/snow blower attachment lift won't engage. It doesn't want to free up this year.
    Any suggestions on what to look for?

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    Kloudbuster's Avatar
    Join Date
    Jun 2013
    Last Online
    09-20-2019 @ 06:21 PM
    Location
    ct.
    Posts
    80
    Thanks
    46
    Thanked 7 Times in 6 Posts
    Did you try a little lube on all the links and work it back and forth. That has always worked for me but it can take a little while.

    Sent from my XT1254 using Tapatalk

  4. Top | #3

    Join Date
    Nov 2014
    Last Online
    06-20-2017 @ 06:30 PM
    Location
    United States
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Kloudbuster View Post
    Did you try a little lube on all the links and work it back and forth. That has always worked for me but it can take a little while.

    Sent from my XT1254 using Tapatalk
    By links do you mean linkage?
    Down under or up high?

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    Kloudbuster's Avatar
    Join Date
    Jun 2013
    Last Online
    09-20-2019 @ 06:21 PM
    Location
    ct.
    Posts
    80
    Thanks
    46
    Thanked 7 Times in 6 Posts
    Yes, linkage points. Does everything move freely

    Sent from my XT1254 using Tapatalk

  7. Top | #5

    Join Date
    Jan 2015
    Last Online
    06-04-2016 @ 10:11 PM
    Location
    NC OHIO; Go BUCKEYES!!!
    Posts
    144
    Thanks
    2
    Thanked 10 Times in 10 Posts
    It took a hammer and lube on some moving parts on Dad's 425 to get freed up. It did feel like we were gonna brake off the valve lever doing so. But we got it to work.

  8. Top | #6

    Join Date
    Nov 2014
    Last Online
    06-20-2017 @ 06:30 PM
    Location
    United States
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks guys.
    I'll get out there tomorrow.

  9. Top | #7

    Join Date
    Nov 2014
    Last Online
    06-20-2017 @ 06:30 PM
    Location
    United States
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    A remotely related question I put elsewhere http://www.greentractortalk.com/foru...-question.html

  10. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •