New member with 6420s problems.
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: New member with 6420s problems.

  1. Top | #1

    Join Date
    Oct 2014
    Last Online
    10-26-2014 @ 02:54 PM
    Location
    UK
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    New member with 6420s problems.

    Hi everyone I am from the UK and recently traded my 2003 6300 in for an 05 6420s.

    I bought the tractor with a starting issue that the seller sorted out. The glow plug light was flashing with the warning light and the tractor really struggled to start. He fixed the issue and said it was the crank sensor, he replaced with a new one and gave the tractor a service.

    Today has been my first day I have used it properly and started hauling.
    The same warning lights have come up again, the tractor starts but not immediately. I don't think the battery is much good anymore.
    Does anyone have any ideas to what this could be?

    Cheers
    Alex

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    GTT's Pilot in Command (PIC) farmgirl19's Avatar
    Join Date
    Apr 2013
    Last Online
    @
    Location
    Texas
    Posts
    8,562
    Thanks
    1,503
    Thanked 1,149 Times in 751 Posts
    Unfortunately, I cannot help with the issue that you are having, but still wanted to say.....

    If man had enough horse sense to treat his wife like a Thoroughbred, she'd never grow into an old nag.

    If you climb in the saddle, be ready for the ride!

    Happiness is contagious; Be a carrier!

  4. Top | #3
    felixm22's Avatar
    Join Date
    May 2013
    Last Online
    10-04-2019 @ 02:29 PM
    Location
    Concord, NH
    Posts
    3,964
    Thanks
    320
    Thanked 453 Times in 340 Posts
    Welcome from WV.


    Sent from my iPhone using Tapatalk
    John Deere 318, 50in deck, 54in blade w/ power angle

    Looking for JD Parts check here on JD's official parts website.

    Have no idea where to start with JD Parts check here for a how to.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    Tomfive's Avatar
    Join Date
    Dec 2011
    Last Online
    Yesterday @ 08:22 PM
    Location
    Mid-Hudson Valley, NY
    Posts
    4,186
    Thanks
    97
    Thanked 608 Times in 473 Posts


    Welcome from New York. I hope you get the problems ironed out in your "new to you" tractor.
    Tom

    2011 1026R/R4's -- H120 FEL/49" -- 260 BH/12" -- Bro-Tek Ripper -- Artillian Forks/42" -- 244 lbs JD Rear Wheel Weights -- KBOH Hooks and Clevis' --
    Block heater -- 180* T-stat -- Evans HP Waterless Coolant

  7. Top | #5
    glc
    glc is offline
    glc's Avatar
    Join Date
    Sep 2010
    Last Online
    Yesterday @ 07:19 PM
    Location
    Big Beaver,Pa
    Posts
    5,259
    Thanks
    522
    Thanked 404 Times in 362 Posts
    Greg from western pa



    2009 2520
    FEL/61" HD bucket/replaceable cutting edge
    62D2 MMM
    IMatch Quick Hitch
    A "REAL" snow blade ---- JD 380A modded to fit
    Homemade 3PT Receiver
    Homemade Ballast Box
    Woods GB65 Box Blade

    2019 JOHN DEERE X390 with 48" ACCEL DEEP DECK

    MY 2520 SE SEAT MOD:

    https://www.greentractortalk.com/for...d-for-the-2520

    MY BALLAST BOX
    https://www.greentractortalk.com/for...llast-box.html

  8. Top | #6
    Texkev's Avatar
    Join Date
    Sep 2013
    Last Online
    06-13-2016 @ 08:14 AM
    Location
    Texas
    Posts
    1,139
    Thanks
    131
    Thanked 260 Times in 114 Posts
    Kevin

    Diesel Fuel Lube Group Buy - Opti-Lube Diesel Fuel Additives

    Bale Supply - Hay & Ranching Supplies

    Green Tractor Talk - John Deere Online Community

    JD Tech Talk - John Deere Blog

  9. Top | #7
    etcallhome's Avatar
    Join Date
    Jan 2011
    Last Online
    Yesterday @ 08:25 PM
    Location
    Preston County WV
    Posts
    13,522
    Thanks
    3,304
    Thanked 2,505 Times in 1,614 Posts
    Welcome from West Virginia,, sorry I can't help .

    Gene

    Have fun and be safe !!!
    USAR 8yr 8 mo SSG 99th ARCOM
    JD 1025R, H120 FEL 54" bucket, 54" mmm Auto Conn, 54" Front blade, JD back hoe ,JD IMatch, 48" Bush Hog tiller, Middlebuster from MF dealer, used King Kutter 5' rear blade, a new 47" JD Front blower and Original Tractor cab w/heater.
    We have a Red Honda Pioneer 700-4 (4 seater) w/soft top , doors, and winch.

  10. Top | #8
    Guest
    Join Date
    Apr 2013
    Last Online
    01-22-2018 @ 07:31 PM
    Location
    Tennessee
    Posts
    1,919
    Thanks
    392
    Thanked 256 Times in 196 Posts


    Welcome from Lancaster, PA! Did you test the glow plugs? That's where I'd start.

  11. Top | #9
    56FordGuy's Avatar
    Join Date
    Jan 2012
    Last Online
    Yesterday @ 09:20 PM
    Location
    Wyoming
    Posts
    10,043
    Thanks
    482
    Thanked 1,661 Times in 1,091 Posts
    Take a voltmeter and test the battery voltage when you're not trying to start, then have a helper crank the tractor and watch the voltmeter. What are the voltages resting, cranking, and with the engine running?
    -Blake

    Your mileage may vary.

    JD 6410
    Some other stuff

    YouTube- Life in Wyoming

  12. Top | #10

    Join Date
    Oct 2014
    Last Online
    10-26-2014 @ 02:54 PM
    Location
    UK
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I will check it out and let you know.
    I noticed after driving it all day yesterday as well that the fault come up when I change from E-2,3 or 4 to F.
    The dash also briefly flashed dash voltage problem when I started it.

    Thank you for all your help
    Alex

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •