1025R wont start
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
Like Tree43Likes

Thread: 1025R wont start

  1. Top | #1

    Join Date
    Feb 2017
    Last Online
    09-12-2019 @ 06:22 PM
    Location
    Australia
    Posts
    18
    Thanks
    10
    Thanked 0 Times in 0 Posts

    1025R wont start

    My JD1025R won't start. Fuel solenoid is working but no action on starter. The battery has been checked. However the dash indicator says PTO is engaged. In that position it will not start. Although the yellow switch is down no go. Checked all relays, fuses, etc. Wondering if the engine controller is faulty or switch faulty. Still scratching my head on what to do next. Anyone have this problem. Tractor is 3 years old.
    Marlin and PJR832 like this.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    tomd999's Avatar
    Join Date
    Jun 2011
    Last Online
    06-30-2019 @ 10:15 AM
    Location
    Manchvegas, NH area
    Posts
    1,965
    Thanks
    0
    Thanked 422 Times in 285 Posts
    Hiya,

    I would disconnect the PTO switch and see if that gets it to start. You could also try moving the selector to a different position and try it there. Another thing to try is to disconnect the negative battery terminal and let it sit for 20 minutes, that may help it reset too. (That last one was a bit of a WAG, I don't know if the ECM has a battery in it to retain data)

    Tom
    etcallhome, Marlin, 56Nine and 1 others like this.
    2010 3320 Cab
    Loaded R3's, 300CX w/3rd SCV
    61" HD-Tooth Bar, 72" HD-bolt-on edge, Frontier Forx
    "A" front hitch, Mid-PTO, Air ride seat, Horn, Back-up alarm, Rear work lights, External mirrors, Auto cruise
    60HD broom. 366 Blade, 59 blower, i-Match
    Looking for: Rear Wheel Weight Set

    Stuff for Sale:
    New 200CX/H130 Masts 25/2720-2032R
    New Jamison Bryce adapter, cart and chute

    “Suppose you were an idiot, and suppose you were a member of Congress; but I repeat myself” Mark Twain

  4. The Following User Says Thank You to tomd999 For This Useful Post:

    linlee (01-07-2018)

  5. Top | #3

    Join Date
    Feb 2017
    Last Online
    09-12-2019 @ 06:22 PM
    Location
    Australia
    Posts
    18
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Tried removing switch. Also tried bypassing switch but no luck. However yesterday was a 40 deg C degrees hot day and I noticed the fog in the dash display had evaporated into drops of water. Obviously there is water getting into the display. I had the battery disconnected for several days. I connected everything uo today without doing anything else and lo and behold it started with no problems. I am wondering if the moisture is causing my problems. Don't feel like paying Deere A$770 for a new one. Not sure if you can dismantle display dry and reseal. Thanks.
    Marlin and PJR832 like this.

  6. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  7. Top | #4

    Join Date
    Jul 2017
    Last Online
    05-06-2018 @ 11:21 AM
    Location
    Iowa
    Posts
    307
    Thanks
    12
    Thanked 25 Times in 21 Posts
    Bad battery connections?

  8. The Following User Says Thank You to CaseIH574 For This Useful Post:

    linlee (01-07-2018)

  9. Top | #5
    Captain Hook Kennyd's Avatar
    Join Date
    Aug 2010
    Last Online
    Today @ 08:18 AM
    Location
    Westminster, MD
    Posts
    16,427
    Thanks
    5,056
    Thanked 4,082 Times in 2,548 Posts
    Marlin and PJR832 like this.
    Kenny

    -John Deere 3720 Deluxe Cab TLB
    FEL, MMM, Artillian 42" Forks and Modular Grapple, I-Match, Ballast Box, and lots of other STUFF.
    -John Deere 455 w/60" MMM


    Bolt on Grab Hooks and other cool stuff are now for sale!!

    Visit our YouTube Channel

    My Equipment:
    John Deere 3720 Deluxe Cab, 300cx FEL, 366 Front Blade, 59" Front Snowblower, Ballast Box
    Artillian 3K Forks, Grapple, Front-Hoe Bucket
    John Deere 455, 60" MMM

  10. The Following User Says Thank You to Kennyd For This Useful Post:

    linlee (01-07-2018)

  11. Top | #6
    etcallhome's Avatar
    Join Date
    Jan 2011
    Last Online
    Today @ 07:30 AM
    Location
    Preston County WV
    Posts
    13,510
    Thanks
    3,300
    Thanked 2,505 Times in 1,614 Posts
    What is the print our on the dash.. turn 3pto off or neutral .

    If neutral above mmm pto is a switch unplug and put a jumper between leads on the wiring harness. If it starts bad switch , easy part to change just a little messy.

    Can't remember the leads to just on pto switch believe two closest wires to the side of the tractor,, thinking red - and orange wires .

    You said you checked battery HOW ,, you with v meter or did you take it to a dealer or auto parts store. Could be a bad battery
    BigJim55 and PJR832 like this.
    Gene

    Have fun and be safe !!!
    USAR 8yr 8 mo SSG 99th ARCOM
    JD 1025R, H120 FEL 54" bucket, 54" mmm Auto Conn, 54" Front blade, JD back hoe ,JD IMatch, 48" Bush Hog tiller, Middlebuster from MF dealer, used King Kutter 5' rear blade, a new 47" JD Front blower and Original Tractor cab w/heater.
    We have a Red Honda Pioneer 700-4 (4 seater) w/soft top , doors, and winch.

  12. The Following User Says Thank You to etcallhome For This Useful Post:

    linlee (01-07-2018)

  13. Top | #7
    Ray_PA's Avatar
    Join Date
    Dec 2013
    Last Online
    Today @ 09:41 AM
    Location
    North of Harrisburg, PA
    Posts
    1,932
    Thanks
    138
    Thanked 562 Times in 339 Posts
    Quote Originally Posted by linlee View Post
    My JD1025R won't start. Fuel solenoid is working but no action on starter. The battery has been checked. However the dash indicator says PTO is engaged. In that position it will not start. Although the yellow switch is down no go. Checked all relays, fuses, etc. Wondering if the engine controller is faulty or switch faulty. Still scratching my head on what to do next. Anyone have this problem. Tractor is 3 years old.
    When you say "fuel solenoid is working but no action on starter", do you mean the engine is not even turning over?
    JD 1025 TLB (2013) ** 60D 7 Iron MMM w/auto-connect ** H120 FEL** 260 BH ** 54" snowblower ** 54" blade ** 52" Front Broom ** Ken's Bolt on Hooks ** Frontier BB2048L box scraper ** County Line 5' landscape rake ** JD Hydraulic Dump MCS ** Artillian Forks w/36" Forks ** JD 3 - Point Ballast Box ** JD I-Match Quick Hitch ** Heavy Hitch front Weight Bar ** Heavy Hitch 3 Point Weight Bar ** Fimco 40 Gallon Sprayer ** EA Aerator ** FitRite Hydraulics Rear SCV ** 12 - 40# suitcase weights

  14. The Following User Says Thank You to Ray_PA For This Useful Post:

    linlee (01-07-2018)

  15. Top | #8
    Valley Boy's Avatar
    Join Date
    Mar 2015
    Last Online
    Yesterday @ 06:27 PM
    Location
    Nova Scotia, Ca
    Posts
    124
    Thanks
    7
    Thanked 31 Times in 17 Posts
    Mine is almost three years old. If I back it out of the barn when raining to give me room to work inside. The tractor will not start after wards, and a code comes up the PTO is engaged. All I can do is wait for it to stop raining and dry out. Then it starts with no problem. Last couple times I put a tarp over it and all was good!
    BigJim55, Marlin and PJR832 like this.
    Laurie

    John Deere 1025r TLB, Frontier 54" Rear Blower with hydraulics , 54" Quick Connect Mower, 49" Frontier Tiller, iMatch Hitch, Ballast Box, 42" Adjustable Front Tines, 48" Frontier Box Blade, Light Guards, Rear Work Light, Front ROPS Mounted Utility Lights, Block Heater.

  16. The Following User Says Thank You to Valley Boy For This Useful Post:

    linlee (01-07-2018)

  17. Top | #9

    Join Date
    Feb 2017
    Last Online
    09-12-2019 @ 06:22 PM
    Location
    Australia
    Posts
    18
    Thanks
    10
    Thanked 0 Times in 0 Posts

    1025R won't start

    Ray you can hear the fuel solenoid working but motor will not turn over. Valley Boy problems with his sounds exactly like mine. Does the inside of the dash display cloud over with moisture? Mine currently is bad and you cannot read the instruments. Started well this morning. Can the dash panel be dismantled to allow it to dry out and maybe reseal? Cheers
    BigJim55, Ray_PA, Marlin and 1 others like this.

  18. Top | #10
    Valley Boy's Avatar
    Join Date
    Mar 2015
    Last Online
    Yesterday @ 06:27 PM
    Location
    Nova Scotia, Ca
    Posts
    124
    Thanks
    7
    Thanked 31 Times in 17 Posts
    Quote Originally Posted by linlee View Post
    Ray you can hear the fuel solenoid working but motor will not turn over. Valley Boy problems with his sounds exactly like mine. Does the inside of the dash display cloud over with moisture? Mine currently is bad and you cannot read the instruments. Started well this morning. Can the dash panel be dismantled to allow it to dry out and maybe reseal? Cheers
    I get a tiny bit of moisture on the inside of the glass when I am blowing snow. Goes away and all is good. Not sure if you can take it apart. I think I saw something on here about a fogged up display. Even when I wash it I don't have a problem and I guess that's because it's in the sun to dry before I try to start it.
    etcallhome, BigJim55 and PJR832 like this.
    Laurie

    John Deere 1025r TLB, Frontier 54" Rear Blower with hydraulics , 54" Quick Connect Mower, 49" Frontier Tiller, iMatch Hitch, Ballast Box, 42" Adjustable Front Tines, 48" Frontier Box Blade, Light Guards, Rear Work Light, Front ROPS Mounted Utility Lights, Block Heater.

  19. The Following User Says Thank You to Valley Boy For This Useful Post:

    linlee (01-08-2018)

  20. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 3 1 2 3 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •