Got my 1025R MY 2013 fixed
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Like Tree53Likes

Thread: Got my 1025R MY 2013 fixed

  1. Top | #1
    John Deere 1025R TLB's Avatar
    Join Date
    Jan 2014
    Last Online
    10-15-2019 @ 12:40 PM
    Location
    Scranton, PA Area
    Posts
    2,450
    Thanks
    114
    Thanked 169 Times in 157 Posts

    Got my 1025R MY 2013 fixed

    Hi guys,
    Finally, John Deere came trough with a new Instrument Cluster. It now starts relatively smoothly (single stumble and puff of smoke). The new IC apparently lights off the glow plugs. Light goes off, and immediately start, triggers a second longer activation timer of the plugs (2 minutes). I know that to be the case, as leaving it on longer post glow light extinguishing, results in the same kind of cold start, as before the replacement.(bad stumble,Smoke but significantly shorter in duration. Started today immediately when the glow light went off and ran great immeditely. Well worth the wait for the fix.
    The above goes for the new machines too.

    Sent from my SM-N910V using Tapatalk
    DRobinson, Levi, spferdil and 2 others like this.
    MY2013 1025R TLB
    47" 2 stage front QT Snow Blower
    647 Tiller
    54D QT mowing deck W/ independent lift
    120H FEL W/ 49 in bucket
    260 BH W/ 12" bucket
    Homemade 10 Kw PTO Driven Generator (Timing Belt Driven 2000RPM input, from front PTO)
    1972 Homelite XL12 inherited from Dad going strong!
    Stihl FS90 String Trimmer
    Mantis Rotary Tiller
    ABI 5ft. Heavy Duty Landscape Rake

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    chex313's Avatar
    Join Date
    Dec 2012
    Last Online
    Yesterday @ 06:37 PM
    Location
    SE. PA.
    Posts
    897
    Thanks
    146
    Thanked 95 Times in 82 Posts
    I thought this was a pregnancy prevention thread

    Glad you got her "fixed" up JD
    Last edited by chex313; 03-02-2018 at 02:58 PM.
    Dave's 2012 1026R TLB,54"MMM Auto Attach,Ken's hooks&clevis,Artillian 36' Forks and a KennyPedal WH 520H 48" Snow Blade,48" Deck379 Peterbuilt (3 Million Miles in a big truck)

  4. Top | #3

    Join Date
    Apr 2017
    Last Online
    10-16-2019 @ 11:48 AM
    Location
    Lebanon, PA
    Posts
    377
    Thanks
    53
    Thanked 26 Times in 24 Posts
    So what was the problem? Is this a follow-up to some issue with cold starts? You replaced the entire instrument cluster? As in, the whole dashboard?
    John

    2015 JD 2025R Classic - 54D, 220R FEL, JD iMatch, JD Ballast Box, Frontier AF10F Plow, Frontier AP11F 42" Pallet Forks
    Tag Alongs: JD #15 Cart, 48" Poly Lawn Roller, JD Dethatcher
    Chainsaws: Echo CS-330T, Husqvarna 562XP-AT, Dolmar 7300
    Snowblower: Simplicity P1728E

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Jan 2018
    Last Online
    01-06-2019 @ 07:14 AM
    Location
    Kalamazoo, MI
    Posts
    554
    Thanks
    45
    Thanked 88 Times in 71 Posts
    Quote Originally Posted by John Deere 1025R TLB View Post
    Hi guys,
    The new IC apparently lights off the glow plugs. Light goes off, and immediately start, triggers a second longer activation timer of the plugs (2 minutes).
    I don't understand what's happening here.

    1. You turn the key part way
    2. The glow plug light comes on for 4-5 seconds and then turns off
    3. Then you start
    4. After you start it up, the plugs come back on for 2 minutes?

    Is that what you're saying? Or do you wait for the plugs to go off after 4-5 seconds and that by itself triggers a second longer activation of the plugs?

  7. Top | #5

    Join Date
    Jul 2017
    Last Online
    05-06-2018 @ 11:21 AM
    Location
    Iowa
    Posts
    307
    Thanks
    12
    Thanked 25 Times in 21 Posts
    I'm confused as well. You replaced the instrumentation cluster? Did JD do the work or did you do the change out? Might help us understand better. Thanks
    etcallhome and greenharley like this.

  8. Top | #6
    John Deere 1025R TLB's Avatar
    Join Date
    Jan 2014
    Last Online
    10-15-2019 @ 12:40 PM
    Location
    Scranton, PA Area
    Posts
    2,450
    Thanks
    114
    Thanked 169 Times in 157 Posts
    Quote Originally Posted by CaseIH574 View Post
    I'm confused as well. You replaced the instrumentation cluster? Did JD do the work or did you do the change out? Might help us understand better. Thanks
    JD dealer got a new cluster and installed. I believe the action of starting triggers second timer setting glows off during run cycle. If nothing done after the Light goes off ,such as sitting there listening to the lift pump run and watching the hour meter cick off time, the glows shut off , presumably so they would not drain the battery or whatever. If you have been watching the hour meter click up, thinking you are heating the cylinders up , yo u are not. If you let it go for an extra 30 seconds after the light extuishes it will start rough, but the glows come on from starting and it smoothes out within a second or two. A truely well thought out solution to the very crappy start I had. I gave JD the idea (called and made formal complaint about the crappy starting and asked if they had a way to reprogram the cluster to keep glows going after start) back within a couple months of delivery. (2013) Was recieved well, just took a long time to impliment. More wining by. Me got the new cluster. Sorry did not get paperwork yet to give the DTAC number. They came to me and the tech came only with the cluster, no paperwork. I was at work when he came. Wife supervised.
    By the way, doing this made it so she could not have baby trators too... but hey, I could not find a stud tractor anyway, so no loss.
    Bill

    Sent from my SM-N910V using Tapatalk
    Last edited by John Deere 1025R TLB; 03-03-2018 at 05:12 AM.
    MY2013 1025R TLB
    47" 2 stage front QT Snow Blower
    647 Tiller
    54D QT mowing deck W/ independent lift
    120H FEL W/ 49 in bucket
    260 BH W/ 12" bucket
    Homemade 10 Kw PTO Driven Generator (Timing Belt Driven 2000RPM input, from front PTO)
    1972 Homelite XL12 inherited from Dad going strong!
    Stihl FS90 String Trimmer
    Mantis Rotary Tiller
    ABI 5ft. Heavy Duty Landscape Rake

  9. Top | #7
    John Deere 1025R TLB's Avatar
    Join Date
    Jan 2014
    Last Online
    10-15-2019 @ 12:40 PM
    Location
    Scranton, PA Area
    Posts
    2,450
    Thanks
    114
    Thanked 169 Times in 157 Posts
    Quote Originally Posted by JohnM45 View Post
    So what was the problem? Is this a follow-up to some issue with cold starts? You replaced the entire instrument cluster? As in, the whole dashboard?
    Yes.. new cluster has a new glow plug sequence that totally eliminates the 20 seconds of misfiring stumble and heavy smoke at below zero temps. Does or did stumbling upon cold start below about 50 degrees to varying degrees dependent upon temp and how long it sat in that cold. Compression ignition us a wonderful thing, but cold cylinders have to get at least warm to run right and actually be able to ignight the fuel when compressed.

    Sent from my SM-N910V using Tapatalk
    MY2013 1025R TLB
    47" 2 stage front QT Snow Blower
    647 Tiller
    54D QT mowing deck W/ independent lift
    120H FEL W/ 49 in bucket
    260 BH W/ 12" bucket
    Homemade 10 Kw PTO Driven Generator (Timing Belt Driven 2000RPM input, from front PTO)
    1972 Homelite XL12 inherited from Dad going strong!
    Stihl FS90 String Trimmer
    Mantis Rotary Tiller
    ABI 5ft. Heavy Duty Landscape Rake

  10. Top | #8

    Join Date
    Apr 2017
    Last Online
    10-16-2019 @ 11:48 AM
    Location
    Lebanon, PA
    Posts
    377
    Thanks
    53
    Thanked 26 Times in 24 Posts
    Quote Originally Posted by John Deere 1025R TLB View Post
    Yes.. new cluster has a new glow plug sequence that totally eliminates the 20 seconds of misfiring stumble and heavy smoke at below zero temps. Does or did stumbling upon cold start below about 50 degrees to varying degrees dependent upon temp and how long it sat in that cold. Compression ignition us a wonderful thing, but cold cylinders have to get at least warm to run right and actually be able to ignight the fuel when compressed.

    Sent from my SM-N910V using Tapatalk
    Thanks for the explanation - So, from the sounds of it, they've implemented this change across the board. Sounds like a good thing!
    John

    2015 JD 2025R Classic - 54D, 220R FEL, JD iMatch, JD Ballast Box, Frontier AF10F Plow, Frontier AP11F 42" Pallet Forks
    Tag Alongs: JD #15 Cart, 48" Poly Lawn Roller, JD Dethatcher
    Chainsaws: Echo CS-330T, Husqvarna 562XP-AT, Dolmar 7300
    Snowblower: Simplicity P1728E

  11. Top | #9

    Join Date
    Jul 2017
    Last Online
    05-06-2018 @ 11:21 AM
    Location
    Iowa
    Posts
    307
    Thanks
    12
    Thanked 25 Times in 21 Posts
    Quote Originally Posted by JohnM45 View Post
    Thanks for the explanation - So, from the sounds of it, they've implemented this change across the board. Sounds like a good thing!
    I'm going to check mine when I get a chance and see if that is how the glow plugs are working. Mine starts great and runs good. Should be interesting.
    etcallhome and greenharley like this.

  12. Top | #10
    John Deere 1025R TLB's Avatar
    Join Date
    Jan 2014
    Last Online
    10-15-2019 @ 12:40 PM
    Location
    Scranton, PA Area
    Posts
    2,450
    Thanks
    114
    Thanked 169 Times in 157 Posts
    Quote Originally Posted by CaseIH574 View Post
    I'm going to check mine when I get a chance and see if that is how the glow plugs are working. Mine starts great and runs good. Should be interesting.
    So what did you find out?

    Sent from my SM-N910V using Tapatalk
    MY2013 1025R TLB
    47" 2 stage front QT Snow Blower
    647 Tiller
    54D QT mowing deck W/ independent lift
    120H FEL W/ 49 in bucket
    260 BH W/ 12" bucket
    Homemade 10 Kw PTO Driven Generator (Timing Belt Driven 2000RPM input, from front PTO)
    1972 Homelite XL12 inherited from Dad going strong!
    Stihl FS90 String Trimmer
    Mantis Rotary Tiller
    ABI 5ft. Heavy Duty Landscape Rake

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •