Broken Parking Brake linkage 1025R
Results 1 to 8 of 8
Like Tree6Likes
  • 3 Post By dieselshadow
  • 2 Post By Ray_PA
  • 1 Post By Ray_PA

Thread: Broken Parking Brake linkage 1025R

  1. Top | #1

    Join Date
    Nov 2013
    Last Online
    08-02-2019 @ 11:12 AM
    Location
    CT
    Posts
    70
    Thanks
    10
    Thanked 2 Times in 2 Posts

    Broken Parking Brake linkage 1025R

    So I went to finally fix my broken parking break today and realized it was more broken then I thought

    Click image for larger version. 

Name:	IMG_20180825_163513.jpg 
Views:	31 
Size:	5.11 MB 
ID:	645000

    I tried to use JD parts but I am not seeing how things are attaching

    I was referencing Brake Pedal and Linkage - ST745819, Park Lock W/ Cruise Control, Domestic - ST821626, and Park Lock - ST745827 but am not certain how everything goes together

    I tried to get the JD parts images but could not get them to copy and my computer was not showing them large enough to copy and paste into another program.

    Thoughts?
    1025r 54" auto connect deck, H120 FEL, 54" Snow blower, sub soiler

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    Keeper of the GTT Cookies dieselshadow's Avatar
    Join Date
    Nov 2011
    Last Online
    Today @ 09:48 AM
    Location
    Joelton TN
    Posts
    19,909
    Thanks
    1,067
    Thanked 4,325 Times in 2,598 Posts
    Is this what you are looking for?

    Attached Thumbnails Attached Thumbnails Screen Shot 2018-08-26 at 7.22.06 AM.png  
    - Jason

    GreenTractorTalk.com Rules, Policies, and Terms of Use

    Subscribe to dieselshadowman on YouTube

    2720 w/ 200CX FEL
    , Ken's weld-on hooks, Fit Rite Hydraulics Top and Tilt kit, Artillian forks.
    1954 60 - getting full restoration, 1964
    110 round fender in the shop for crustoration
    Ferris IS3200Zzero turn mower

    Quote Originally Posted by Gizmo2 View Post
    Dieselshadow is my Hero.


  4. Top | #3
    Ray_PA's Avatar
    Join Date
    Dec 2013
    Last Online
    Today @ 07:33 AM
    Location
    North of Harrisburg, PA
    Posts
    1,927
    Thanks
    138
    Thanked 558 Times in 336 Posts
    Here are pictures from the tech manual.
    Attached Thumbnails Attached Thumbnails Brake Linkage_1.JPG   Brake Linkage_2.JPG   Brake Linkage_3.JPG   Brake Linkage_4.JPG   Brake Linkage_5.JPG  

    Brake Linkage_6.JPG   Brake Linkage_7.JPG   Brake Linkage_8.JPG  
    etcallhome and raco232 like this.
    JD 1025 TLB (2013) ** 60D 7 Iron MMM w/auto-connect ** H120 FEL** 260 BH ** 54" snowblower ** 54" blade ** 52" Front Broom ** Ken's Bolt on Hooks ** Frontier BB2048L box scraper ** County Line 5' landscape rake ** JD Hydraulic Dump MCS ** Artillian Forks w/36" Forks ** JD 3 - Point Ballast Box ** JD I-Match Quick Hitch ** Heavy Hitch front Weight Bar ** Heavy Hitch 3 Point Weight Bar ** Fimco 40 Gallon Sprayer ** EA Aerator ** FitRite Hydraulics Rear SCV ** 12 - 40# suitcase weights

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    Ray_PA's Avatar
    Join Date
    Dec 2013
    Last Online
    Today @ 07:33 AM
    Location
    North of Harrisburg, PA
    Posts
    1,927
    Thanks
    138
    Thanked 558 Times in 336 Posts
    Quote Originally Posted by davisj4 View Post
    So I went to finally fix my broken parking break today and realized it was more broken then I thought



    I tried to use JD parts but I am not seeing how things are attaching

    I was referencing Brake Pedal and Linkage - ST745819, Park Lock W/ Cruise Control, Domestic - ST821626, and Park Lock - ST745827 but am not certain how everything goes together

    I tried to get the JD parts images but could not get them to copy and my computer was not showing them large enough to copy and paste into another program.

    Thoughts?
    Actually, what you have is your brake linkage, not the parking brake.
    raco232 likes this.
    JD 1025 TLB (2013) ** 60D 7 Iron MMM w/auto-connect ** H120 FEL** 260 BH ** 54" snowblower ** 54" blade ** 52" Front Broom ** Ken's Bolt on Hooks ** Frontier BB2048L box scraper ** County Line 5' landscape rake ** JD Hydraulic Dump MCS ** Artillian Forks w/36" Forks ** JD 3 - Point Ballast Box ** JD I-Match Quick Hitch ** Heavy Hitch front Weight Bar ** Heavy Hitch 3 Point Weight Bar ** Fimco 40 Gallon Sprayer ** EA Aerator ** FitRite Hydraulics Rear SCV ** 12 - 40# suitcase weights

  7. Top | #5

    Join Date
    May 2017
    Last Online
    08-29-2019 @ 09:25 PM
    Location
    Michigan
    Posts
    40
    Thanks
    9
    Thanked 6 Times in 5 Posts
    I'm curious about the cause of your broken parking brake linkage. Any idea of the cause?

    I have issues with my parking brake but have yet to have the time to tear into it to look for a cause. Mine doesn't want to release after it's been set. I push it down to release with foot on brake, but the handle does not go down all the way unless "encouraged" a bit more than I would think it was designed for. I have concerns that I might be heading down the same path has the OP.
    John Deere 1025R with FEL and 60" snow plow (currently in storage because the ATV is much faster and lots of fun in the snow!) and engine block heater.
    My filled tires and ballast box give me great ground hugging capabilities and F1 type performance.
    Artillian forks, Artillian grapple and iMatch quick hitch make light work of the perpetual woods clearing that I'm always working at.
    Just added Edge Tamers, Kenny's Bolt On Hooks, and more to come soon.


  8. Top | #6
    Ray_PA's Avatar
    Join Date
    Dec 2013
    Last Online
    Today @ 07:33 AM
    Location
    North of Harrisburg, PA
    Posts
    1,927
    Thanks
    138
    Thanked 558 Times in 336 Posts
    Quote Originally Posted by Chipmeister View Post
    I'm curious about the cause of your broken parking brake linkage. Any idea of the cause?

    I have issues with my parking brake but have yet to have the time to tear into it to look for a cause. Mine doesn't want to release after it's been set. I push it down to release with foot on brake, but the handle does not go down all the way unless "encouraged" a bit more than I would think it was designed for. I have concerns that I might be heading down the same path has the OP.
    Technically, there is no separate parking brake on the I series. It is a service brake lock.

    Take some WD40 or something like that and spray the brake lock linkage. I spray mine routinely to keep it working freely.
    JD 1025 TLB (2013) ** 60D 7 Iron MMM w/auto-connect ** H120 FEL** 260 BH ** 54" snowblower ** 54" blade ** 52" Front Broom ** Ken's Bolt on Hooks ** Frontier BB2048L box scraper ** County Line 5' landscape rake ** JD Hydraulic Dump MCS ** Artillian Forks w/36" Forks ** JD 3 - Point Ballast Box ** JD I-Match Quick Hitch ** Heavy Hitch front Weight Bar ** Heavy Hitch 3 Point Weight Bar ** Fimco 40 Gallon Sprayer ** EA Aerator ** FitRite Hydraulics Rear SCV ** 12 - 40# suitcase weights

  9. Top | #7

    Join Date
    Nov 2013
    Last Online
    08-02-2019 @ 11:12 AM
    Location
    CT
    Posts
    70
    Thanks
    10
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by Chipmeister View Post
    I'm curious about the cause of your broken parking brake linkage. Any idea of the cause?

    I have issues with my parking brake but have yet to have the time to tear into it to look for a cause. Mine doesn't want to release after it's been set. I push it down to release with foot on brake, but the handle does not go down all the way unless "encouraged" a bit more than I would think it was designed for. I have concerns that I might be heading down the same path has the OP.
    It happened a while ago so I do not recall exactly what it was but something snagged it while clearing brush

    To everyone else thanks for your help, when I get some time I will provide some more details but it looks like the differential lock bell crank is the broken part. Hopefully once I get everything hooked back up everything will work.

    Thanks for the quick replies and help.
    1025r 54" auto connect deck, H120 FEL, 54" Snow blower, sub soiler

  10. Top | #8
    ErikR's Avatar
    Join Date
    Jan 2015
    Last Online
    Yesterday @ 05:53 PM
    Location
    Northern WI
    Posts
    692
    Thanks
    28
    Thanked 204 Times in 124 Posts
    I hope you can get that fixed up with no problems....


    Here's a little bigger view of what's broken.

    Click image for larger version. 

Name:	brkoe.JPG 
Views:	7 
Size:	134.9 KB 
ID:	645356
    2014 1025R, H120 loader w/53" bucket and Heavy Hitch Tooth Bar, 54" Auto Connect MMM, 47" QH snow blower, Ballast box and loaded rear tires, Speeco Quick Hitch, Ken's Bolt-on Grab Hooks, King Kutter Carry All, 54" front QH blade w/Heavy Hitch skids, Titan 36" pallet forks, Land Pride GS0560 Grading Scraper, and chrome (kitchen drain pipe) exhaust tip!!

    1950 Allis-Chalmers B, Electric start, PTO, Belt Pulley, Hydraulic pump. Stuck engine (a work in progress)

  11. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •