1025r won’t start
Results 1 to 10 of 10
Like Tree12Likes
  • 1 Post By etcallhome
  • 1 Post By Big
  • 3 Post By dieselshadow
  • 1 Post By etcallhome
  • 3 Post By kylew
  • 1 Post By AJgrn78
  • 1 Post By Salt Life
  • 1 Post By DMagers

Thread: 1025r won’t start

  1. Top | #1

    Join Date
    Apr 2016
    Last Online
    06-14-2019 @ 09:39 PM
    Location
    Lone Oak, Ky
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    1025r won’t start

    I went to start my tractor tonight and as soon as the wait to start light began to flash there was a pop and everything went dead. It won’t do anything now. No start, no lights, nothing. None of the fuses are blown but none of the lights will work either. At first I thought the ignition switch went bad but that doesn’t explain why none of the lights work. Could it be one if the relays? Would the neutral start switch have anything to do with it? I unhooked the neutral start switch above the mid pto and plugged it back in and got the dash to light up for a minute but it didn’t last and the lights still didn’t come on. I’m not very good at chasing electrical problems. Anyone else have an experience like this?

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    etcallhome's Avatar
    Join Date
    Jan 2011
    Last Online
    Today @ 08:14 AM
    Location
    Preston County WV
    Posts
    13,505
    Thanks
    3,300
    Thanked 2,503 Times in 1,613 Posts
    Not sure what pops , but first off how old is your battery,.. For me first thing to check is battery, if you don't a battery tester , take battery to Advance or Auto Zone, or to your dealer they can test your battery. Then go from there when you know you have power coming from the battery..
    OxPath likes this.
    Gene

    Have fun and be safe !!!
    USAR 8yr 8 mo SSG 99th ARCOM
    JD 1025R, H120 FEL 54" bucket, 54" mmm Auto Conn, 54" Front blade, JD back hoe ,JD IMatch, 48" Bush Hog tiller, Middlebuster from MF dealer, used King Kutter 5' rear blade, a new 47" JD Front blower and Original Tractor cab w/heater.
    We have a Red Honda Pioneer 700-4 (4 seater) w/soft top , doors, and winch.

  4. Top | #3
    Big
    Big is online now
    Big's Avatar
    Join Date
    Jan 2018
    Last Online
    Today @ 08:37 AM
    Location
    Greenville SC
    Posts
    1,281
    Thanks
    105
    Thanked 225 Times in 162 Posts
    Most of the time it's a bad battery. Have you tried jump starting?
    OxPath likes this.
    -2017 2032R, 220r Loader, I-Match, Ken's Extended Top Hook, MMM, JD Ballast Box, Dual rear SCV's, Single Point Hydraulic Connection, Landscape Rake, Tarter Tiller, Boom Pole, Middle Buster/Potato Plow, Drag Harrow, Single Row Hipper, 5' Enorossi sickle bar, 3 point spike drag, Titan 42" Forks, 60" Box Blade, Landpride 3 point spreader, Leinbach 5' Disc.

    -Bobcat 325G Mini Ex
    -Toro Dingo 322 with many attachments
    -Honda Pioneer 700

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    Keeper of the GTT Cookies dieselshadow's Avatar
    Join Date
    Nov 2011
    Last Online
    Today @ 06:58 AM
    Location
    Joelton TN
    Posts
    19,926
    Thanks
    1,067
    Thanked 4,328 Times in 2,601 Posts
    Check and clean your battery connections. Then check the other end of those big cables. Clean and tight.

    These batteries are also known for “Sudden Death Syndrome.” They’ll just up and die just like someone flipped a switch.
    etcallhome, OxPath and kylew like this.
    - Jason

    GreenTractorTalk.com Rules, Policies, and Terms of Use

    Subscribe to dieselshadowman on YouTube

    2720 w/ 200CX FEL
    , Ken's weld-on hooks, Fit Rite Hydraulics Top and Tilt kit, Artillian forks.
    1954 60 - getting full restoration, 1964
    110 round fender in the shop for crustoration
    Ferris IS3200Zzero turn mower

    Quote Originally Posted by Gizmo2 View Post
    Dieselshadow is my Hero.


  7. Top | #5

    Join Date
    Apr 2016
    Last Online
    06-14-2019 @ 09:39 PM
    Location
    Lone Oak, Ky
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It’s the original battery but I’ve had a battery tender on since I brought it home.

  8. Top | #6
    etcallhome's Avatar
    Join Date
    Jan 2011
    Last Online
    Today @ 08:14 AM
    Location
    Preston County WV
    Posts
    13,505
    Thanks
    3,300
    Thanked 2,503 Times in 1,613 Posts
    Quote Originally Posted by Salt Life View Post
    It’s the original battery but I’ve had a battery tender on since I brought it home.
    Doesn't matter , battery will still go bad... get your battery tested.
    Big likes this.
    Gene

    Have fun and be safe !!!
    USAR 8yr 8 mo SSG 99th ARCOM
    JD 1025R, H120 FEL 54" bucket, 54" mmm Auto Conn, 54" Front blade, JD back hoe ,JD IMatch, 48" Bush Hog tiller, Middlebuster from MF dealer, used King Kutter 5' rear blade, a new 47" JD Front blower and Original Tractor cab w/heater.
    We have a Red Honda Pioneer 700-4 (4 seater) w/soft top , doors, and winch.

  9. Top | #7
    kylew's Avatar
    Join Date
    Jan 2018
    Last Online
    Today @ 03:22 AM
    Location
    Grass Lk, Michigan
    Posts
    1,249
    Thanks
    214
    Thanked 268 Times in 223 Posts
    There was a thread a couple/few months ago experiencing nearly the exact same thing. They heard a pop and then nothing worked. Turned out to be the battery died....literally. The concensus was the pop that was heard was the plates shorting out. Get yourself a new battery, you'll be good.
    🌠Back in my day we had 9 planets🌠

    2014 1025R TLB
    60D AutoConnect Mower●H120 Loader●260 Backhoe●BB2048 Box Blade●RB2060L Back Blade●RC2048 Rotary Cutter●JD 60" Quick Hitch Plow Blade●Ken's Bolt-on Hooks●Ken's Diff Pedal●Ken's I-Match Hook●Ken's Backhoe Steps●Titan 42" Forks w/Headache Rack●Titan Ballast Box●Titan Toothbar w/23WTL Tiger Teeth●3" Edge Tamers●BXpanded 6" Bucket, Ripper & Bucket Quick Change●This & That Mods●Other Stuff I Forgot About●

    The Mrs. has 2014 X360

  10. Top | #8
    AJgrn78's Avatar
    Join Date
    Feb 2016
    Last Online
    Today @ 07:34 AM
    Location
    Buffalo, NY
    Posts
    1,265
    Thanks
    14
    Thanked 91 Times in 84 Posts
    Yep......battery.
    etcallhome likes this.
    1984 JD 316 w/ cat 0 3-pt hitch and 2000 rpm pto, 48" tiller, 49" snowblower, 42" belly mower
    2015 JD 1025r, 60d MMM, 54" front mounted snowblower, Heavy hitch, Ballast box
    1980 JD 1050 4wd, JD 75 loader, IH 60" brush hog
    1980? Satoh S550g Elk, 60" belly mower
    McCulloch Saws - 1970's Mini Mac 30; Mac 10-10
    1978 Ariens Sno-Thro 32"; Troy-Bilt 24" snoblower
    1996 Polaris 680 Ultra Snowmobile, 2004 Yamaha Raptor 660, 2016 Polaris Sportsman 570
    1996 KTM EXC 300
    Gravely ZT-HD 60"

  11. Top | #9

    Join Date
    Apr 2016
    Last Online
    06-14-2019 @ 09:39 PM
    Location
    Lone Oak, Ky
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you all. I’ll pull the battery tomorrow and check it.
    etcallhome likes this.

  12. Top | #10

    Join Date
    Feb 2019
    Last Online
    Today @ 07:55 AM
    Location
    Central, IL
    Posts
    74
    Thanks
    5
    Thanked 3 Times in 3 Posts
    Yep, my 1026R did the funky sudden death syndrome with the battery. One second great and the next second zero.

    Let us know how it checked out.

    You know I hustled back to mother Deere to get a replacement.
    etcallhome likes this.

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •