2305 wonít stay running tried everything?
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Like Tree29Likes

Thread: 2305 wonít stay running tried everything?

  1. Top | #1

    Join Date
    Jul 2019
    Last Online
    07-22-2019 @ 05:04 PM
    Location
    Knappa,Oregon
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    2305 wonít stay running tried everything?

    I have a 2305 John Deere year 2010 compact tractor and like many others on here when I turn the key to start it it fires off then dies. It began as I would have to wiggle my hi/lo selector to get it to run this went on for quite some time now it finally quit although it still runs if I hold the key on. Iíve done a few things that were suggested like take off the rear tire to get to some wires and did what I was supposed to do(forgot what that was) it would start after that just not run UNLESS I held the key on. I also replaced the solenoid and one diode still have the same problem. It will turn over and run if I hold the key on but thatís it. Oh it appears the lights on the dash donít work when you turn that first click of the key I believe that does something else too? Glow plugs and Or fuel pump? Iíve checked the fuses all good. Iím going crazy. Please any one have some suggestions?

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    Superglidesport's Avatar
    Join Date
    Dec 2011
    Last Online
    Today @ 09:30 AM
    Location
    Littleton, MA
    Posts
    7,721
    Thanks
    697
    Thanked 1,586 Times in 996 Posts
    Sounds like lack of fuel. A couple of things come to mind. Restricted fuel tank outlet? Is the fuel bowl full? If not remove the feed line and fuel cap and lightly blow some compressed air back into the tank to dislodge debris.

    Another possibility is the diode that powers the fuel control solenoid is bad. It's buried in the wiring harness and is only a ~$7.00 part. The hardest oart of this repair is finding it.

    Here's some homework for you: https://www.greentractortalk.com/for...0won%27t%20run

    etcallhome, rtgt, BigJim55 and 1 others like this.
    John Deere 3320
    eHydro, R4's, 300CX Loader, 61" HD Bucket
    JD Tooth Bar, Deluxe Hood Guard, Ken's Bolt-on Hooks
    485 Backhoe w. 18" HD Bucket
    Mid-PTO, Front 3 Point Hitch, 366 Front Blade
    Tarter 5' 3PH Tiller
    Frontier AP12F Forks

    John Deere 2032R
    R3's, 220R Loader, 57" HD Bucket
    Curtis Hard Side Cab & Heater
    62D Deck, iMatch Quick Hitch
    54 Snowblower
    Super HeavyHitch
    Little Wonder "Optimax" & JRCO Blower Buggy
    Fimco 60 Gallon 3PH Boomless Sprayer w. PTO Pump

  4. Top | #3
    Captain Hook Kennyd's Avatar
    Join Date
    Aug 2010
    Last Online
    Today @ 05:47 PM
    Location
    Westminster, MD
    Posts
    16,392
    Thanks
    5,043
    Thanked 4,074 Times in 2,540 Posts
    I'd bet it's the diode like Frank mentioned.

    Welcome to GTT.
    Kenny

    -John Deere 3720 Deluxe Cab TLB
    FEL, MMM, Artillian 42" Forks and Modular Grapple, I-Match, Ballast Box, and lots of other STUFF.
    -John Deere 455 w/60" MMM


    Bolt on Grab Hooks and other cool stuff are now for sale!!

    Visit our YouTube Channel

    My Equipment:
    John Deere 3720 Deluxe Cab, 300cx FEL, 366 Front Blade, 59" Front Snowblower, Ballast Box
    Artillian 3K Forks, Grapple, Front-Hoe Bucket
    John Deere 455, 60" MMM

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    coaltrain's Avatar
    Join Date
    May 2014
    Last Online
    Today @ 04:56 PM
    Location
    NW Penna
    Posts
    20,076
    Thanks
    1,084
    Thanked 3,092 Times in 2,257 Posts
    If the diode is suspect as the gurus say, here is an interesting video to view -

    John Deere 2305 V4 diode replacement - YouTube
    ~Stan~
    It is what it is
    Knowledge is power, ignorance is bliss
    2520 w/200CX w/62D2

  7. The Following User Says Thank You to coaltrain For This Useful Post:

    Kennyd†(07-10-2019)

  8. Top | #5
    BigJim55's Avatar
    Join Date
    Nov 2013
    Last Online
    Today @ 12:05 PM
    Location
    Schellsburg, PA
    Posts
    11,228
    Thanks
    3,035
    Thanked 1,397 Times in 1,098 Posts
    i thought in his first post he said he replaced a diode-it sure sounds like a bad diode--acts just like how my 2520 did--lack of fuel. mine would run on a small bit of crack---i cracked my injector lines-but i couldn't get no fuel out of em. i loaded it up and took it to the dealer---turned out it was a diode i don't think they was 7 bucks back then, but it has been several yrs now-and things are going up in price.
    etcallhome and rtgt like this.
    jim

    2006 2520 mcut, 2004 x475, 1953 model 50, 1985 318-was my Dad's,
    king kutter tiller-60", frontier-stone rake, jd-4ft brush hog, frontier-6ft back-blade, frontier-forks, 48 inch forks,
    2-54inch jd snow plows, jd-5ft-pull brush hog,

    2018 835R gas model gator-"aka" the Cadillac i say!! 6ft jd snow plow-which already has a dtac out on it. i got just about everything on it i could at the time

  9. Top | #6
    coaltrain's Avatar
    Join Date
    May 2014
    Last Online
    Today @ 04:56 PM
    Location
    NW Penna
    Posts
    20,076
    Thanks
    1,084
    Thanked 3,092 Times in 2,257 Posts
    Quote Originally Posted by BigJim55 View Post
    i thought in his first post he said he replaced a diode-it sure sounds like a bad diode--acts just like how my 2520 did--lack of fuel. mine would run on a small bit of crack---i cracked my injector lines-but i couldn't get no fuel out of em. i loaded it up and took it to the dealer---turned out it was a diode i don't think they was 7 bucks back then, but it has been several yrs now-and things are going up in price.
    But arenít there multiple diodes? Maybe the OP changed one that wasnít the one that went bad?
    etcallhome, rtgt and BigJim55 like this.
    ~Stan~
    It is what it is
    Knowledge is power, ignorance is bliss
    2520 w/200CX w/62D2

  10. Top | #7
    etcallhome's Avatar
    Join Date
    Jan 2011
    Last Online
    Today @ 05:58 PM
    Location
    Preston County WV
    Posts
    13,490
    Thanks
    3,299
    Thanked 2,496 Times in 1,608 Posts
    I haven't checked but thinking 4 diodes might only be 3.
    rtgt and BigJim55 like this.
    Gene

    Have fun and be safe !!!
    USAR 8yr 8 mo SSG 99th ARCOM
    JD 1025R, H120 FEL 54" bucket, 54" mmm Auto Conn, 54" Front blade, JD back hoe ,JD IMatch, 48" Bush Hog tiller, Middlebuster from MF dealer, used King Kutter 5' rear blade, a new 47" JD Front blower and Original Tractor cab w/heater.
    We have a Red Honda Pioneer 700-4 (4 seater) w/soft top , doors, and winch.

  11. Top | #8

    Join Date
    Mar 2015
    Last Online
    Today @ 05:35 PM
    Location
    Eastern Virginia, United States
    Posts
    4,535
    Thanks
    344
    Thanked 817 Times in 534 Posts

    Might be too simple

    This might be too simple but I'd check the switch. Possibly the starting position is good and running juice to the fuel system but the run position is not.

    It's a thought anyway and it should be possible to bypass the switch with a jumper on the right pins.

    Treefarmer
    etcallhome, rtgt, BigJim55 and 1 others like this.
    John Deere 790, 300 loader w Ken's Bolt on Hooks & Piranha tooth bar, grapple, back blade, box blade, Bush Hog mower, couple of red tractors, hay equipment, various old stuff some red, one orange, some I don't remember

  12. Top | #9
    BigJim55's Avatar
    Join Date
    Nov 2013
    Last Online
    Today @ 12:05 PM
    Location
    Schellsburg, PA
    Posts
    11,228
    Thanks
    3,035
    Thanked 1,397 Times in 1,098 Posts
    Quote Originally Posted by coaltrain View Post
    But arenít there multiple diodes? Maybe the OP changed one that wasnít the one that went bad?
    yeah that's possible i suppose--but IIRC---the jd tech showed me my old one -and u could see it was burnt out--so i just figured if he said he changed one then it was bad.

    maybe he has a couple bad ones

    i'm thinking the 2520's has 6 diodeswould have to look that up to be sure... very frustrating to have ur tractor not run -to only find out one of them little buggers burned out.
    SulleyBear likes this.
    jim

    2006 2520 mcut, 2004 x475, 1953 model 50, 1985 318-was my Dad's,
    king kutter tiller-60", frontier-stone rake, jd-4ft brush hog, frontier-6ft back-blade, frontier-forks, 48 inch forks,
    2-54inch jd snow plows, jd-5ft-pull brush hog,

    2018 835R gas model gator-"aka" the Cadillac i say!! 6ft jd snow plow-which already has a dtac out on it. i got just about everything on it i could at the time

  13. Top | #10

    Join Date
    Jul 2019
    Last Online
    07-22-2019 @ 05:04 PM
    Location
    Knappa,Oregon
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thanks

    Thanks guys and yes I changed the diode I will try the switch and see if that might be the problem. Itís not lack of fuel because if I hold the key in the start position it will stay running,as soon as I let off it dies. Iím headed out to look at the key switch.
    Thanks again.
    SulleyBear likes this.

  14. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts