JD955 PTO Engagement
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By theduke

Thread: JD955 PTO Engagement

  1. Top | #1

    Join Date
    Sep 2019
    Last Online
    09-03-2019 @ 07:58 PM
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    JD955 PTO Engagement

    I have 2/1998 models; both have a vertical lever to the left of the steering that you push upward to engage the PTO. They are suppose to stay upward when engaged!! I have made a manual lock to hold them in position. That works fine; but something is amiss. Any ideas? Battery/alternator are fine!!

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    theduke's Avatar
    Join Date
    Feb 2016
    Last Online
    Today @ 09:53 PM
    Location
    NW Oregun Gutterslut...the Wet Side.... Gaston
    Posts
    970
    Thanks
    72
    Thanked 153 Times in 104 Posts
    Hi

    There are wire springs on each side of the lever to help hold it forwards.

    are yours gone??

    Lever is also partially held by the electro magnet disk thats down under dash behind lever. You can see it through small area from the side left. One of my 955's had this similar problem that iirc was traced back to the switch under the seat. They don't seem to last too long. At least with 2 identical units you can swap parts back and forth to help diagnose......untill they both have a similar issue. Also there are 4 or 5 fuses right next to the magnet area....check them.
    SulleyBear likes this.
    Dan


    JD 955 ,70A loader, 60" mmm , Original I-match ,4' woods B hog , 5' Box blade , 12' orchard plane/driveway grader ,various other doo-dads & homebuilt implements. Goossen BFBlower, JakeRake..this thing is different.
    Kubota U-15
    Kubota RTV 900

    47 8n......good times..V8 in my future possibly

    Pharrell Williams - Freedom (Video) - YouTube ...George Michael - Freedom! ’90 (Official Video) - YouTube..

  4. Top | #3

    Join Date
    Oct 2016
    Last Online
    Today @ 08:29 PM
    Location
    Woodland, ME
    Posts
    200
    Thanks
    19
    Thanked 27 Times in 22 Posts
    I had a similar problem when I bought my 955. I replaced the electromagnet and the problem was solved.

    Dave
    1990 955
    Curtis Cab
    Model 59 2 stage snowblower
    72" mid mount mower
    Model 70A loader with Edge Tamers and Edge Extenders

    1990 420 repowered with V Twin Honda
    Cozy Cab
    Model 47 2 stage snowblower
    60" mid mount mower
    3 bag Material Collection System

    1939 Oliver Row Crop 70

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •