Another Dead Battery Victim
Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
Like Tree79Likes

Thread: Another Dead Battery Victim

  1. Top | #1
    bones's Avatar
    Join Date
    Sep 2012
    Last Online
    @
    Location
    NE PA
    Posts
    374
    Thanks
    53
    Thanked 17 Times in 16 Posts

    Another Dead Battery Victim

    Well chalk up another victim of Deere's crappy battery on the 1026R. Took mine out today to remove the loader and hoe for some yard work. I got the loader off and re-positioned to remove the hoe, tried to start it back up and nothing but weird noises from the dash. I was kind of in a pinch because we are getting some trees cut that need to be moved for a construction project to start Friday so I ran to Wally World and picked up a 51R. Got it in and she fired right up. My tractor was purchased new 9/2012 and the battery was marked 2012 as well, always stored indoors with heat in the winter. The way it sounds, I guess I am lucky to get 4 years out of it.
    pcabe5, BigJim55 and KE8LW like this.
    2012 1026R TLB - 60D 7 Iron MMM Auto connect w/ hyd lift - H120 w/ 53" FEL - 260BH w/ 12" Bucket - JD Aux Lights - R4's - Block heater - Artillian 36" JDQA Forks - Ken's Hooks - Piranha Tooth bar - Upgraded seat springs from psrumors

    2013 Laramie Ram Power Wagon w/ Western 8.5' ProPlus plow
    2008 Dodge Avenger R/T Chrysler 200,000 Mile Club
    '16 Polaris Sportsman Touring 1000 XP
    '03 Kawasaki Prairie 650

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    AJgrn78's Avatar
    Join Date
    Feb 2016
    Last Online
    Today @ 10:16 PM
    Location
    Buffalo, NY
    Posts
    1,268
    Thanks
    14
    Thanked 92 Times in 85 Posts
    I got ya beat...the battery in my new Polaris ATV lasted from March until September. I mean one day it was stone dead, would not hold a charge, had never been discharged or anything. replaced with a new AGM Deka battery and all fixed.
    BigJim55 likes this.

  4. Top | #3
    jgayman's Avatar
    Join Date
    Jul 2012
    Last Online
    Today @ 09:29 PM
    Location
    Central Pennsylvania
    Posts
    10,087
    Thanks
    371
    Thanked 1,668 Times in 1,263 Posts
    Quote Originally Posted by bones View Post
    Well chalk up another victim of Deere's crappy battery on the 1026R.
    Sorry to hear it and welcome to the "Click" Club.
    2012 2720 -- 200CX Loader -- 54" Quick Attach Snow Blower -- Frontier LR5060 Rake -- Land Pride RB1660 Blade (Hydraulic Angle) -- Artillian 42" Forks -- Ken's Bolt on Grab Hooks -- Fit Rite Hydraulic top-link -- 2013 X500 for mowing duties

  5. The Following User Says Thank You to jgayman For This Useful Post:

    bones (11-15-2016)

  6. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  7. Top | #4
    bones's Avatar
    Join Date
    Sep 2012
    Last Online
    @
    Location
    NE PA
    Posts
    374
    Thanks
    53
    Thanked 17 Times in 16 Posts
    Quote Originally Posted by AJgrn78 View Post
    I got ya beat...the battery in my new Polaris ATV lasted from March until September. I mean one day it was stone dead, would not hold a charge, had never been discharged or anything. replaced with a new AGM Deka battery and all fixed.
    I bought a new 2016 Polaris Sportsman Touring 1000 XP... same thing happened. Took delivery in May, by August or so in the summer, it went dead. I did not call the dealer or anything, just charged it up and it took a charge. We'll see how long it lasts again. It's probably dead now, as I havn't driven it in a while.
    Last edited by bones; 11-15-2016 at 01:42 PM.
    2012 1026R TLB - 60D 7 Iron MMM Auto connect w/ hyd lift - H120 w/ 53" FEL - 260BH w/ 12" Bucket - JD Aux Lights - R4's - Block heater - Artillian 36" JDQA Forks - Ken's Hooks - Piranha Tooth bar - Upgraded seat springs from psrumors

    2013 Laramie Ram Power Wagon w/ Western 8.5' ProPlus plow
    2008 Dodge Avenger R/T Chrysler 200,000 Mile Club
    '16 Polaris Sportsman Touring 1000 XP
    '03 Kawasaki Prairie 650

  8. Top | #5
    Jim Timber's Avatar
    Join Date
    Jan 2015
    Last Online
    08-18-2019 @ 08:55 AM
    Location
    Brainerd/Metro, MN
    Posts
    2,965
    Thanks
    25
    Thanked 239 Times in 177 Posts
    My India battery died last week too!

    Fine one day, back out a couple later and it wouldn't turn the dash on, much less take a charge.

    Went with a deep cycle from Costco.
    BigJim55 likes this.
    5065E MFWD w/553 loader

  9. Top | #6
    spferdil's Avatar
    Join Date
    May 2014
    Last Online
    Today @ 10:38 PM
    Location
    Texas
    Posts
    2,203
    Thanks
    145
    Thanked 388 Times in 241 Posts
    I'd say you were lucky to get 4 years out of it. I bought my 1025r new in 2014 and the battery died earlier this year. I only got about 2 years. Plus mine was running at the time it died, had started just fine right before. When I pushed the lift button to raise the MMM everything in the dash flashed and the engine died, battery was dead as a doornail.
    pcabe5, BigJim55 and Drifterbike like this.
    It may be that your sole purpose in life is simply to serve as a warning to others.

  10. Top | #7
    Jim Timber's Avatar
    Join Date
    Jan 2015
    Last Online
    08-18-2019 @ 08:55 AM
    Location
    Brainerd/Metro, MN
    Posts
    2,965
    Thanks
    25
    Thanked 239 Times in 177 Posts
    Wow! That could be dangerous.

    I didn't see a date on my battery, but it's at least 4 years old, so the death wasn't lamented by any means.

    I didn't have jumper cables, so I pulled it and put it on the charger right away. When it took 2 of the available 6 amps (little charger), I knew the ghost had left.
    BigJim55 and Drifterbike like this.
    5065E MFWD w/553 loader

  11. Top | #8
    TickTock's Avatar
    Join Date
    Sep 2015
    Last Online
    @
    Location
    No longer here
    Posts
    592
    Thanks
    17
    Thanked 50 Times in 42 Posts
    Quote Originally Posted by Jim Timber View Post
    My India battery died last week too!

    Fine one day, back out a couple later and it wouldn't turn the dash on, much less take a charge.

    Went with a deep cycle from Costco.
    Make sure you get a deep cycle that's also rated for starting engines or you might be replacing it again soon.

    EDIT: I should add I tried a deep cycle on an old MF tractor, as that's all I had available. It failed pretty quickly, but that was 30-something years ago. Things have likely changed.
    Last edited by TickTock; 11-15-2016 at 02:00 PM.
    pcabe5, BigJim55 and Jim Timber like this.

  12. Top | #9
    HouseMouse's Avatar
    Join Date
    Aug 2014
    Last Online
    09-28-2019 @ 05:17 AM
    Location
    Witness Protection Program.
    Posts
    967
    Thanks
    6
    Thanked 101 Times in 80 Posts
    Same year tractor here.... Notice the battery was a little sluggish this spring and changed it out. Caught it in time I would guess based on your post.
    pcabe5, BigJim55 and Drifterbike like this.
    2017 Ford F350, 6.7, DRW, 4x4.

    1026R with block heater and Curtis Cab, iMatch, Ken's Bolt on Hooks combo, 54" Front Mount snow blower, 60" MMM, H-120 FEL, Ballast Box, 100Lbs wheel weights, BB2048, sprayer with 7' boom, Front Mount HeavyHitch, John Deere tow behind spreader, 260 Backhoe With BXPanded Thumbs, Bro-Tek 1.5" Spacers.

  13. Top | #10
    jgayman's Avatar
    Join Date
    Jul 2012
    Last Online
    Today @ 09:29 PM
    Location
    Central Pennsylvania
    Posts
    10,087
    Thanks
    371
    Thanked 1,668 Times in 1,263 Posts
    Quote Originally Posted by HouseMouse View Post
    Same year tractor here.... Notice the battery was a little sluggish this spring and changed it out. Caught it in time I would guess based on your post.
    You were very fortunate that the battery exhibited some sluggish behavior. The battery in my 2720 was dated Dec/2011 and it died this summer. Up to that point it never waivered at all. In fact on the day it died it started right up with full energy, I pulled the tractor out of the garage, the tractor sat for about 20-mins and when I went to restart it there was just a big click and that was all she wrote.

    The battery in my old JD 175 Hydro riding mower was 9 years old and always started the engine without hesitation. One day I mowed the yard on a Wed. and on Friday I tried starting the engine and it didn't even click... stone dead.

    With the 2720 battery I was lucky to have my jump box because the tractor was blocking the driveway. I feel much better about dealing with SDBS (Sudden Death Battery Syndrome) since getting the jump box. It saved me with the tractor and saved me once when a brand new battery in the car decided to drop a cell. It even recently saved the neighbor when their car battery decided to go face down.

    Click image for larger version. 

Name:	JNC660.jpg 
Views:	189 
Size:	33.6 KB 
ID:	266793

    So it seems one is very lucky if you get ANY warning at all of battery failure.
    2012 2720 -- 200CX Loader -- 54" Quick Attach Snow Blower -- Frontier LR5060 Rake -- Land Pride RB1660 Blade (Hydraulic Angle) -- Artillian 42" Forks -- Ken's Bolt on Grab Hooks -- Fit Rite Hydraulic top-link -- 2013 X500 for mowing duties

  14. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 4 1 2 3 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •