'09 Silverado - "service Stabilitrack"
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Like Tree38Likes

Thread: '09 Silverado - "service Stabilitrack"

  1. Top | #1
    56Nine's Avatar
    Join Date
    May 2015
    Last Online
    Today @ 08:45 PM
    Location
    Alleman, IA United States
    Posts
    708
    Thanks
    30
    Thanked 212 Times in 116 Posts

    '09 Silverado - "service Stabilitrack"

    The other day this message popped up in the odometer display. I've googled the message, and it's not clear what the culprit is, it appears that some report that with this message the truck goes into the "limp mode", but mine does not. Before contacting someone for repair, I was curious if anyone here has experienced this and what some possible causes could be.
    Darwin
    1025r -> 60D Auto Connect MMM; H120 FEL, 53" bucket, KBOH (3), shackle backer (3), bolt on replaceable cutter; Frontier SB1154; 5' king cutter box blade; king cutter 3pt trailer mover; JD ballast box; 1.25" rear wheel spacers, 40 gallon Fimco sprayer, 52" Ohio Steel lawn sweeper, 3pt King Kutter Poly Fertilizer spreader.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2
    DRobinson's Avatar
    Join Date
    Jan 2011
    Last Online
    Today @ 06:24 PM
    Location
    Northeastern PA
    Posts
    10,653
    Thanks
    2,118
    Thanked 2,324 Times in 1,445 Posts
    Quote Originally Posted by 56Nine View Post
    The other day this message popped up in the odometer display. I've googled the message, and it's not clear what the culprit is, it appears that some report that with this message the truck goes into the "limp mode", but mine does not. Before contacting someone for repair, I was curious if anyone here has experienced this and what some possible causes could be.
    56Nine: I put almost 50,000 miles on my 2009 Silverado, but never saw the service light come on. Isn't it possible to turn it off if you want? That might be one way to check. If the light doesn't come back on after cycling the switch, I wouldn't worry about it. However, I am not a GM technician. I would be interested to know what you find out though.
    Thanks,
    Don
    Gizmo2, BigJim55 and 56Nine like this.
    Don

    2320, 54D MMM, 200CX FEL, 54 Front Blade with Artillian Extensions, Omni Transformer Hitch
    445, 54 mower and 54 front blade
    80 dump cart, 21 walk behind mower

  4. Top | #3
    Zebrafive's Avatar
    Join Date
    Apr 2012
    Last Online
    Today @ 07:15 AM
    Location
    South West Michigan
    Posts
    7,268
    Thanks
    1,533
    Thanked 605 Times in 531 Posts
    It could be multiple things, a single wheel speed sensor failure, steering position sensor, etc. You almost have to have the system read for stored codes.
    Only easy thing to try is disconnect the battery and see if on reconnect the ode is cleared and the service stabilitrack light off.
    glc, DRobinson, BigJim55 and 2 others like this.
    J
    John Deere 2030 w/245SL Loader
    John Deere 6415 w/640SL Loader
    John Deere 285 50" deck Stolen May 2017
    John Deere x485 62" deck AWS
    Kawasaki Mule 2510 4x4 bought new 1996
    Ford F250 4x4 bought new 1978

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    56Nine's Avatar
    Join Date
    May 2015
    Last Online
    Today @ 08:45 PM
    Location
    Alleman, IA United States
    Posts
    708
    Thanks
    30
    Thanked 212 Times in 116 Posts
    Quote Originally Posted by Zebrafive View Post
    It could be multiple things, a single wheel speed sensor failure, steering position sensor, etc. You almost have to have the system read for stored codes.
    Only easy thing to try is disconnect the battery and see if on reconnect the ode is cleared and the service stabilitrack light off.
    That's a good idea, I'll head to O'Reilly's to get the free code read...to see what they say. I'll report back.
    BigJim55 likes this.
    Darwin
    1025r -> 60D Auto Connect MMM; H120 FEL, 53" bucket, KBOH (3), shackle backer (3), bolt on replaceable cutter; Frontier SB1154; 5' king cutter box blade; king cutter 3pt trailer mover; JD ballast box; 1.25" rear wheel spacers, 40 gallon Fimco sprayer, 52" Ohio Steel lawn sweeper, 3pt King Kutter Poly Fertilizer spreader.

  7. Top | #5
    56Nine's Avatar
    Join Date
    May 2015
    Last Online
    Today @ 08:45 PM
    Location
    Alleman, IA United States
    Posts
    708
    Thanks
    30
    Thanked 212 Times in 116 Posts
    Quote Originally Posted by DRobinson View Post
    56Nine: I put almost 50,000 miles on my 2009 Silverado, but never saw the service light come on. Isn't it possible to turn it off if you want? That might be one way to check. If the light doesn't come back on after cycling the switch, I wouldn't worry about it. However, I am not a GM technician. I would be interested to know what you find out though.
    Thanks,
    Don
    Wow, that's not hardly broken in! I have 142K. Overall I am not a fan of the stabilitrack. My understanding is it can be turned off, but generally I like to have things work as they are supposed to, not a fan of yellow dash lights. It seems to reset when I start/stop the truck and this morning it came on about 8 miles down the road. When I find out what's going on, I will report back.
    BigJim55 likes this.
    Darwin
    1025r -> 60D Auto Connect MMM; H120 FEL, 53" bucket, KBOH (3), shackle backer (3), bolt on replaceable cutter; Frontier SB1154; 5' king cutter box blade; king cutter 3pt trailer mover; JD ballast box; 1.25" rear wheel spacers, 40 gallon Fimco sprayer, 52" Ohio Steel lawn sweeper, 3pt King Kutter Poly Fertilizer spreader.

  8. Top | #6
    Zebrafive's Avatar
    Join Date
    Apr 2012
    Last Online
    Today @ 07:15 AM
    Location
    South West Michigan
    Posts
    7,268
    Thanks
    1,533
    Thanked 605 Times in 531 Posts
    Quote Originally Posted by 56Nine View Post
    That's a good idea, I'll head to O'Reilly's to get the free code read...to see what they say. I'll report back.
    I do not think O'Reilly's will be able to pull/read the code(s) Unless they are ABS related and they have an ABS code reader. . You might need to go to GM dealer. Expect to pay for this to be done if a GM dealer has to do it

    Quote Originally Posted by 56Nine View Post
    Wow, that's not hardly broken in! I have 142K. Overall I am not a fan of the stabilitrack. My understanding is it can be turned off, but generally I like to have things work as they are supposed to, not a fan of yellow dash lights. It seems to reset when I start/stop the truck and this morning it came on about 8 miles down the road. When I find out what's going on, I will report back.
    It sounds like a sensor. Computer does a system check and it takes that 8miles, time wise, for it complete all checks and turn on the service light.
    Last edited by Zebrafive; 12-21-2015 at 09:52 AM.
    BigJim55 and tj1 like this.
    J
    John Deere 2030 w/245SL Loader
    John Deere 6415 w/640SL Loader
    John Deere 285 50" deck Stolen May 2017
    John Deere x485 62" deck AWS
    Kawasaki Mule 2510 4x4 bought new 1996
    Ford F250 4x4 bought new 1978

  9. Top | #7
    56Nine's Avatar
    Join Date
    May 2015
    Last Online
    Today @ 08:45 PM
    Location
    Alleman, IA United States
    Posts
    708
    Thanks
    30
    Thanked 212 Times in 116 Posts
    Quote Originally Posted by Zebrafive View Post
    I do not think O'Reilly's will be able to pull/read the code(s) Unless they are ABS related and they have an ABS code reader. . You might need to go to GM dealer. Expect to pay for this to be done if a GM dealer has to do it
    Good to know, I thought a code was "a code".... cheap mode kick'n in.
    DRobinson and BigJim55 like this.
    Darwin
    1025r -> 60D Auto Connect MMM; H120 FEL, 53" bucket, KBOH (3), shackle backer (3), bolt on replaceable cutter; Frontier SB1154; 5' king cutter box blade; king cutter 3pt trailer mover; JD ballast box; 1.25" rear wheel spacers, 40 gallon Fimco sprayer, 52" Ohio Steel lawn sweeper, 3pt King Kutter Poly Fertilizer spreader.

  10. Top | #8
    BigJim55's Avatar
    Join Date
    Nov 2013
    Last Online
    Yesterday @ 10:16 PM
    Location
    Schellsburg, PA
    Posts
    11,237
    Thanks
    3,037
    Thanked 1,404 Times in 1,103 Posts
    I got a 2006 chevy Silverado and when I had trouble with the ABS wheel sensor, I remember that my check engine light came on. took it to garage to find out what was wrong, and I believe it then spit out the code for the left front wheel bearing was bad. I don't remember seeing anything about what ur's is saying--sorry about that. big jim
    56Nine likes this.

  11. Top | #9
    tj1
    tj1 is offline
    tj1's Avatar
    Join Date
    Jan 2015
    Last Online
    Yesterday @ 05:07 PM
    Location
    ma
    Posts
    3,888
    Thanks
    266
    Thanked 305 Times in 228 Posts
    Quote Originally Posted by Zebrafive View Post
    I do not think O'Reilly's will be able to pull/read the code(s) Unless they are ABS related and they have an ABS code reader. . You might need to go to GM dealer. Expect to pay for this to be done if a GM dealer has to do itIt sounds like a sensor. Computer does a system check and it takes that 8miles, time wise, for it complete all checks and turn on the service light.
    You are correct, you would need an ABS code reader to do that. The OBD11 readers only check codes that are engine related or smog stuff, (maybe some tranny issues too).. My wife had a 4X4 09 Silverado off road vehicle and she always had check engine lights, and brake malfunction issues. A brake sensor was an issue with her stabilitrack light. Last year I Had my Hummer H2 all of a sudden light up the stabilitrack malfunction and after driving a few miles it went out. I think my brakes caused the issue because I slid on some snow coming to a stop and the light came on after the pulsing stopped. Cost me nothing! GM dealer will charge you for the read, maybe head to a garage you know will not screw around with you and tell you your vehicle needs this and that.. The wife got a recall about the ABS system and the very next week her ABS went out after the dealer "looked" at it, and deemed it good, $1500 to fix it I don't think so, they did something to make that happen so our garage guy disconnected the ABS by pulling a wire. She never had an issue with her brakes or the malfunction light after that.. Still waiting to see how the class action law suit ends up with the dealership that no longer exists!
    BigJim55 and 56Nine like this.
    Jeff

    X 738 4X4/ 54" mower deck, 47" two stage snow thrower/ linear actuator spout control, Curtis hard side cab/heater, JD roof top LED work lights, Curtis fuse block, rear roof light connected to dash light switch and reverse lights, additional 20amp alternator, Curtis fast Cast 2000 sander custom fitted to tractor/ vibrator for use with dry sand, Kubota L39 TLB, JD 450 E dozer, Husky 18 horse/ 48" mower deck/Berco 42" two stage snow thrower/Berco soft side cab, Kubota RTV500-H.

  12. Top | #10
    coaltrain's Avatar
    Join Date
    May 2014
    Last Online
    Today @ 04:40 PM
    Location
    NW Penna
    Posts
    20,173
    Thanks
    1,094
    Thanked 3,108 Times in 2,271 Posts
    With these newer vehicles (ie computer driven) it really makes no sense to speculate - a trip to the dealer is warranted for proper diagnosis.
    56FordGuy, BigJim55 and 56Nine like this.
    ~Stan~
    It is what it is
    Knowledge is power, ignorance is bliss
    2520 w/200CX w/62D2

  13. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •