5055E Transmission Issues??
Results 1 to 10 of 10
Like Tree3Likes
  • 1 Post By Tx Jim
  • 1 Post By Tx Jim
  • 1 Post By wtg1960

Thread: 5055E Transmission Issues??

  1. Top | #1

    Join Date
    May 2018
    Last Online
    06-08-2018 @ 05:22 AM
    Location
    Georgia
    Posts
    3
    Thanks
    3
    Thanked 0 Times in 0 Posts

    5055E Transmission Issues??

    My tractor is stopping occasionally while driving. The neutral light comes on and tractor stops. Put tractor back in neutral and then back in gear and tractor begins. This happens when stopping and starting (like moving hay bales around). I can drive non stop and this will not happen. I also was having the transmission indicator warning come on but I already changed out the enable pressure sensor on transmission and this corrected this. Tractor is 2 years old and warranty expired. Any others see this issue? I'm thinking another sensor gone bad. Your thoughts?

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Oct 2014
    Last Online
    Today @ 04:20 PM
    Location
    Coyote Flats,Texas
    Posts
    1,769
    Thanks
    15
    Thanked 303 Times in 272 Posts
    Welcome to GTT
    I presume your tractor has power reverser which I think fwd/rev is controlled by relays. I'm guessing your tractor has a faulty relay or bad electrical connection. Electronically controlled hyd functions are great when new & operating correctly but can be a PITA when they malfunction. I like my cable controlled hyd reverser.
    em14 likes this.

  4. Top | #3

    Join Date
    May 2018
    Last Online
    06-08-2018 @ 05:22 AM
    Location
    Georgia
    Posts
    3
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Another question

    Dumb question here but does the 5055e have a separate transmission filter than the main hydraulic filter? Nowhere in the manual can I find if this tractor needs transmission fluid or filter but only refers to the main hydraulic filter and fluid. I've crawled under the tractor but for the life of me I cannot find another filter.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4

    Join Date
    Oct 2014
    Last Online
    12-03-2019 @ 06:34 PM
    Location
    Shenandoah Valley of VA
    Posts
    370
    Thanks
    3
    Thanked 63 Times in 46 Posts
    Quote Originally Posted by wtg1960 View Post
    Dumb question here but does the 5055e have a separate transmission filter than the main hydraulic filter? Nowhere in the manual can I find if this tractor needs transmission fluid or filter but only refers to the main hydraulic filter and fluid. I've crawled under the tractor but for the life of me I cannot find another filter.
    I don't believe that it does. My father's tractor, a 5065e with power reverser, doesn't that I know of.
    The transmission uses Hygaurd hydraulic fluid.
    Romans 1:16 "For I am not ashamed of the gospel of Christ..."

  7. The Following User Says Thank You to hodge For This Useful Post:

    wtg1960 (05-23-2018)

  8. Top | #5

    Join Date
    Oct 2014
    Last Online
    Today @ 04:20 PM
    Location
    Coyote Flats,Texas
    Posts
    1,769
    Thanks
    15
    Thanked 303 Times in 272 Posts
    Ditto hyd & trans sump/filter are the same.
    BigJim55 likes this.

  9. The Following User Says Thank You to Tx Jim For This Useful Post:

    wtg1960 (05-23-2018)

  10. Top | #6

    Join Date
    May 2015
    Last Online
    Yesterday @ 09:07 PM
    Location
    VA
    Posts
    158
    Thanks
    0
    Thanked 20 Times in 19 Posts
    It has a transmission sump screen, 2 bolts and cover by the pto shaft this is where the sight glasses are for hydro fluid level, and a spin on filter element on the rightside by the rear tire. If you remove the sump screen cover you must drain hydro fluid prior to opening cover.
    Last edited by RAM2940; 05-22-2018 at 06:02 PM.

  11. The Following User Says Thank You to RAM2940 For This Useful Post:

    wtg1960 (05-23-2018)

  12. Top | #7
    JROC's Avatar
    Join Date
    Apr 2018
    Last Online
    11-25-2019 @ 07:55 PM
    Location
    South Carolina
    Posts
    116
    Thanks
    4
    Thanked 17 Times in 15 Posts
    Maybe you lost a bunch of weight recently and you have your seat set for too much weight?

  13. Top | #8

    Join Date
    Oct 2014
    Last Online
    12-02-2019 @ 01:15 PM
    Location
    andover maine
    Posts
    159
    Thanks
    52
    Thanked 8 Times in 7 Posts
    is the light n light blinking?I had same issue and i agree it was my seat occupancy switch was out of adjustment

  14. Top | #9

    Join Date
    May 2018
    Last Online
    06-08-2018 @ 05:22 AM
    Location
    Georgia
    Posts
    3
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Rusty View Post
    is the light n light blinking?I had same issue and i agree it was my seat occupancy switch was out of adjustment
    OK- thanks for that info. I haven't lost a lot of weight but I have dropped a few pounds. It could be a bad switch that could possibly cause this. Thanks again.
    johnH123 likes this.

  15. Top | #10
    johnH123's Avatar
    Join Date
    Feb 2015
    Last Online
    12-03-2019 @ 01:49 PM
    Location
    Indiana
    Posts
    4,409
    Thanks
    465
    Thanked 330 Times in 278 Posts
    Maybe just jumper it and see what happens?
    - 2002 John Deere 4510 TLB PR,
    -Woods BB60X 60" rotary cutter
    -Countyline box blade,
    -Allis Chalmers sickle mower,
    -RED windrow rake,
    -titan 48" 3000 pound forks/bale spear
    - Farm Star rear bale spear

    Yamaha Rhino 700, Yamaha Rhino 660,
    Murray 624 mower/38" deck

  16. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •