1020 Electrical Issue with lights
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By jd110

Thread: 1020 Electrical Issue with lights

  1. Top | #1

    Join Date
    Feb 2019
    Last Online
    04-08-2019 @ 12:54 PM
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    1020 Electrical Issue with lights

    I have a 1967 John Deere 1020 Diesel. The lights were functioning fine when I decided to move a new light from the front fender to the rear. I figured it grounded during installation and blew a fuse because now none of the lights work. I talked with my local Deere parts guy. He sold me an AR28493 Circuit Breaker which come to find out was not bad. I can’t see any other fuses on this tractor. Ideas? Could it be the switch itself? Ive not had a chance yet to run a tested for voltage yet. Hopefully that will tell me. I was just hoping someone here would say, oh I had the same issue. Below is a pic of the wiring.Click image for larger version. 

Name:	20190405_140149.jpg 
Views:	3 
Size:	3.12 MB 
ID:	679990Click image for larger version. 

Name:	20190404_124311.jpg 
Views:	1 
Size:	3.97 MB 
ID:	679992Click image for larger version. 

Name:	20190404_124140.jpg 
Views:	4 
Size:	3.67 MB 
ID:	679994

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Jan 2011
    Last Online
    11-09-2019 @ 06:07 AM
    Location
    Maryland
    Posts
    889
    Thanks
    5
    Thanked 315 Times in 240 Posts
    You need to check for voltage at the purple wire on back of light switch. There should be 12 volts there with key on. If not, then the key switch could be bad or the purple wire between key switch and light switch. The light switch is most likely bad if it has 12 volts supplied to it. The circuit breaker in your photo looks nasty, so I would replace it anyway. If it were bad, tractor should not start either.
    Toughsox likes this.

  4. Top | #3
    Zebrafive's Avatar
    Join Date
    Apr 2012
    Last Online
    11-08-2019 @ 09:41 AM
    Location
    South West Michigan
    Posts
    7,329
    Thanks
    1,540
    Thanked 613 Times in 539 Posts
    Also check the connector at the base of the fender. They get brittle with age. On my 2030 the connector fell apart and shorted out the lights.
    J
    John Deere 2030 w/245SL Loader
    John Deere 6415 w/640SL Loader
    John Deere 285 50" deck Stolen May 2017
    John Deere x485 62" deck AWS
    Kawasaki Mule 2510 4x4 bought new 1996
    Ford F250 4x4 bought new 1978

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Similar Threads

  1. 1020 Power Steering Issue
    By A65Thor in forum Agricultural Tractors
    Replies: 17
    Last Post: 01-07-2019, 07:13 AM
  2. 1020 Steering Issue
    By w30bob in forum Restoration
    Replies: 9
    Last Post: 10-08-2016, 08:27 PM
  3. 2210 Electrical Woes (wont start, no lights)
    By fiddelm3742 in forum Sub Compact Utility Tractors (SCUT)
    Replies: 18
    Last Post: 10-11-2013, 09:24 AM
  4. 1020 Hydraulic issue
    By relliott1961 in forum Hydraulics
    Replies: 10
    Last Post: 03-20-2013, 12:51 PM
  5. Lights, strobes and other electrical upgrade power for your CUT
    By Kennyd in forum Sub Compact Utility Tractors (SCUT)
    Replies: 5
    Last Post: 02-23-2011, 07:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •