F911 - Started fine and now wont turn over
Results 1 to 4 of 4
Like Tree3Likes
  • 1 Post By clayh
  • 1 Post By cordel1
  • 1 Post By johnH123

Thread: F911 - Started fine and now wont turn over

  1. Top | #1

    Join Date
    Mar 2016
    Last Online
    10-12-2019 @ 04:15 PM
    Location
    Holland, MI
    Posts
    30
    Thanks
    0
    Thanked 0 Times in 0 Posts

    F911 - Started fine and now wont turn over

    Hey all, I have an F911 that sat all winter. I did start it a few times over the down season, it started typical for not being ran very often. I went to move it the other day to get it closer to tools etc to get ready for mowing and after moving it behind the barn, it won't start again. I do get dash lights, but no cranking at all. I was going to jump start it, but how do you do that when the seat is up to get at the battery?? The seat switch worked normally when it was running, so I am not sure how to even jump start this one?? Any thoughts?? It seems weird that it started, and now nothing.

    Thank you!!

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Dec 2012
    Last Online
    11-04-2019 @ 11:24 AM
    Location
    Calgary AB, Canada
    Posts
    730
    Thanks
    5
    Thanked 54 Times in 52 Posts
    Not sure on the specifices on a F911 but based on my old F932 you should be able to start with the seat up as long as the brake is set and the PTO is off.

    Since the dash lights are on and it doesn't even try to crank I would say you have a wiring issue, possibly a bad switch. Work the PTO switch a times and make sure its off, same with the brake and make sure its set. Do one thing at a time so you can narrow the problem down. If that doesn't resolve it try jumping the starter directly, if it doesn't go then its a starter issue. You can try tapping the starter housing with a hammer to jiggle the brushes.

    If it does go then its a wiring issue, bad safty switch, PTO switch, key switch, starter relay, broken wire.....

    The seat switch is easy to disconnect and jumper to rule it out completely.
    BigJim55 likes this.
    F932-gas with 72" mower deck(sold)
    2720-72" mower deck with hydraulic lift, 3 valve rear SCV, loader, bucket, forks, 84" RFM, blade, 74" snow blower, box blade, land grader........
    2305- sold
    Z915B

  4. Top | #3

    Join Date
    Mar 2016
    Last Online
    10-12-2019 @ 04:15 PM
    Location
    Holland, MI
    Posts
    30
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hey all, I think my issue was a very corroded positive cable. I replaced it and now it seems to work normally. Part of my issue was the parking brake / key switch. The brake was in the wrong position, allowing it to start but die when I tried to move. Thanks all for looking!!! Enjoy the Memorial weekend!!
    Tomfive likes this.

  5. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  6. Top | #4
    johnH123's Avatar
    Join Date
    Feb 2015
    Last Online
    Yesterday @ 08:55 PM
    Location
    Indiana
    Posts
    4,405
    Thanks
    464
    Thanked 329 Times in 277 Posts
    Definitely clean the terminals.
    BigJim55 likes this.
    - 2002 John Deere 4510 TLB PR,
    -Woods BB60X 60" rotary cutter
    -Countyline box blade,
    -Allis Chalmers sickle mower,
    -RED windrow rake,
    -titan 48" 3000 pound forks/bale spear
    - Farm Star rear bale spear

    Yamaha Rhino 700, Yamaha Rhino 660,
    Murray 624 mower/38" deck

  7. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •