JD F911 front mower blows 25 amp fuse when engaging deck
Results 1 to 2 of 2

Thread: JD F911 front mower blows 25 amp fuse when engaging deck

  1. Top | #1

    Join Date
    Jul 2018
    Last Online
    07-14-2018 @ 07:09 PM
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cool JD F911 front mower blows 25 amp fuse when engaging deck

    Hi Guys: I have a JD F911 front mow. It has new battery, new voltage rectifier regulator because it was sending 24.7 volts to battery, wrecked the battery. So got those replaced. Now its pushing 14.4volts to battery when 1/4 to full throttle. So that part is fixed. However, when I go engage the electric PTO for mower deck, it blows the 25 amp fuse (center fuse on that row of 3 fuses behind the seat). I have electric clutch harness unplugged to rule out the electric clutch. It still blows the fuse. When I move the electric clutch switch to first position of engagement, it does not blow the fuse. Its when I press the yellow PTO switch to 2nd level that fuse blows. I have already replaced the PTO brake release solenoid thinking that was the problem.

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Jun 2013
    Last Online
    Today @ 06:15 PM
    Location
    Southern Maine
    Posts
    7,838
    Thanks
    624
    Thanked 742 Times in 629 Posts

    JD F911 front mower blows 25 amp fuse when engaging deck

    Check your pto resistance. I bet it’s low.

    Edit: My bad for not reading all the way through. There is the pto switch electricals and dead shorts to look for.
    Last edited by rydplrs; 07-14-2018 at 07:15 PM.

  4. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •