Green Tractor Talk banner

h120

  1. 1025r SCV Strain when Moved with Loader Detached?

    Sub Compact Utility Tractors (SCUT)
    Hello all! I have been enjoying reading GTT for a while but this is my first post. I am hoping someone here will be able to help me refresh my memory. I have a 1025r with 18 hrs on it. Recently I have noticed that the SCV lever will strain when moved without the loader attached. Prior to the...
  2. JDQA to 3pt Quick Hith for H120

    Implements & Attachments
    Just get back from welder and pick up my project. TEST IT OUT ON ALL MY 3pt attachments. So far so good. Still need some grinding but I know it will fit. Thanking about to get the quick hitch with H120 but there is nothing in the market like it. I know Artillian frame could have 3pt quick hitch...
  3. Dolly for H120 FEL

    Implements & Attachments
    I decided I needed a dolly to store my FEL. Space in my garage is limited and I sometimes have to move things around just to have room to work. Without a dolly, this requires the tractor every time. This fills the garage with diesel fumes and requires taking off other front-end implements to...
  4. h120 hydraulic problem

    Implements & Attachments
    I had pallet forks attached to my h120 loader. I was pushing brush with the forks in the down position. The strain broke the black hydraulic hose. Replaced hose and bucket will not tilt up when I move the control to the left. If you very carefully nudge the control to the left, you can get...
  5. JD 1025R with H120 Loader lift capacity and proper rear ballast

    Sub Compact Utility Tractors (SCUT)
    I just ordered a 1025r with an H120 loader and 60" MM deck from my local JD dealer along with a Land Pride BB1254 box blade, and it's supposed to be ready for pickup later this week. I can't wait to start using it! I'm going to be using it for multiple purposes to include mowing, hauling...
  6. Not able to connect 2 of my 4 hydraulic lines on 1026R/H120 FEL

    Hydraulics
    Just went to move my H120 FEL outside today to install Kenny's hooks on the bucket and I am not able to hook up the black and yellow quick connects. I push as hard as I can, but I cannot get the ring on the female portion of the connection to snap in place. I think I've isolated the problem...
Top