Green Tractor Talk banner

pto problems

  1. Agricultural Tractors
    I have a 4230 quad range that I recently put a new main hydraulic pump and transmission pump in and it seemed to be working good. Now only about 100 hours later it doesn't have nearly as much flow as before and when I use the PTO and shift between the high low it shuts off. It still has 2300psi...
  2. Sub Compact Utility Tractors (SCUT)
    Would like some help and reassurance I'm doing the right thing. Scenario is this, Cutting grass with MMM and PTO cuts off. Check temps, retry PTO switch, nothing. Move tractor to driveway, check GTT and get some ideas. Go back, jiggle wires, tap solenoid, and now it blows the 10A fuse. Dash...
  3. Lawn & Garden Tractors
    I've got a LA140 and it's about 10 years old and the PTO clutch broke free of the mounts and spun the wiring Harnass all up. I replaced the PTO and the wiring Harnass and the 20 amp fuse it blew and still nothing. Could I also need the main engagement switch to be replaced...what else could...
  4. Lawn & Garden Tractors
    My name is Paul I live in upstate NY. I have a John Deere x300 and it doesn't work First of all let me say I know what a wrench is but obviously I am not a bonafide mechanic. As I said I have a JD x300 42" mower w/100 hrs that I have been using right along with no issues at all. Last cut was 2...
  5. Utility Tractors
    I am BRAND NEW to this forum, but joined here looking for a good resource to help me with my tractor. I bought a brand new 5085E Cab tractor 2 months ago today. I love everything about it, but I'm having two issues with it. The first is the check engine light coming on. The tech visiting...
Top