Green Tractor Talk banner

starting

  1. 420 electrical issues

    Vintage Lawn & Garden Tractors
    Hi all, I'm currently having an an issue on a JD 420 where the tractor will either show no response at all to the ignition key being turned, make a single click, or start after making atypical grinding noise and run until the parking brake is released ( so 10 seconds or so ). The tractor is...
  2. SRX75 not starting

    Lawn & Garden Tractors
    Hello all! I am new to the forum and wanted to pose a question about the 1995 SRX75 that I just inherited. This is my first John Deere mower so I am a little unfamiliar with it. It has a 9 HP Kawasaki FC290V-FS10 motor. I am having trouble getting it to start and stay running: it is a...
  3. 1025 electrical issue

    Sub Compact Utility Tractors (SCUT)
    Had the 1025 for a couple years without issues. Used it all winter, went to start it this morning and seems to be some sort of electrical issue. Disconnected and reconnected the battery without help. Any thoughts, checked battery reads ok via voltmeter, and all the fuses seem fine. Thanks
  4. Problems starting and poor power - any suggestions?

    Vintage Lawn & Garden Tractors
    I know there are a 1001 posts about similar subjects, but I'm having a bit of a hard time sifting through everything to find something that makes sense. I have an '86 JD 318 (onan) with a B43G engine. I have no idea how many hours are on it, as it has no hour meter. Over the last few...
  5. Plugging in Tractor

    General Tractor Operation and Ownership
    So my tractor stays under a carport type roof. I live in Maine so it gets cold, ok lets be honest deathly cold, so I was wondering if I need to plug in my tractor when it's below zero. I run the non gel additive and I have started the tractor outside at 20 below without plugging it in, but it...
  6. 2520 stalling, cranking, hard to start, then fine.

    Medium Frame Compact Utility Tractors (MCUT)
    Hello all, new user here. Maybe someone out there can help me. My 2010 2520 that I bought new and has been regularly serviced, (has 130 hrs now), is having problems. Started about a week ago when i started it up and it stalled before i could even move it. Was fine for a few days after that. Did...
Top