Green Tractor Talk banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
I purchased a 1023e on 4/08. I took delivery on 3 days later on the 11th because of a “solenoid recall” on the 3ph. On Saturday 4/13 I removed the FEL to cut grass. After I detached the FEL I get back on the Tractor and start the mmm. The dash goes haywire. The rmp meter goes to 0 and it says it is overheating. I only ran it for 5 minutes tops. .4 hrs on it at this point. I figured it to be an electrical problem after I could almost keep my hand on the engine and every time I turn the key to the on position it said overheated. I disconnect the battery and everything went back to normal. Everything seemed to be fine at this point to I cut my grass and parked it in my garage that night. Monday I enter my garage to find a nice pool of hydraulic fluid on my floor under the rear of the tractor. Emailed the dealer and they came to pick up on Tuesday. I call Thursday and they tell me that it was a torn o ring on the neutral star causing the leak. The dash went crazy because a clip had come off the back of the dash and had to be replaced. The tractor was returned to me on Friday 4/19. I notice a big paint chip on the brush guard and the yellow hydraulic cap for the FEL was cut. Said they would send someone to fix it.

I didn’t touch the tractor again until 4/27 when I cut my grass again and used the FEL. Parked it that night and enter the garage on Monday 4/29 to see a small spot of coolant on the floor. The overflow was normal for a cold engine. I look under the tractor to see it is leaking coolant onto the axle from up above. I could not find the source. I take the radiator cap off to check the fluid level there and coolant bubbled out and ran everywhere. I hadn’t started the engine in days so that seemed odd to me. The dealer picked the tractor up on Tuesday 4/30. Wednesday I was told they could not find a leak and they would run the tractor to see if they could replicate the problem but all tractors push coolant out when you remove the cap(that’s ok by me, but mine was leaking from somewhere before I ever removed the cap). Monday 5/6 they contact me stating they could not find a problem and would fix the torn cap and paint the brush guard and have it back to me Wednesday. It is Friday 5/10 and they claim they will have it to me today. We’ll see.

Sorry this is so lengthy but I wanted to get advice on how someone else would handle this situation. Does it sound like I am being screwed around? When you pay 14k you don’t expect these kinds of problems. Oh, I just had to make my first payment yesterday and I feel like they have had the tractor more than me! The last two of the attached images are from the coolant leak I mentioned.
 

Attachments

·
Administrator
Joined
·
20,906 Posts
Welcome to GTT!

Sorry to hear about your troubles. :thumbsdown: But I do have a few notes for you.

My 1026R's coolant overflow bottle's cap leaked. As I mowed the grass, it tended to spill a little coolant here and there. Nothing major, but it should be covered under warranty. Don't know if that's the source of your coolant, but it's worth a look see.

Your yellow cap got bit by the mower belt as mine did. That's just something you'll have to keep an eye on to prevent that. I wrapped the caps around the lines to prevent them from drooping to low. Unfortunately there isn't a good fix for that. That's the price we have to pay to get so much tractor in such a small package. The loader QD's are close to the mower and the ground allowing the caps to get entangled if you don't pay attention to them getting them up out of harm's way.

It is very frustrating having a new machine in the shop just after you got it. Hang in there though. I'm certain you'll have fun and love it once you get to put some hours on the clock.:thumbup1gif:
 
1 - 2 of 2 Posts
Top