Green Tractor Talk banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Wondering if anyone else has seen this problem on their 1025R and the new 54D mower decks. I purchased the load and go brackets with the mower because they sounded handy. At first sight they appeared great but once I started the tractor more I found the load and go bracket was hitting the hydraulic quick connect fittings when deck was raised. This causes the hydraulic to disconnect as the the deck jostles around. It happens every time and basically makes the front loader useless with the deck attached. Anyone else seen this or did I just install mine incorrectly?
 

·
Registered
Joined
·
231 Posts
Several other people have this issue. Check out this thread on the topic...


I recently took delivery of a 1025R. I was originally planning on going with the 54D with the LNG brackets, but the dealer set it up and the brackets were too close to the hydraulic ports for my liking, although they were not touching. I ended up going with the 60D as the LNG brackets are offset from the hydraulics with the larger deck.

The linked thread should have plenty of information.
 

·
Registered
3046R, 320R loader, 375A BH, 72D MMM, 4406H BB, County Line Landscape Rake, Fimco 40gal 3pt sprayer
Joined
·
133 Posts
This has been a pretty common problem across several of the deck/tractor combinations with the LnG. Several of us with 3Rs and 72" decks have had to trim them down because the left bracket hits the bottom of the step brace under the cab. Seems like JD either didn't R&D them very well or set them up for clearances that are too tight and may change depending on options.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top