Green Tractor Talk banner

1 - 11 of 11 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hello everyone. I have had an issue with my tractor over the last few days. It loses power intermittently especially when the pto is engaged. It will rev up and down in a dramatic fashion. Today before I began to mow I had trouble starting the 1025r. It finally started but ran terribly. Before starting it I changed the fuel filter due to the fact I think I may have gotten some bad fuel a few weeks back. However the tractor did not run well after a few minutes of just letting it idle and giving it throttle from time to time. I let it set for 20-30 minutes to run. However it began to shake terribly at one point hard enough to break a strap that I think goes around a part of the motor.

Any ideas what in the world could be wrong? I am afraid I am looking at major $$$ in repairs. Any ideas would be greatly appreciated.

Thanks everyone.
 

·
Registered
Joined
·
375 Posts
The strap may be for the air cleaner. Read the two sticky posts about the air cleaner. Hopefully your intake cover didn’t break and suck pieces into the engine. I suspect it’s fuel related (drain fuel, replace filters) but a hole in your intake cover would certainly cause issues.
 

·
Registered
Joined
·
1,377 Posts
Don't those tractors have that pesky little fuel filter under the floorboard??

Did you change that one too?

:munch:
 

·
Registered
Joined
·
2,022 Posts
There are two fuel filters, one in a sediment bowl looking arrangement mounted on the engine block and the other under the left foot board. Which did you change?
 

·
Registered
Joined
·
1,973 Posts
Your complete profile with location tractor model and year and any attachments may also help us determine how best to help you.

Example-you May still be under powertrain warranty, so it might cost you very little.
 

·
Premium Member
Joined
·
1,129 Posts
As above posters said , check your valve cover , ensure you didn't kink or otherwise inhibit fuel delivery . I am assuming you check fuel level ? Good luck and keep us posted with resolution . :kidw_truck_smiley:
 

·
Registered
Joined
·
2,055 Posts
Either you changed the fuel/water separator ( the one you can see on the right side of the tractor with the clear plastic showing the fuel in it), or the one under the floorboard (in-line filter), or both. Can you tell us if you did both?
 

·
Registered
Joined
·
2,776 Posts
If you have bad fuel you may need to change out the filters a few times. There may even be a pickup screen in the fuel tank that could be plugged. Not sure if that applies to your tractor :dunno:. The tank may need to be flushed out.
 

·
Registered
Joined
·
1,377 Posts
I only changed the one filter on the motor. I will change the other and advise. Thanks everyone. I was not aware there were 2.


Bingo

replace & report please

Hopefully that will fix it

:munch:
 
1 - 11 of 11 Posts
Top