Green Tractor Talk banner

1 - 20 of 25 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
Had trouble auto connecting to my 60" deck today and found the pto coupler pointed about 45 degrees up. Couldn't figure out why and then decided to disassemble the whole thing and found the pto shaft only is moving a little over an inch out of the shaft. No way it will ever drop enough with that little play. Seems like the top of the shaft has some peening preventing it from moving further out.


Will take to dealer tomorrow but was wondering if anyone else had this issue and if its an easy "fix" or if they should just replace the whole thing






 

·
Registered
Joined
·
524 Posts
Had trouble auto connecting to my 60" deck today and found the pto coupler pointed about 45 degrees up. Couldn't figure out why and then decided to disassemble the whole thing and found the pto shaft only is moving a little over an inch out of the shaft. No way it will ever drop enough with that little play. Seems like the top of the shaft has some peening preventing it from moving further out.


Will take to dealer tomorrow but was wondering if anyone else had this issue and if its an easy "fix" or if they should just replace the whole thing






So you can't get the small part out of the main driveline? It doesn't slide but an inch or so?


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
524 Posts
Yep. But that doesn't cut my grass today

Will bring it over to the dealer in the morning.
Yea I hear you!! Well they will try to take it apart if they can't they will probably warranty a new one. Sorry I wasn't any help buddy!!


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
4,468 Posts
Sorry, no help here, but how much is it supposed to slide out? :dunno:
 

·
Registered
Joined
·
524 Posts
I believe they come completely apart. Can't remember been awhile since I've set up or worked in that area of one.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
349 Posts
Hi All
Also the Grease nipple (i think you call it a zerk) looks to be sealed with black paint, the shaft does not seem to have much grease on it and it is showing signs of lack of lubrication ( the scuffing on the exposed part of the square drive) I would try greasing it to see if the the zerk is working and see if that frees it up.
Regards John
 

·
Registered
Joined
·
1,379 Posts
Up to you but you could try taking off the grease zerk and spray some Wd-40 or knock it loose if you have any and see if that will loosen it up. The spray breaks down the grease. It looks like it is dry from the little bit that is showing. Also is that the original zerk on the shaft? Sounds crazy but if it's too long and screwed in to far it could be catching and not letting it slide in or out? Just throwing in my 2 cents. Good luck and if it's still under warranty I would take it to dealer and say fix it... :)
 
  • Like
Reactions: PJR832

·
Registered
Joined
·
747 Posts
Tug hard.... It will free up, then grease it up! I don't know why the shafts jamb like that, but mine did once. I doubt it's "broken" just stuck...

DSCF7152.JPG

DSCF7151.JPG
 

·
Administrator
Joined
·
20,849 Posts
I believe the set screw captures the inner shaft and prevents it from separating.
 

·
Corndog Hater
Joined
·
11,773 Posts
I think DS is right. The set screw on mine loosened up and the shaft would come apart every time I dropped the MMM (mine is non auto connect FWIW). I did notice the other day that the zerk on the shaft fell out of mine, anybody have any idea what size it is?
 

·
Registered
Joined
·
1,339 Posts
Is this just some gunk or is the metal deformed? If the latter, then that explains why it won't come out.

pto shaft.jpg
 
1 - 20 of 25 Posts
Top