Green Tractor Talk banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 1025r tractor and I installed a 4 ft rake on the 3 point hitch and I cant raze or lower it. I move the side control handle and it doesn't do anything. I changed the hydraulic fluids and the filter also cleaned the wire screen. what can my problem be? Can anybody help me?
 

·
Registered
Joined
·
2,958 Posts
It is a shot in the dark, but I'll offer a suggestion.
This tractor has rear positioning control.
There is linkage (I believe attached to the hand control) that gives feedback to the valve.
You move the hand control and the hitch moves until it feels the linkage feedback point.
It may be that something is disconnected or too tight with the linkage, such as jammed in the full down position, and the valve thinks position is satisfied.

Is this a unit with a backhoe and power beyond valve? Maybe if so, the coupling between the hose and valve is not seating?

Good luck and try and post a resolution when you discover the problem.
 

·
Registered
Joined
·
2,410 Posts

·
Registered
Joined
·
3,399 Posts
I have a 1025r tractor and I installed a 4 ft rake on the 3 point hitch and I cant raze or lower it. I move the side control handle and it doesn't do anything. I changed the hydraulic fluids and the filter also cleaned the wire screen. what can my problem be? Can anybody help me?
Not positive, but I think the handle is loose. The following link addresses the issue including a YouTube video.:dunno:

1025r Broken 3pt control
 

·
Registered
Joined
·
1 Posts
Drop/Lock Rate Valve Knob

Is your Drop/Lock Rate Valve Knob locked? I did that when I first staring using my tractor!

Lock 3-Point Hitch: Rotate drop/lock rate valve knob clockwise until tight.
Unlock 3-Point Hitch: Rotate drop/lock rate knob counter-clockwise.


 

·
Registered
Joined
·
732 Posts
If you just changed the fluids, operate the bucket a few times, and run the pto, you might just have an air lock.
 

·
Registered
Joined
·
23,002 Posts
First thing to do is remove the rake and see if the arms will move up and down without any implement attached. Then start troubleshooting form there.

It’s a remote possibility but you could have the sway bar links too tight which won’t allow the hitch to move.
 
1 - 7 of 7 Posts
Top