Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hello,

I recently replaced my bucket cylinder and once I got it back up and running. I noticed that only the one function of lowering the bucket was very slow. I cleaned and inspected all of the quick disconnects and even changed the male end (black hose) and no improvement....?! All other functions with the bucket are good. Any advice would be very helpful.

Thank you!!!


P.S.

I will follow up with my other post and post some
 

·
Super Moderator
Joined
·
5,427 Posts
What happens if you swap the up/down hoses with the curl hoses at your SCV? Does the problem stay the same or does the problem move to the curl function?
 

·
Registered
Joined
·
1,048 Posts
Jsin, Not 100% sure on this, but you may (??) have an orifice in loader hose. This is simply a disc with a small hole in it. Lower arms to ground & disconnect couplers for raise/lower arms. Remove disconnect connector and any fittings attached to hose. You should find the orifice, item 15 below. Bob
758311
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
Rwmeyer,

Thank you!! I will take a look later today. Can that orifice just be removed or does it need to be replaced..?

Jsin
 

·
Registered
Joined
·
1,048 Posts
Jsin, Orifice, E40500, shows available from a JDdealer for $29.58, so you may be able to drill your existing one out a little larger, and if it suddenly drops too fast for your, you can put a new one back in after drilling it to a smaller size.

After removing the original orifice, you may (??) find a plain flat washer will also work, don't know. Bob
 
1 - 6 of 6 Posts
Top