Green Tractor Talk banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Just purchased this machine and used it to cut grass for about an hour, it ran great but I wanted to adjust the deck, so I took the deck off to sharpen blades, etc, also had the rear seat, gas tank and plastics off to get at deck adjustment spring. Started tractor to make my adjustment by lifting deck up and down it all worked great, went to put deck back on and thought before I put all the plastics and seat back on I would start it to make sure its working properly. Well it just cranks but won't fire. I have spark, I bypassed seat switch, I don't believe my tractor has the time delay module switch that I've been reading about. Is there any other switch that I may have moved that would prevent it from firing or has anyone else experienced this problem.
 

·
Registered
Joined
·
13,747 Posts
Just purchased this machine and used it to cut grass for about an hour, it ran great but I wanted to adjust the deck, so I took the deck off to sharpen blades, etc, also had the rear seat, gas tank and plastics off to get at deck adjustment spring. Started tractor to make my adjustment by lifting deck up and down it all worked great, went to put deck back on and thought before I put all the plastics and seat back on I would start it to make sure its working properly. Well it just cranks but won't fire. I have spark, I bypassed seat switch, I don't believe my tractor has the time delay module switch that I've been reading about. Is there any other switch that I may have moved that would prevent it from firing or has anyone else experienced this problem.
sounds like maybe with u having the tank off and back on, maybe their was some dirt in the tank that got swished around in the bottom of it, did it run after u put it on,, maybe it had just enough gas for it to start, did u look at the gas filter? u said u have spark-right check for gas now and see where that takes u-good luck.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
sounds like maybe with u having the tank off and back on, maybe their was some dirt in the tank that got swished around in the bottom of it, did it run after u put it on,, maybe it had just enough gas for it to start, did u look at the gas filter? u said u have spark-right check for gas now and see where that takes u-good luck.
no, checked that, its all good, someone else said that might be a stripped camshaft? as apparently it was a plastic shaft in that year, what do you think? That's a big tear down.
 

·
Registered
Joined
·
575 Posts
Just purchased this machine and used it to cut grass for about an hour, it ran great but I wanted to adjust the deck, so I took the deck off to sharpen blades, etc, also had the rear seat, gas tank and plastics off to get at deck adjustment spring. Started tractor to make my adjustment by lifting deck up and down it all worked great, went to put deck back on and thought before I put all the plastics and seat back on I would start it to make sure its working properly. Well it just cranks but won't fire. I have spark, I bypassed seat switch, I don't believe my tractor has the time delay module switch that I've been reading about. Is there any other switch that I may have moved that would prevent it from firing or has anyone else experienced this problem.

I get from reading your post you removed the gas tank. Correct? Now, when you did this, did you remove the hose(s) two of them from the tank. And when you reinstalled the hoses, did you put them back on the same "fittings" as they where? If not, you won't get any fuel to the carburetor. Trace the hose from the gas filter back to the gas tank and see if the hose is connected to the fitting that has the long plastic pickup tube.

If you have a 345, you have a TDM on the left side of the engine right near the starter. It may be a black round or a flat one.
 

·
Registered
Joined
·
248 Posts
The 1995-1998 345 (FD590V motor) did NOT have a TDM... only the 1999 and newer models with the 20hp FD611V motor had that.
Yes the FD590V had a plastic cam gear from the factory but the replacement gear is made of steel. You can check by taking a valve cover off and turn it over. If the rocker arms don't move that means the cam gear is the issue.

A lot of 320 and 345 owners myself included have done the steel cam gear just so we don't have to worry about it. Peace of mind.
Its not near as big of a deal as it sounds but you do have to pull the motor out. I pulled mine out and had my friend who is a mechanic put the new parts in the motor then I put the motor back in myself. Saved a LOT on labor that way. These motors are very much worth saving and will run for several thousands of hours.

Did you check all the basics? are you getting fuel and spark?
 

·
Premium Member
Joined
·
10,091 Posts
When the plastic gear lost teeth on my JD285, It sounded different when it was turning/cranking. It was like the starter was not working as hard, engine spinning faster.
 
  • Like
Reactions: BigJim55
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top