Green Tractor Talk banner

1 - 8 of 8 Posts

·
Registered
Joined
·
716 Posts
Discussion Starter #1
I was using my tractor yesterday and suddenly my control pedals would only engage a small amount. The tractor would move, but only at a very slow speed. I immediately thought I had jammed something into the linkage. It took me a few minutes to figure out that the problem was with the brake linkage. The arm (#29 in the drawing) had slipped off of the pivot pin. Clearly I lost the retaining clip #27 and spacer #28 (which looks in the drawing to be more or less a washer. I can't fathom what would cause this to fall off. I slid the arm back on the pin and finished the job. It did not come off again. I thought this was very odd.

The parts appear to be very cheap, but not available at my local dealer. Clearly I want to fix this, but am wondering if I should just find an off the shelf retaining clip and washer. Any thoughts on the original issue or how critical it is to replace with the OEM part?

Lee

MP41347________UN08JUL08.jpg
 

·
Administrator
Joined
·
17,272 Posts
Those "E" clips are available at lots of places Lee, I probably have some in the shop. I wouldn't worry about OEM parts there, just be sure to get the correct size.
 

·
Registered
Joined
·
291 Posts
Or do it the old fashioned way and use a cotter pin of the correct size and a washer.
 

·
Senior GTT Super Slacker
Joined
·
36,069 Posts
The parts appear to be very cheap, but not available at my local dealer. Clearly I want to fix this, but am wondering if I should just find an off the shelf retaining clip and washer. Any thoughts on the original issue or how critical it is to replace with the OEM part?

Lee
Use off the shelf items and it you are not comfortable with the end result, order the parts.
 

·
Registered
Joined
·
716 Posts
Discussion Starter #6
thanks guys. I need to get a measurement and go shopping. I suspect that the "spacer" AKA washer could be more difficult to find than the e-clip. It would be nice if I could find it in the yard, but I have no clue when it fell off. Based on how well the arm stayed put without the clip, it could have been gone for some time. I think that the only reason it popped off is because I jammed a stick up into the linkage. I consider myself lucky that it did not do in the fan. If I was doing this kind of work more often, I would definitely need to install a shield for that fan.

Lee
 

·
Administrator
Joined
·
17,272 Posts
Lee, if you need a special spacer just get me some measurements and I'll make you one.
 
1 - 8 of 8 Posts
Top