Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Newbie here, taking advantage of the forum's resources trying to resolve a charging problem on my tractor. Initially, thought the problem was going to be straightforward after removing the voltage regulator and finding the DC out positive voltage lead separated from the regulator body with burnt insulation thrown in there for good measure. Checked continuity thru the harness back to the V+ battery post and it was good. Replaced the regulator (eBAY, US seller)..and....no joy.

Started checking every diode I could find, replaced the 2 identical safety relays, grounding checks..and still the idiot light continued to mock me. Thinking I may have a high resistance short in the charging circuit that was providing a sneak path somewhere, I was checking continuity once more from the battery to the regulator when I noticed the white wire in the wire harness' mating connector to the voltage regulator seemed to be loose. Since this is what feeds the regulator's output back to the battery for charging, it got my attention. Gave it a gentle tug and out it came. DUH! Removed the DC out positive voltage lead from the regulator's connector and jumpered it to the harness' white wire and...voila....success.

The schematic I found on this site was invaluable. Thanks for the help!!
 

·
Administrator
Joined
·
18,291 Posts
:wgtt:

Thanks for the info!
 

·
Registered
Joined
·
1,106 Posts
Electrical issues are always tough to find. It sounds like you had a tough find on this one, not to mention the persistence and the help from here you found the issue. oh and welcome aboard.
 

·
Premium Member
Joined
·
6,593 Posts
:thumbup1gif::thumbup1gif:

Thank you for the great post! We can always use a good electrician around here.

Welcome to GTT.
 

·
Senior GTT Super Slacker
Joined
·
37,800 Posts
Thanks for the post leroysch and welcome to GTT.
 
1 - 5 of 5 Posts
Top